Bug 39715 - Some embedded mathematical formulae MathType Equation not imported properly from old PPT from 2003 (OK if PPT resaved in MSO)
Summary: Some embedded mathematical formulae MathType Equation not imported properly f...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PPT
  Show dependency treegraph
 
Reported: 2011-08-01 05:52 UTC by Tobias Burnus
Modified: 2018-11-27 13:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot comparing MS PowerPoint 2010 with LibreOffice 3.6 (45.71 KB, image/png)
2012-08-14 14:56 UTC, Tobias Burnus
Details
Screenshot page 2 LO 3.6 MS 2010 (88.54 KB, image/png)
2012-08-15 17:16 UTC, Florian Reisinger
Details
Screenshot page 3 LO 5.2+ vs. MSO 2013 (157.20 KB, image/png)
2016-04-05 16:08 UTC, Timur
Details
Screenshot page 3 LO 5.2+ vs. MSO 2013 with PPT re-saved in MSO (176.77 KB, image/png)
2016-04-05 16:29 UTC, Timur
Details
Original PPT (3.26 MB, application/x-ole-storage)
2016-04-05 16:35 UTC, Timur
Details
Original PPT re-saved as PPT with MSO 2013 (3.18 MB, application/x-ole-storage)
2016-04-05 16:36 UTC, Timur
Details
PPT reduced to 2 pages and saved as PPT in MSO 2016 (120.50 KB, application/wps-office.ppt)
2018-11-27 13:20 UTC, Timur
Details
PPT reduced to 2 pages and saved in MSO 2016 compared with LO (126.19 KB, image/jpeg)
2018-11-27 13:21 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2011-08-01 05:52:01 UTC
Opening the PPT file
  http://openoffice.org/bugzilla/attachment.cgi?id=5827
all formulas are missing when I import. (PPT created with PowerPoint under MacOS.)

The issue was initially reported against OO 1.0.1, but is also present in LO 3.3.3.

See original OO report:
http://openoffice.org/bugzilla/show_bug.cgi?id=13339
Comment 1 Björn Michaelsen 2011-12-23 12:23:43 UTC Comment hidden (obsolete)
Comment 2 Florian Reisinger 2012-08-14 13:59:33 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 14:00:44 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:05:27 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:07:28 UTC Comment hidden (obsolete)
Comment 6 Tobias Burnus 2012-08-14 14:56:37 UTC
Created attachment 65552 [details]
Screenshot comparing MS PowerPoint 2010 with LibreOffice 3.6

With LibreOffice 3.6.0.4:

There is a large improvement:
 * Replacement WMF are rendered
 * Double clicking on the equations opens them in LO's equation editor

However, there are still some issues:
 * The replacement image is rendered oddly, e.g. page 11: The vector arrows are renders as "r".
 * Double clicking on the some equations leads to garbage, e.g. the one one slide 15.

See attached screen shot - left MS PowerPoint 2010, right LO 3.6.


Test case:
  https://issues.apache.org/ooo/attachment.cgi?id=5827 (PPT file)

Original OOo bug report:
  https://issues.apache.org/ooo/show_bug.cgi?id=13339
Comment 7 Florian Reisinger 2012-08-15 17:16:06 UTC
Created attachment 65606 [details]
Screenshot page 2 LO 3.6 MS 2010

Okay, formula unuseable
Comment 8 Florian Reisinger 2012-08-15 17:17:20 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2015-01-05 17:52:06 UTC Comment hidden (obsolete)
Comment 10 Buovjaga 2015-01-28 12:48:24 UTC
Still the bad result.

.ppt now here: https://issues.apache.org/ooo/attachment.cgi?id=5827
Original report: https://issues.apache.org/ooo/show_bug.cgi?id=13339

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36
Comment 11 QA Administrators 2016-02-21 08:37:04 UTC Comment hidden (obsolete)
Comment 12 Timur 2016-04-05 16:08:32 UTC
Created attachment 124098 [details]
Screenshot page 3 LO 5.2+ vs. MSO 2013

Still similar to comment 7.
Comment 13 Timur 2016-04-05 16:29:38 UTC
Created attachment 124099 [details]
Screenshot page 3 LO 5.2+ vs. MSO 2013 with PPT re-saved in MSO

But, this screen shot shows that LO reads file properly if re-saved in MSO. 
It's not probable this will ever be fixed. 
So, I recommend this be closed as WontFix.
Comment 14 Timur 2016-04-05 16:35:41 UTC
Created attachment 124100 [details]
Original PPT
Comment 15 Timur 2016-04-05 16:36:28 UTC
Created attachment 124101 [details]
Original PPT re-saved as PPT with MSO 2013
Comment 16 QA Administrators 2017-05-22 13:19:12 UTC Comment hidden (obsolete)
Comment 17 Tobias Burnus 2017-05-22 13:39:24 UTC
Tested with 5.3.2.2:

The vectors on page 14 are still wrongly rendered ('r' instead of an arrow over the symbols. That's attachment 124100 [details], which has been created by Microsoft Office on a Macintosh quite a while back.

They are correctly rendered in MSO 2013/Windows. As Timur mentions, opening the old file in MSO 2013 (on Windows?) and re-saving it as PPT produces a PPT file where Libreoffice correctly renders the arrows.

(Side note: The rendering of the math formulas in LO 5.3 looks rather ugly with gaps between the parenthesis segments and bad spacings.)
Comment 18 QA Administrators 2018-05-23 02:36:12 UTC Comment hidden (obsolete)
Comment 19 Timur 2018-11-27 13:20:21 UTC
Created attachment 147065 [details]
PPT reduced to 2 pages and saved as PPT in MSO 2016

Original PPT reduced to 2 pages and saved as PPT in MSO 2016 opens fine in LO 6.3+.
Comment 20 Timur 2018-11-27 13:21:29 UTC
Created attachment 147066 [details]
PPT reduced to 2 pages and saved in MSO 2016 compared with LO
Comment 21 Timur 2018-11-27 13:34:43 UTC
This may stay open but I'm afraid it will never be fixed because issue is only with some older PPT format. 
If PPT is resaved in MSO, it opens fine with LO.
So I'll close.