Download it now!
Bug 39728 - FILEOPEN xlsx file crashes LO 3.4.2
Summary: FILEOPEN xlsx file crashes LO 3.4.2
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: All Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: target:3.5 target:3.4.3
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-01 14:55 UTC by noname
Modified: 2011-12-23 14:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
xslx test file from bug 37880 (11.76 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2011-08-01 14:55 UTC, noname
Details
test.xlsx opened with GO-OO 3.2.1 (130.47 KB, image/jpeg)
2011-08-02 10:25 UTC, noname
Details
test file re-saved with GO-OO (11.77 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2011-08-02 14:26 UTC, noname
Details

Note You need to log in before you can comment on or make changes to this bug.
Description noname 2011-08-01 14:55:58 UTC
Created attachment 49801 [details]
xslx test file from bug 37880

I was checking out the fixed bug 37880 
When I opened the file that was attached to that report, LO crashed.
Comment 1 wope 2011-08-02 04:43:17 UTC
Also with MSO 2007, there is an errormessage opening the file.
If you save the file, with the new file, there is no problem.
it seems, the file is defekt.
Comment 2 noname 2011-08-02 10:22:37 UTC
(In reply to comment #1)
> Also with MSO 2007, there is an errormessage opening the file.
> If you save the file, with the new file, there is no problem.
> it seems, the file is defekt.

I don't think so. It opens fine with [Win2K OpenOffice.org 3.2.1 OOO320m19 Build:9505) ooo-build 2010-07-18].

And if the file was defect, it still shouldn't crash the program.
Comment 3 noname 2011-08-02 10:25:20 UTC
Created attachment 49842 [details]
test.xlsx opened with GO-OO 3.2.1
Comment 4 Markus Mohrhard 2011-08-02 11:29:58 UTC
You will always be able to crash LibreOffice with a corrupt file. In this case it is a problem with named ranges. I have a quick look after it, but I think I won't change anything if it is caused by the invalid document.
Comment 5 noname 2011-08-02 14:25:26 UTC
(In reply to comment #4)
> You will always be able to crash LibreOffice with a corrupt file. In this case
> it is a problem with named ranges. I have a quick look after it, but I think I
> won't change anything if it is caused by the invalid document.

Tell me something. Why can GO-OO open and show the file correctly then ?

I re-saved the file and unpacked both files. Can't see much difference between the two. And the newly created file still crashes LO, so you might rule out a corrupt file, or does go-oo (yeah it's old) create corrupt files by default ?
Comment 6 noname 2011-08-02 14:26:32 UTC
Created attachment 49850 [details]
test file re-saved with GO-OO
Comment 7 Markus Mohrhard 2011-08-02 15:48:56 UTC
pushed a patch for this to master and 3-4