Download it now!
Bug 39784 - After upgrade to KDE 4.7 all tooltips in LibreOffice are black on black and illegible (theme regression)
Summary: After upgrade to KDE 4.7 all tooltips in LibreOffice are black on black and i...
Status: RESOLVED DUPLICATE of bug 40461
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-02 17:11 UTC by rsimmons0
Modified: 2011-10-10 03:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Notice the black tooltip right in the center (17.43 KB, image/png)
2011-08-02 17:11 UTC, rsimmons0
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rsimmons0 2011-08-02 17:11:43 UTC
Created attachment 49854 [details]
Notice the black tooltip right in the center

I upgraded to KDE 4.7 and after the upgrade all the tooltips in LibreOffice are
suddenly black text on a black background.

Reproducible: Always

Steps to Reproduce:
1) Install Libre Office and KDE 4.7.0
2) Open a LibreOffice document.
3) Hover over anything to make a tooltip appear.

Actual Results:  
Black text on black background tooltips.

Expected Results:  
Black text on blue background like the rest of the tooltips.

I am using the following versions:
Kubuntu 11.04
Libre Office 3.3.2
KDE 4.7.0
Comment 1 Algot Runeman 2011-09-05 09:06:34 UTC
Bug shows up on my Kubuntu 11.04 KDE 4.7.0 
LibreOffice 3.3.3 
OOO330m19 (Build:301)
tag libreoffice-3.3.3.1, Ubuntu package 1:3.3.3-1ubuntu2

Tried changing colors of System Settings, but there was no tooltip effect within LibreOffice though tooltips are legible white on black in Firefox, for example.

See also bug 40461
Comment 2 Bruce Korb 2011-09-29 14:37:04 UTC
This bug reports two problems:

1. that this happens, but also
2. there is no clear way to change it.

Pretty surely, somebody was trying to highlight the tool tip font.
The problem is likely something like highlighting in yellow, but
the tool tip is black and white, so you get a black highlight of
a black font.  But I cannot remove the highlighting in the themes.


Please give this some priority as it severely constrains the
usefulness of your otherwise highly useful tool.

Thank you.
Comment 3 Luboš Luňák 2011-10-10 03:24:53 UTC

*** This bug has been marked as a duplicate of bug 40461 ***