Bug Hunting Session
Bug 39809 - Can't print duplex
Summary: Can't print duplex
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 38758 42926 49591 68612 (view as bug list)
Depends on:
Blocks: Printer-Settings
  Show dependency treegraph
 
Reported: 2011-08-03 10:01 UTC by Hans Glomme
Modified: 2017-06-02 07:43 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Main Tab Printing dialogue (63.99 KB, image/png)
2013-11-11 12:42 UTC, Hans Glomme
Details
The properties dialogue (48.39 KB, image/png)
2013-11-11 12:43 UTC, Hans Glomme
Details
duplex screenshot (27.26 KB, image/jpeg)
2013-11-11 13:52 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Glomme 2011-08-03 10:01:19 UTC
Hello,

I try to print in duplex mode but there are no settings to do it.

In OpenOffice there is into the V3.3 a option into the printer dialogue to set the printer to duplex.

http://www.glomme.de/snaggit/2011-08-03_16-40-03-2.jpeg

But in Libreoffice 3.4.2 and also 3.3.3 the settings are missed:

http://www.glomme.de/snaggit/2011-08-03_16-42-50-1.jpeg

So it would be fine to implement it also in LibreOffice. Before that option is not implemented for me (I'm sorry to say) it's a no go, because I need it very often.
Comment 1 Hans Glomme 2011-08-05 12:22:01 UTC
*** Bug 38758 has been marked as a duplicate of this bug. ***
Comment 2 Christopher M. Penalver 2011-11-25 06:35:08 UTC
Confirmed in Ubuntu 11.10 LibreOffice 3.4.4. When one clicks File -> Print -> highlight the printer -> Properties -> Paper tab duplex has options for either <ignore> or Off.

lsb_release -rd
Description:	Ubuntu 11.10
Release:	11.10

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.4.4-0ubuntu1
  Candidate: 1:3.4.4-0ubuntu1
  Version table:
 *** 1:3.4.4-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.4.3-3ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
Comment 3 Björn Michaelsen 2011-12-23 12:26:01 UTC Comment hidden (obsolete)
Comment 4 sasha.libreoffice 2012-03-01 05:54:35 UTC
Thanks for bugreport
Please, verify: in last version of LibreOffice problem remains?
If available, try on another OS and tell result
On the same computer, but from another program, duplex works?

May be related:
Bug 33639 - doesn't remember duplex settings
Bug 42926 - Duplex options are ignored
Bug 45630 - : Printer Driver Options do not Work with LO Documents (Duplex, Pages per Sheet)
Bug 32841 - Printing multiple copies outputs full duplex
Bug 35096 - Bug: printing sides + multiples pages per sheet
Bug 43932 - PRINTING: Paper tray setting not accepted from "File -> Print..."
Comment 5 Hans Glomme 2012-03-01 08:42:13 UTC
Hello,

additional info now.:

Like you see in the screenshot (first one) the duplex option works in OpenOffice.
The Screenshot of course was made on the same computer (else it makes no sense).

Because LibreOffice is based on OpenOffice that option was missed.

When you have also a look here at LibreOffice 3.5.0 into the printing dialogue:

http://www.glomme.de/snaggit/2012-03-01_17-08-52.snagproj.jpeg

you see nothing also in 3.5 will be changed.

In opposite of OpenOffice:

http://www.glomme.de/snaggit/2012-03-01_17-10-54.snagproj.jpeg

or NeoOffice:

http://www.glomme.de/snaggit/2012-03-01_17-13-05.snagproj.jpeg

you see there the duplex Options work. All programs are running on OSX 10.7.3.

At windows 7 the option is there  also if it will be hidden:

http://www.glomme.de/snaggit/2012-03-01_17-39-50.snagproj.jpeg <- Option

http://www.glomme.de/snaggit/2012-03-01_17-41-09.snagproj.jpeg <- Duplex

So only here at osx (not tester here at linux) the option will be missed.
Comment 6 sasha.libreoffice 2012-03-01 21:28:15 UTC
Thanks for additional tests
Comment 7 Björn Michaelsen 2012-03-09 02:16:04 UTC Comment hidden (obsolete)
Comment 8 Hans Glomme 2012-04-16 11:17:24 UTC
The posted Problem its different from my one.
The Problem https://bugs.freedesktop.org/show_bug.cgi?id=44638 describes a Problem with empty pages, when using duplex. My Problem is that I can't print duplex because the function is missing.

The Problem in the bug is also regarding Ubuntu, my Problem occurs in OSX (ok also unix working in the background).

So I think the Problems are different.

With that additional info, I also change the Platform to my one. (x86-64 / Mac OS X)
Comment 9 Hans Glomme 2012-04-16 11:24:22 UTC
Also change the version of LO, because the Problem also still exit in the Version 3.5.2.2.

http://www.glomme.de/snaggit/2012-04-16_20-20-55.snagproj.png
Comment 10 Christopher M. Penalver 2012-04-16 12:30:05 UTC
Hans Glomme, please do not toggle the version. For more on this please see: http://wiki.documentfoundation.org/BugReport_Details#Version
Comment 11 Richard 2012-12-06 13:41:38 UTC
Bug 42926 "Duplex options are ignored" - This appears to be the same problem and the solution of setting the "Printer Language Type" to "PostScript" certainly works on my system.

If more people can confirm this solution perhaps the status should be changed to RESOLVED, but being new to bug reporting I am not sure how this is done.

When using the "PDF" language setting and setting the printer "preferences" to duplex mode, the printer will operate in duplex mode, i.e. to re-feed the paper, but there is nothing printed on the reverse side.  What should have been printed on the reverse side it printed on the next new sheet feed into the printer, i.e. the end result is the same at setting duplex mode to "none", but slower due to the re-feed of the paper.

Problem exists on versions 3.5 (Build ID: 350m1(Build:413)) and 3.6 (Build ID: 360m1(Build:303)) under openSuSE 12.1 i586 and 12.2 x86_64 repectively printing to Kyocera FS-C5100DN.

Tried various printer driver options, but manufacturer's PPD offers best results and control of paper input.

Work round:  output as PDF and print using Acrobat reader

Bug 33639 "doesn't remember duplex settings if modifying with LO-windows" - Not the same issue.

Bug 45630 "Printer Driver Options do not Work with LO Documents" - Don't think this is the same issue.
Comment 12 Hans Glomme 2012-12-06 16:13:11 UTC
Hi Richard,

Bug 42926 : You look at the date? Maybe that case must be closed. Because it was after my one.


"If more people can confirm this solution perhaps the status should be changed to RESOLVED, but being new to bug reporting I am not sure how this is done."

Well so you think a not solved problem has to been solved? Because at me the problem still exist.

Work round:  output as PDF and print using Acrobat reader

Of course you can do it like that. But please forgive me: What does it have to do with the problem that I can't print duplex (doesnt matter if I use a ink printer or a laser printer, so also not a Postscript Problem) out of LO?

So for me the problem still exist and isn't solved. And BTW in oOO and also in NeoOffice it works only LO don't have any option for Duplex printing.
Comment 13 retired 2013-07-17 08:47:57 UTC
*** Bug 42926 has been marked as a duplicate of this bug. ***
Comment 14 retired 2013-07-17 08:49:08 UTC
Setting OS to ALL since fdo#42926 was reported against Linux and fdo#39809 here OS X.
Comment 15 ign_christian 2013-07-25 07:28:42 UTC
*** Bug 49591 has been marked as a duplicate of this bug. ***
Comment 16 Alex Thurgood 2013-07-25 11:21:20 UTC
Tested on :
Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)

on OSX 10.8.4

This worksforme with a Kyocera FS-C5150DN networked printer. 
1) Load multi-page document in Writer
2) Press Cmd-P to open OSX print dialog.
3) Select "Double-sided printing" checkbox next to "Number of Copies" in the OSX print dialog.
4) Press "Print" to print


Alex
Comment 17 ign_christian 2013-08-28 02:33:15 UTC
*** Bug 68612 has been marked as a duplicate of this bug. ***
Comment 18 Julien Nabet 2013-11-10 11:05:26 UTC
On pc Debian x86-64 with 4.1 sources updated 1 week ago, I see a duplex options in Print dialog.
- File/Print
- Properties
- Duplex

Hans: could you give a try to a recent version? (last one is 4.1.3)
Comment 19 Hans Glomme 2013-11-11 12:42:25 UTC
Created attachment 89023 [details]
Main Tab Printing dialogue

The Main dialogue where I choose the printer
Comment 20 Hans Glomme 2013-11-11 12:43:22 UTC
Created attachment 89024 [details]
The properties dialogue

Here I can't find anything about duplex
Comment 21 Hans Glomme 2013-11-11 12:44:57 UTC
I try it out under windows and can't find any duplex option under the way : 
- File/Print
- Properties (here is not option "Duplex")
- Duplex
Comment 22 Julien Nabet 2013-11-11 13:52:19 UTC
Created attachment 89025 [details]
duplex screenshot

I attached a screenshot. The problem I have is it's always grayed, but that's another story.
Comment 23 Julien Nabet 2013-11-11 13:53:17 UTC Comment hidden (obsolete)
Comment 24 Hans Glomme 2013-11-11 14:40:59 UTC
(In reply to comment #23)
> Hans: seeing your first screenshot, could you then click on "Eigenschaften"?

Hello,

then the printer tool open and I can set the settings. Then it also works.
Only thought that LO did it.
But so it's ok, also if I expect something other.
Comment 25 Julien Nabet 2013-11-11 15:01:08 UTC
Hans: Thank you for your feedback. I'm not sure to have well understood your last comment.
1) Do you mean you found duplex option + been able to print in duplex?
2) What other scenario did you expect?
Comment 26 Hans Glomme 2013-11-11 16:00:18 UTC
(In reply to comment #25)
> Hans: Thank you for your feedback. I'm not sure to have well understood your
> last comment.
> 1) Do you mean you found duplex option + been able to print in duplex?
> 2) What other scenario did you expect?

Hello,

sorry that I don't write it more clear.
Ok at this comment I will try to bring a little bit light into the dark ;)

When I press on "Eigenschaften" then the printer settings from HP (in my case) comes up:

https://www.dropbox.com/s/djtjiwkwmbvxz7x/11-11-2013%2016-03-10.png

The same I could do with my Samsung printer but then comes up the samsung software.

https://www.dropbox.com/s/09v2kbz51l421ny/11-11-2013%2016-05-07.png

What I was expecting was somthing like in Microsoft Word / Excel etc.
Where I can direct say into the settings that all my documents are printed out Duplex. I also can remember (but they also changed now) that it was like that some versions before into OpenOffice.

I made a screenshot what I mean 

https://www.dropbox.com/s/wuzd99cxbvnhye3/11-11-2013%2016-07-26.png

Something like in the screenshot I would expected. Like it also will be into work see screenshot below:

https://www.dropbox.com/s/zdr8gah5rmvg7jv/11-11-2013%2016-10-55.png
Comment 27 Julien Nabet 2013-11-22 19:46:13 UTC
I put it back at NEW since I got no more questions. Sorry for the delay to respond.
Comment 28 tommy27 2014-10-31 05:59:52 UTC
please retest with current LibO 4.3.3.2 and give an update of the bug status (still present or resolved)
Comment 29 Timur 2015-02-10 11:54:21 UTC
This bug is rather messy. First it looked like a problem with specific printer, and in the end from Comment 26 it looks like a LO printing enhancement request. Generally, duplex printing works fine, via Printer Properties ("Eigenschaften").

This should then either be renamed to "Add duplex option to Print dialog (summary in Comment 26)" or closed so that new bug can be open with simple explanation. 
Then, it's Importance should be marked as "enhancement" and Component set to "UX".
In my opinion, putting duplex option to Page layout tab of Print dialog is the same, one click away, as having it as it is now, in Printer Properties.
There might be some improvement if there duplex option were in the main Print dialog, but imagine how long it will take to implement this, if it took 2+ to clarify what this is about at all.

One issue still unclear to me is what Hans wrote and attached a picture that OO 3.3 had the option in the printer dialogue to set the printer to duplex. All that is OS and version specific so there had to be more details. In Windows, OO 3.3 never had such an option.
Comment 30 Hans Glomme 2015-02-10 13:55:38 UTC
Hello,

sorry for my late reply.
It seems (testet it under Mint Linux) like the option will exist right now if you press the property button. (LO V4.2.7.2)

I also try it under OS X (Yosemite) LO V4.4.0.3 but there the property button is only greyed out.

Let me know if screenshot is needed.
Comment 31 QA Administrators 2016-02-21 08:34:51 UTC Comment hidden (obsolete)
Comment 32 QA Administrators 2017-03-06 15:02:03 UTC Comment hidden (obsolete)
Comment 33 berndheinze69 2017-05-28 17:10:27 UTC
This bug is NOT fixed!
I still see this bug on Windows XP with LibreOffice 5.3.3.2 and a Brother HL-1430 printer.
(For the record this bug can also be found in 5.0.3.2 and 4.3.4.1)

The brother printer driver offers a manual duplex function which displays message boxes to the user "Insert paper like this... and press OK" before printing the even and odd pages. With LibreOffice this does not happen, instead all pages are printed immediately.


I think this is more of a problem how LO communicates with the printer drivers. Just like LO itself the brother driver offers the option "2 pages on 1 sheet". If I use this option the printer will only print one page at a time, with the other half of the page being blank.
Example: (page 1|empty), (page 2|empty), (page 3|empty), etc.
Should be: (page 1|page 2), (page 3|page 4)
Comment 34 Timur 2017-06-02 07:43:12 UTC
Per comment 29 and comment 30, I'll close this bug as WFM.
What I see is that may be some problems with specific printers, but that should be inspected and reported relating to those printers, since duplex print works in general. 
If you find it inappropriate, feel free to reopen, but please narrow the problem to tested printers and OS.

There's comment 33 but the same comment is in Bug 60428.