Bug 40147 - Bad Performance of Print Preview in Print Dialog
Summary: Bad Performance of Print Preview in Print Dialog
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 76194 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-16 09:55 UTC by famo
Modified: 2015-07-14 13:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc preview sample (44.80 KB, image/png)
2011-08-16 09:56 UTC, famo
Details
Draw preview sample (52.49 KB, image/png)
2011-08-16 09:57 UTC, famo
Details
Writer preview sample (37.83 KB, image/png)
2011-08-16 09:57 UTC, famo
Details
Calc Sample File (similar to the one in the screen-shot) (10.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-08-16 10:23 UTC, famo
Details
Draw Sample File (similar to the one in the screen-shot) (12.47 KB, application/vnd.oasis.opendocument.graphics)
2011-08-16 10:24 UTC, famo
Details
Calc with poor print preview (52.59 KB, image/png)
2011-08-20 20:08 UTC, Jeffrey
Details
Calc sample in LO 4.4.5 (41.00 KB, image/jpeg)
2015-07-10 17:54 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description famo 2011-08-16 09:55:16 UTC
The new (since LO 3.3 (?)) print preview in the print dialog has a very bad perfomance:
- the down scaling of the document content in the "preview", is so poor that the actual content is hardly visible and it rather looks like random dots and lines (see attached screenshots).
- with the new "preview" in the print dialog the opening and closing of the print dialog is more cpu intensive and takes longer. In calc it takes me up to 6 seconds for opening and 1 second for closing (at 100% CPU each), this is for a calc document with just 1 page on 1 sheet (see lo_calc_printpreview.png).
My specs:
Windows XP, LO 3.4.2, CPU: AMD Thunderbird 1,2 Ghz, 1 GB SD-Ram.


In the attached screen-shots you can see that the downscaling in the actual application (calc/draw/writer) is much better (and thus visible), than in the "preview".
Comment 1 famo 2011-08-16 09:56:15 UTC
Created attachment 50280 [details]
Calc preview sample
Comment 2 famo 2011-08-16 09:57:02 UTC
Created attachment 50281 [details]
Draw preview sample
Comment 3 famo 2011-08-16 09:57:43 UTC
Created attachment 50282 [details]
Writer preview sample
Comment 4 famo 2011-08-16 10:23:13 UTC
Created attachment 50283 [details]
Calc Sample File (similar to the one in the screen-shot)
Comment 5 famo 2011-08-16 10:24:03 UTC
Created attachment 50284 [details]
Draw Sample File (similar to the one in the screen-shot)
Comment 6 m.a.riosv 2011-08-16 16:01:08 UTC
I think this is an orientation preview, only for help to select pages to print.

I guess is know the Menu/File/Preview.
Comment 7 Cor Nouws 2011-08-17 04:59:45 UTC
Hi thanks for the report and screenprints.
As said already: file > print preview is for a real look and this preview in the print dialog only for orrientation.

It performs fine on my pc. Although with complicated graphics its not that fast..

But it is known that the preview is more demanding for the CPU than the old dialog. However, that should be gained later by printing :-)

So sorry, I guess this one won't be picked up...
I suggest a "resolved > won't fix"
Comment 8 famo 2011-08-17 06:42:51 UTC
I understand (and know) that there is a real print preview, also this is not my point.

My point is that this feature adds cpu time, with no reasonable output. And even if it is only for orientation, if you look at the draw or calc sample and imagine two roughly the same graphis/tables, you won't see the difference in the "preview", so it fails here too.

I guess on newer pc you won't notice the increased cpu usage, so I guess I'm	in a minority of one (and hopefully I will have a better pc someday...).


However, the very bad downscaling of the "preview" remains, therefore this issue should remain *open* (even if it has no high priority and won't be fixed anytime soon).
Comment 9 Cor Nouws 2011-08-17 14:00:04 UTC
(In reply to comment #8)
> My point is that this feature adds cpu time, with no reasonable output. And
> even if it is only for orientation, if you look at the draw or calc sample and
> imagine two roughly the same graphis/tables, you won't see the difference in
> the "preview", so it fails here too.


There was some need to for the Mac platform.
Sorry, but I don't remember details.

> However, the very bad downscaling of the "preview" remains, therefore this
> issue should remain *open* (even if it has no high priority and won't be fixed
> anytime soon).

ok :-)
Comment 10 Jeffrey 2011-08-20 20:08:57 UTC
Created attachment 50415 [details]
Calc with poor print preview

Confirmed on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux. Tested with a Calc document with detailed tables and the down-scaled preview was horrendous. Not sure if I am allowed to attach document so here is an image from my end.
Comment 11 Björn Michaelsen 2011-12-23 12:36:21 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 12 famo 2012-01-15 12:17:30 UTC
Tested with LO 3.5 beta - print preview is still very poor.

Status set to new.
Comment 13 khagaroth 2013-06-13 18:13:17 UTC
And even though the performance (as in speed, not quality) aspect was dismissed, I have a (big) calc document, where just opening the print dialog takes 40+ seconds, which I think is pretty lame. It's probably because it's generating the preview for all pages instead of just the one displayed. It should just generate the first page and do the rest asynchronously, or, better, not at all and always render on the fly.
Comment 14 crxssi 2013-08-10 03:50:48 UTC
Performance of the print dialog preview *is* an issue on slow systems, on thin clients, on complex/big documents, and on users remotely running LO.  And the negativity is compounded since the preview is re-rendered with most UI selection/changes (printer change, Properties, Page Layout, etc).

It is unlikely performance can be increased/improved significantly.  One "solution "is an enhancement, and it is described here: Bug 67905
Comment 15 Adolfo Jayme 2014-03-17 01:41:18 UTC
*** Bug 76194 has been marked as a duplicate of this bug. ***
Comment 16 Timur 2015-07-10 17:54:14 UTC
Created attachment 117174 [details]
Calc sample in LO 4.4.5

I consider this bug to be obsolete, or not clearly defined request, or redundant to the proposed Bug 67905. I suggest be closed as WFM.
Comment 17 famo 2015-07-14 11:36:48 UTC
This bug is indeed fixed. Horaay!


Marking as RESOLVED FIXED
Comment 18 Timur 2015-07-14 11:53:06 UTC
If a specific commit/fix is not known, then it's not Fixed, but WorksForMe.
Comment 19 Cor Nouws 2015-07-14 13:01:17 UTC
(In reply to famo from comment #17)
> This bug is indeed fixed. Horaay!

Thanks for checking and confirming!