Bug 40314 - Force intercept for trend line (regression curve)
Summary: Force intercept for trend line (regression curve)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Tomaz Vajngerl
QA Contact:
URL:
Whiteboard: target:4.3.0 target:4.2.0.1
Keywords:
: 63584 (view as bug list)
Depends on:
Blocks: 40317
  Show dependency treegraph
 
Reported: 2011-08-23 10:03 UTC by Laurent BP
Modified: 2014-07-20 12:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2011-08-23 10:03:52 UTC
Hello,

This is the continuation of OOo issue 34093:
Force linear regression curve to go through zero point (origin) or other Y-value defined
http://openoffice.org/bugzilla/show_bug.cgi?id=34093

Force intercept would be a nice option for trend lines. Some file format modifications are required as for bug 35712:
add polynomial regression type trend line
https://bugs.freedesktop.org/show_bug.cgi?id=35712

You can find on this last bug two documents presenting file format modification and a draft for user interface.
Comment 1 Laurent BP 2011-10-04 01:58:03 UTC
Hello,

New version of CorelPoly (v 1.0!) available on
http://extensions-test.libreoffice.org/extension-center/improved-trend-lines/

Now all classic regression are included with forced intercept.
Comment 2 Björn Michaelsen 2011-12-23 12:33:26 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Laurent BP 2011-12-26 13:27:07 UTC
Hello,

This enhancement has not been introduced in LibO 3.5.
Extension CorelPolyGUI (Improved trend lines) try to answer this question but
is not integrated in LibO:
http://extensions.libreoffice.org/extension-center/improved-trend-lines
Comment 4 ign_christian 2013-06-18 02:50:20 UTC
Could you please retest using LO 3.6.6 or 4.0.3 regarding some updates on extension stated in comment 6 ?
Comment 5 ign_christian 2013-06-18 02:51:40 UTC
> Could you please retest using LO 3.6.6 or 4.0.3 regarding some updates on
> extension stated in comment 6 ?

Sorry I mean comment 3 :)
Comment 6 Laurent BP 2013-07-04 21:06:47 UTC
Hello Tomaž

Thanks a lot for your great job :)
I assigned you to this bug as you already done the job ;)

Here are some comments about Version: 4.2.0.0.alpha0+
Build ID: e703b429cf448deddc7682a33c3e6221889efe98

Seems ok.
Comment 7 Tomaz Vajngerl 2013-11-25 17:34:28 UTC
*** Bug 63584 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2013-12-07 20:11:36 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1ef7640148d35646f465d0d7026529b588cb4bcf

fdo#40314 Free value of intercept for trend line



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-12-08 10:27:45 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b9edc19c2a858b0b164aff746568c690558f9d99&h=libreoffice-4-2

fdo#40314 Free value of intercept for trend line


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2013-12-09 07:12:51 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=496ae60435db1c7b508cbdf85bd5cc00c351cf88

fdo#40314 Force intercept only for linear/poly trendlines



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2013-12-09 07:15:12 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=476af21852660edf10442794e712a2433fa3bad4&h=libreoffice-4-2

fdo#40314 Force intercept only for linear/poly trendlines


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 bugquestcontri 2014-07-20 12:00:29 UTC
@Tomaz Vajngerl - Thanks for all your enhancements in Chart. Impressive work. 

I place this message here and refer to all your work.