Bug Hunting Session
Bug 40381 - VIEWING 3D Form fields look flat
Summary: VIEWING 3D Form fields look flat
Status: RESOLVED DUPLICATE of bug 75364
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.3 RC1
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: bibisected35 bibisected35older
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-08-25 10:30 UTC by SURCOUF
Modified: 2014-05-29 06:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file created under LibO3.4.3 RC1 (11.64 KB, application/vnd.sun.xml.base)
2011-08-25 10:30 UTC, SURCOUF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SURCOUF 2011-08-25 10:30:11 UTC
Created attachment 50570 [details]
Test file created under LibO3.4.3 RC1

Hello,

Since quite a long time (LibO3X), I noticed that the 3D effects concerning radio button and check box do not not work. No difference between 3D and flat effects.I thought that will the version eveolution, things will get solved. Unfortunately, it'w still the same till this present version LibO3.4.3 RC1
It looks OK under OOo.

I'm attaching a file toillustrate this bug. a radio button and a check box with 3D effects and another pair with flat effects.

Hope that ti will help.

Bunty
Comment 1 Rainer Bielefeld Retired 2011-08-25 23:07:28 UTC
More or less [Reproducible] with "LibreOffice 3.4.3 RC2 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:302)]". For me the problem is even worse, it's unpredictable how form controls will look for any form control. Sometimes elements with property "Flat" look 3d!

Related to "Bug 33557 - FORM CONTROLS: Check box is not rendered in 3D"?

@reporter:
Your problem is really limited to that Base function or can you confirm my results?
Please:
- Write a meaningful Summary
- Attach screenshots with comments (you can add information using LibO DRAW
  and then attach your screenshot with comments as PDF) if necessary, because
  you can not know what others will see with your sample
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (and if possible how to created a 
  sample document from the scratch)
- add information 
  -- what exactly is unexpected
  -- and why do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC (especially: video card)
  -- concerning your OS
  -- concerning your LibO version and localization (UI language)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read a.m. URL

May be you can test <http://wiki.documentfoundation.org/BugReport_Details> for submitting bug reports?

Please file Bug reports with status UNCONFIRMED if your are not absolutely sure that you contributed all required background information and that the problem will be reproducible with information you can provide! Thank you!
Comment 2 SURCOUF 2011-08-27 00:57:20 UTC
Hello,

I confirm every of your results. You are right, I have noticed sometimes that when flat effect is selected, I got a 3D effect ans vice versia. All radio button and check boxs look quite awkfull (pixelise even with a 100% zoom).In fact this affects all components of LibO. I just tried on every components and I got the same result. I can't notice any difference That why I'm changing "Database" to "Libreoffice".

If ever you need a detailed step by step procedure with sceenshots, I'll give it next time.

Thanks

Bunty
Comment 3 Rainer Bielefeld Retired 2011-08-27 01:40:24 UTC
I wonder whether this one describes an additional effect of "Bug 33557 - FORM CONTROLS: Check box is not rendered in 3D" (or even is a DUP).

@Christoph:
Is there any LibO style guide concerning this issue?

May be help and / or Documentation need some adds?
Comment 4 SURCOUF 2011-08-27 04:17:31 UTC
(In reply to comment #3)
> I wonder whether this one describes an additional effect of "Bug 33557 - FORM
> CONTROLS: Check box is not rendered in 3D" (or even is a DUP).
> 
> @Christoph:
> Is there any LibO style guide concerning this issue?
> 
> May be help and / or Documentation need some adds?

You are right, it's an additional effect of "Bug 33557, describing only the problem concerning check boxes. I tried to explain about the undesired effects for radio button and check boxes.
Comment 5 Christoph 2011-09-09 13:55:01 UTC
(In reply to comment #3)
> @Christoph:
> Is there any LibO style guide concerning this issue?

No, I don't know of any style guide here. Because this setting is usually tied to the toolkit - there hasn't been a need for describing this setting in-depth, I assume.

On my normal installation (LibO 3.3.2, tag libreoffice-3.3.2.2, Ubuntu package 1:3.3.2-1ubuntu2~lucid1) it doesn't look nice, but I see a difference for 3D/flat for e.g. checkboxes and option buttons.

My proposal is:
* Check what platform have impact on the issue (if)
* Check with development what toolkit (or not) is currently used to draw these elements. Maybe some of the cleanups have had impact on the bindings - but this is just a rough guess.
Comment 6 Alex Thurgood 2011-11-23 06:06:02 UTC
Can we mark this as a DUP of 33557 then or shall I just link the two reports ?


Alex
Comment 7 Björn Michaelsen 2011-12-23 13:24:32 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 8 Björn Michaelsen 2012-03-01 09:42:15 UTC
Regression does appear in oldest version of bibisect-3.5.tar.lzma and must be older.
Comment 9 retired 2014-05-04 12:13:39 UTC
Still happening in LO 4.2.3.3 + Version: 4.3.0.0.alpha1+
Build ID: f76026a43acc65465882924796d93e635c35fd90
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-05-04_06:32:55
Comment 10 surbun 2014-05-13 17:49:59 UTC
Hello,

I can confirm the bug under LibO Version: 4.2.3.3 Build ID: 420m0(Build:3) - UBUNTU 14.04 64Bits

Cheer

Bunty
Comment 11 Lionel Elie Mamane 2014-05-29 06:25:16 UTC

*** This bug has been marked as a duplicate of bug 75364 ***