Bug 40427 - Sections in Navigator are not listed in order of occurrence in document
Summary: Sections in Navigator are not listed in order of occurrence in document
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.2.0 target:7.1.3
Keywords:
Depends on:
Blocks: Navigator Section
  Show dependency treegraph
 
Reported: 2011-08-27 16:32 UTC by kaesezeh
Modified: 2021-03-17 18:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of inconsistent ordering (157.54 KB, image/png)
2011-08-27 16:32 UTC, kaesezeh
Details
.odt file with section names in alph. order, not order of occurrence (14.05 KB, application/vnd.oasis.opendocument.text)
2013-09-05 23:32 UTC, kaesezeh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaesezeh 2011-08-27 16:32:32 UTC
Created attachment 50624 [details]
screenshot of inconsistent ordering

I have a Writer document set up with sections (that are named in the Navigator) and that have numbered paragraphs with section headings. For example:

Section 1 in document
  Navigator: Headings: "1 Einleitung" (i.e. numbered as 1)
  Sections: "Introduction"


Section 2 in document
  Navigator: Headings: "2 2 Modelle, ihre ... Ziele" (i.e. numbered as 2)
  Sections: "Models, their formulation, and goals"

etc. However, when I insert a new section at the end of the document and give it a name and a numbered heading, then

- in the Navigator under Headings, the heading shows up in the right numbered position;
- in the Navigator under Sections, the section shows up erratically somewhere.

Cf. the attached screenshot: Section 6 is called "Schlußwort" and shows up as 6 under Headings, but its Section name is "Conclusion", and that shows up somewhere higher up in the list (the ordering is not even alphabetical, it's just off).
Comment 1 Cor Nouws 2011-12-14 06:06:43 UTC
hi kaesezeh.
While looking at some things in the Navigator, I see your bug.
I cannot confirm the behaviour.
Do you have it with all documents? Or is there a special document that you can attach to reproduce?
Thanks a lot!
Cor
Comment 2 Björn Michaelsen 2011-12-23 12:36:26 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sasha.libreoffice 2012-03-01 07:24:38 UTC
@ kaesezeh@gmail.com
Thanks for bugreport
Please, verify if it is reproducible in last version of LibreOffice
And if so, attach document where problem can be reproduced
Comment 4 Cor Nouws 2012-03-03 15:15:58 UTC
still not able to reproduce and no response on request for information/test document ...
Comment 5 Florian Reisinger 2012-08-14 14:02:55 UTC Comment hidden (obsolete)
Comment 6 Florian Reisinger 2012-08-14 14:03:51 UTC Comment hidden (obsolete)
Comment 7 Florian Reisinger 2012-08-14 14:08:25 UTC Comment hidden (obsolete)
Comment 8 Florian Reisinger 2012-08-14 14:10:28 UTC Comment hidden (obsolete)
Comment 9 kaesezeh 2013-09-05 23:32:44 UTC
Created attachment 85296 [details]
.odt file with section names in alph. order, not order of occurrence
Comment 10 sasha.libreoffice 2013-09-06 06:37:37 UTC
Thanks for attachment. Changing status to unconfirmed.

Sorry, but I can not reproduce this bug.
Please, verify if on another computers bug is reproducible.
If so, add step-by-step description of how to reproduce this bug using attachment.

IMHO this bug may be even locale-specific. There may be improvements inside of Writer for German language (native language of this program).
Comment 11 kaesezeh 2013-09-09 08:56:39 UTC
Hm, I opened the same file on another computer and now the section ordering is right. I am out of town for a few weeks and can't go back to the original computer where this happened, but maybe it's just something with having to restart LibreOffice or Linux Mint or something ... Very weird, but on that other computer, the sections ordering WAS different.
Comment 12 Cor Nouws 2013-09-09 09:20:29 UTC
(In reply to comment #11)
> Hm, I opened the same file on another computer and now the section ordering
> is right. I am out of town for a few weeks and can't go back to the original
> computer where this happened, but maybe it's just something with having to
> restart LibreOffice or Linux Mint or something ... Very weird, but on that
> other computer, the sections ordering WAS different.

OK, no problem. Thanks for your information!
If you are able to give some more info later, on hwat happened or what causes this, pls do.
Cor
Comment 13 Jorendc 2013-11-19 18:30:42 UTC
(In reply to comment #11)
> Hm, I opened the same file on another computer and now the section ordering
> is right. 

Thanks for your feedback! Let's mark this as RESOLVED WORKSFORME then for now.

> I am out of town for a few weeks and can't go back to the original
> computer where this happened, but maybe it's just something with having to
> restart LibreOffice or Linux Mint or something ... Very weird, but on that
> other computer, the sections ordering WAS different.

If you still can reproduce this behavior on your other computer, please feel free to reopen this bug. (mark it UNCONFIRMED again)

Kind regards,
Joren
Comment 14 Mike Kaganski 2021-03-09 09:57:58 UTC
It is still here, and - as shown on the screenshot in attachment 50624 [details] - depends on using multi-page view, having the position of the section in the Navigator dependent on its vertical position on screen.

Tested with Version: 7.1.1.2 (x64) / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL
Comment 15 Mike Kaganski 2021-03-09 10:05:23 UTC
https://gerrit.libreoffice.org/c/core/+/112197
Comment 16 Commit Notification 2021-03-10 08:28:48 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4caf4403c1b862e7ccca94b9caee31394d019732

tdf#40427: use node index as position, not Y position on screen

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Roman Kuznetsov 2021-03-16 09:26:38 UTC
verified in

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d97528da0c70c43fccd3239cbe8e064c3480bba8
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: CL

Thanks for fixing it, Mike
Comment 18 Commit Notification 2021-03-17 18:32:53 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/b250a748e6b28ea79e153ae9136fe2930ac9c3d8

tdf#40427: use node index as position, not Y position on screen

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.