Bug Hunting Session
Bug 40957 - Ctrl-Shft-F2 does not put focus in formula bar
Summary: Ctrl-Shft-F2 does not put focus in formula bar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Noel Power
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-09-17 00:17 UTC by Cor Nouws
Modified: 2012-02-08 12:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2011-09-17 00:17:52 UTC
- open spreadsheet
 - type Ctrl-Shft-F2
 > cel is in editing more
 > focus is not in formula bar
Comment 1 Cor Nouws 2011-09-17 00:35:44 UTC
checked with various builds here
last I have that was ok:
Build ID: 6ecb780-4eb4f62-09af278
 (around August 29)

first I have that is wrong:
Build ID: 11df18b-3f8994a-4525197
 (around September 8)
Comment 2 Julien Nabet 2011-09-17 01:09:47 UTC
I tried to reproduce this problem, without success.
- open Spreadsheet -> I'm on A1 cell (with bold border)
- I'm doing ctrl-shift-F2
-> A1 is still selected but there's no more bold border around
-> focus is on formula bar

I'm on Debian testing x86, master repo, updated few minutes ago.
I took a look at the console since I'm in debug mode, no message at all.

Julien.
Comment 3 Cor Nouws 2011-09-17 01:27:39 UTC
thanks for looking at it.

Looking again at it:

I see no cursor at all after hitting Ctrl-Shft-F2, nor in the cell, nor in the formula bar

Clicking in the formula bar does show the cursor, as does double clicking for the cell
Comment 4 Julien Nabet 2011-09-17 01:55:28 UTC
Could you give us these information ?
- when was your last "git pull"
- on which platform do you have this pb
- is there a debug/warn/error message on the console
- after ctrl-shift-F2, have you tried to type something just to know if the pb is just visual (cursor doesn't appear "only")

Julien.
Comment 5 Cor Nouws 2011-09-17 05:12:51 UTC
Of course Julien:

(In reply to comment #4)
> - when was your last "git pull"

Yesterday around 18:30 UTC

> - on which platform do you have this pb

Linux (Ubuntu)

> - is there a debug/warn/error message on the console

no, not related to that (after start I see some 'bar size width n' messages)

> - after ctrl-shift-F2, have you tried to type something just to know if the pb
> is just visual (cursor doesn't appear "only")

Yes, editing works

Cheers - Cor
Comment 6 Kohei Yoshida 2011-09-19 06:41:44 UTC
Cor,

Do you have experimental feature enabled?
Comment 7 Cor Nouws 2011-09-19 06:50:22 UTC
@ kohei: bingo: turning that of cures it ..
Comment 8 Cor Nouws 2011-10-17 03:53:57 UTC
Just checked in Build ID: 4456143-f6a1fc5-e1a2fb3

With experimental features on, Ctrl-F2 gives an immediate crash

( IMO it is not OK to have e.g. both Macro recording (which works, but limited) and the experimental crashy things under one option..
 -> https://bugs.freedesktop.org/show_bug.cgi?id=41865 )
Comment 9 Kohei Yoshida 2011-12-01 09:14:06 UTC
I should give this to Noel.  He is currently the man driving the formula input bar enhancement.
Comment 10 Cor Nouws 2011-12-01 09:40:42 UTC
(In reply to comment #9)
> I should give this to Noel.  He is currently the man driving the formula input
> bar enhancement.

Thanks for reminding .. Was able to create and install twa fresh builds last evening.

In Build ID: 93acae3-090bcba-45cf606 the crash has disappeared. So the problem seems to be solved.

Maybe too for Noel??
Comment 11 Kohei Yoshida 2011-12-01 10:20:33 UTC
(In reply to comment #10)

> In Build ID: 93acae3-090bcba-45cf606 the crash has disappeared. So the problem
> seems to be solved.

Well, let's just close it since it's no longer reproducible for me as well.
Comment 12 Cor Nouws 2012-02-06 11:36:02 UTC
Sorry, have to reopen.

New spreadsheet
type "aap noot" in a cell
leave cell and put cursor on it again
Ctrl-Shft-F2
now move cursor left and right with arrow keys ...
 > no cursor visible

In 3.4.5, the cursor is at the end of the text initially
I have 'experimental' features disabled.
Comment 13 Noel Power 2012-02-07 04:25:18 UTC
(In reply to comment #12)
> Sorry, have to reopen.
> 
> New spreadsheet
> type "aap noot" in a cell
> leave cell and put cursor on it again
> Ctrl-Shft-F2
> now move cursor left and right with arrow keys ...
>  > no cursor visible
> 
yup, it's a problem, seems the cntrl+shift+f2 doesn't focus to the inputbar anymore