Bug 41157 - BUGZILLAASSISTANT: Clicking link in list "Related bug reports" leaves assistant
Summary: BUGZILLAASSISTANT: Clicking link in list "Related bug reports" leaves assistant
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, skillJavaScript
Depends on:
Blocks:
 
Reported: 2011-09-23 11:08 UTC by Rainer Bielefeld Retired
Modified: 2015-12-15 16:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
pseudo-patch which adds target="_blank" to link line generator (hopefully) (396 bytes, patch)
2011-12-08 10:11 UTC, Nino
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-09-23 11:08:30 UTC
Steps to reproduce with Seamonkey Browser:
1. Start Assistant
2. Select C. WWW., SC "BUGZILLAASSISTANT", V. "unspecified"
   Related bug reports list appears
3. Click one of the links
   Expected: Bug will open in new Browser Window or TAB
   Actual: leaves Assistant "Back Button" of browser only opens
           Blank assistant page, all contents lost.

- Reported with Bug Submission Assistant -
Comment 1 Rainer Bielefeld Retired 2011-09-25 08:58:04 UTC
Also see that with WIN7 FF 6.0.2
Easyhack? I don't know how to integrate, and it seems we currently do not have a skill SkillJavascript?
Comment 2 k-j 2011-10-06 02:53:35 UTC
(In reply to comment #1)
> Also see that with WIN7 FF 6.0.2

Can't reproduce it:
I don't get a new tab or window. The assistant is opened on the started tab.

WIN7 64bit FF 6.0.2

This comment was written on the website.

- Reported with Bug Submission Assistant -
Comment 3 Rainer Bielefeld Retired 2011-10-06 03:34:58 UTC
@k-j:
Some Misunderstanding? That exactly is the problem!
When you click on one of the "Related Bug" links, a new Window or Tab for the Bugzilla bug should be opened so that Assistant information will not be lost. Currently The bug will bee opened in the (Seamonkey-) Tab where I started the Assistant, all work is lost. When I click the Browser back button View returns to the assistant, but in "start position", all work is lost
Comment 4 Nino 2011-12-08 10:11:01 UTC
Created attachment 54246 [details]
pseudo-patch which adds target="_blank" to link line generator (hopefully)

Here's (hopefully) a quick repair patch which just adds the HTML code 'target="_blank" to the link lines. 

As I'm not a developer, somebody with git knowledge should please transform this self-generated pseudo-patch into something applicable before applying it ;-)

Maybe changing the heading from "Related bug reports" to "Related bug reports (new window)" or similar would be nice, but I did not have the time to search for the string.
Comment 5 Nino 2011-12-08 10:15:23 UTC
(just adding me to cc list)
Comment 6 Petr Mladek 2011-12-13 11:05:19 UTC
Nino, thanks a lot for the fix. It looks great. I have committed it to the git repository.

We need to find someone who has rights to update the server now :-)
Comment 7 Nino 2011-12-14 06:15:29 UTC
Hi Petr,

On Tuesday 13 December 2011, bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=41157
> 
> Petr Mladek <pmladek@suse.cz> changed:
> 
>            What  |Removed                     |Added
> ----------------------------------------------------------------------------
> Status Whiteboard|ProposedEasyHack            |ProposedEasyHack
>                  |SkillJavascript             |SkillJavaScript
>                CC|                            |pmladek@suse.cz
> 
> --- Comment #6 from Petr Mladek <pmladek@suse.cz> 2011-12-13 11:05:19 PST
> --- Nino, thanks a lot for the fix. It looks great. I have committed it to
> the git repository.

Thanks for your kind words :-)
 
> We need to find someone who has rights to update the server now :-)

Hopefully there is somebody. Can I do something to make it happen soon? Maybe 
send a mail to the Website list? What do you think? 

Regards,
Nino
Comment 8 Nino 2011-12-14 06:55:44 UTC
ok, obviously somebody has updated the server already :-)
so, I'm closing the bug for now.
Comment 9 Rainer Bielefeld Retired 2011-12-14 07:06:42 UTC
Yes, works fine now, at least for me with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0.1) Gecko/20111121 Firefox/8.0.1 SeaMonkey/2.5!
Comment 10 Robinson Tryon (qubit) 2015-12-15 16:56:39 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval, SkillJavaScript)
[NinjaEdit]