Download it now!
Bug 41394 - EDITING / FORMATTING: cannot format data range of chart loose of data
Summary: EDITING / FORMATTING: cannot format data range of chart loose of data
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: medium major
Assignee: Colin
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-01 18:03 UTC by Colin
Modified: 2015-05-03 01:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Initial source document with charts, which was created by a 3.x version (69.38 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-11-01 02:51 UTC, Friedmann Bruno
Details
Editing a curve series (double click + right click ) give good results (284.65 KB, image/png)
2011-11-01 02:57 UTC, Friedmann Bruno
Details
Trying to edit a column chart lead to data source destruction (283.70 KB, image/png)
2011-11-01 03:03 UTC, Friedmann Bruno
Details
Resulting source of data : corrupted (258.55 KB, image/png)
2011-11-01 03:04 UTC, Friedmann Bruno
Details
Spread sheet of purchases by month (70.65 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-12-11 16:54 UTC, Colin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin 2011-10-01 18:03:28 UTC
Problem description: 'data range' not enabled under format menu

Steps to reproduce:
1. ....double click chart so as to modify
2. ....click on format menu
3. ....

Current behavior:data range greyed out and not accessible

Expected behavior:
              Be able to modify data used to create chart
Comment 1 Colin 2011-10-01 18:05:11 UTC
It should also be noted that F9 does no longer update charts
Comment 2 Friedmann Bruno 2011-11-01 02:48:04 UTC
It's absolutely worse that what is describe on 3.4.3 version

If the document used was created by a previous version, trying to edit an existing charts remove all references to the data series sources.

The previous data, sometimes exist but as a table, like if they were copied from the initial data series.

On columns chart type with 3.4.3 the data source is killed, and then there's no way for the users to retrieve it. Even ctrl+Z doesn't restore the chart.

-> Data corruption ! You need to use a previous version of the document if it saved, there's no more data.

See the different print-screen attached.

This as been tested and confirmed under Linux 64bits (openSUSE 11.4 / 12.1 ) + windows 7 64bits, and windows xp 32 bits (legacy LOO.exe installer)
Comment 3 Friedmann Bruno 2011-11-01 02:51:26 UTC
Created attachment 52984 [details]
Initial source document with charts, which was created by a 3.x version

In this document there several charts and data sources that are used to create the chart.
Editing or adding charts with 3.x version of Loo works as expected
Editing or adding a chart with 3.4.3 version crash the column type graph

see other screenshots
Comment 4 Friedmann Bruno 2011-11-01 02:57:22 UTC
Created attachment 52985 [details]
Editing a curve series (double click + right click ) give good results

If you try to edit the first graph in proposed document
you get the right click menu about editing the data ranges

Have a look how is presented the second graph now.
and check what's happen next screenshot
Comment 5 Friedmann Bruno 2011-11-01 03:03:46 UTC
Created attachment 52986 [details]
Trying to edit a column chart lead to data source destruction

Now on a column chart, we try what was done previously.
once you double clic on it for editing the chart is exploded.

and in place we have a chart data table ?
The chart is totally destroyed

If the user, or the auto-save function save the document at that time, the document is destroyed. And need to be recovered from a backup!
Comment 6 Friedmann Bruno 2011-11-01 03:04:42 UTC
Created attachment 52987 [details]
Resulting source of data : corrupted

Resulting data in the edit mode !
Which is totally wrong
Comment 7 Friedmann Bruno 2011-11-01 03:08:17 UTC
I change the level of priority, due to the fact that document is destroyed and can't be saved.

Now if you try to add a new column chart graph with the wizard it ask you to select the data ranges. which appear the first time, but if you click on the tab data series you see all is empty (expected) then you click back on the range selection and this one is empty too !!!! 

If dev can't reproduce it, I can run it on a gdb session and give a traceback
(I've all debuginfo installed)
Comment 8 Friedmann Bruno 2011-11-01 03:09:08 UTC
modified plateform is reproductible on 32bits and 64bits.
Comment 9 Jean-Baptiste Faure 2011-12-04 03:49:21 UTC
(In reply to comment #0)
> Problem description: 'data range' not enabled under format menu
> 
> Steps to reproduce:
> 1. ....double click chart so as to modify
> 2. ....click on format menu
> 3. ....
> 
> Current behavior:data range greyed out and not accessible
> 
> Expected behavior:
>               Be able to modify data used to create chart

I do not reproduce on LibreOffice 3.4.4 x86_64 with FR langpack (vanilla version) under Ubuntu 10.04. 
Please try again with the current release.

Best regards. JBF
Comment 10 Jean-Baptiste Faure 2011-12-04 03:53:13 UTC
(In reply to comment #2)
> It's absolutely worse that what is describe on 3.4.3 version
> 
> If the document used was created by a previous version, trying to edit an
> existing charts remove all references to the data series sources.
> 
> The previous data, sometimes exist but as a table, like if they were copied
> from the initial data series.
> 
> On columns chart type with 3.4.3 the data source is killed, and then there's no
> way for the users to retrieve it. Even ctrl+Z doesn't restore the chart.
> 
> -> Data corruption ! You need to use a previous version of the document if it
> saved, there's no more data.
> 
> See the different print-screen attached.
> 
> This as been tested and confirmed under Linux 64bits (openSUSE 11.4 / 12.1 ) +
> windows 7 64bits, and windows xp 32 bits (legacy LOO.exe installer)

It is a different issue. AFAIK it is not the correct behavior to have the button Data table activated inside Calc. This button is useful when you insert your chart in a text document using copy-paste.
All works as expected in LibO 3.4.4 under Ubuntu 10.04 x86_64 with FR langpack.

Please try again with the current release.

Best regards. JBF
Comment 11 Friedmann Bruno 2011-12-06 06:29:09 UTC
Unfortunately, testers like JBF have missed important part of the bug.

Under Loo 3.4.4 

The graphique is altered like before in 3.4x series, and the data source range is silently and buggy converted to a table series totally disconnected from the initial source.

Tested with WinXP 3.4.4, Win7 3.4.4 (no need to test more platforms)
Comment 12 Kohei Yoshida 2011-12-08 11:43:58 UTC
Ok.  Colin and Friedmann Bruno describe two totally different bugs here.  That's not appreciated.

We should stick with Colin's bug in this bug report.  Friedmann Bruno, please file a separate bug for your specific issue.  Thanks.
Comment 13 Kohei Yoshida 2011-12-09 06:52:51 UTC
For the record Bruno's problem has been resolved downstream:

https://bugzilla.novell.com/show_bug.cgi?id=727504

BTW Colin, we need you to provide the document that demonstrate your problem, or else there is nothing we can do about it.
Comment 14 Colin 2011-12-11 16:54:58 UTC
Created attachment 54332 [details]
Spread sheet of purchases by month

This bug was first reported via launchpad at the beginning of october together with the file and screen print of the problem. I am amazed it has taken so long to fix.
1).Double clicking a chart to modify the data series does not allow access to the format/ data range menu--it is greyed out.
2) The chart is not automatically updated with data changes,
3) f9 does not update chart.
4) Because of all the above, attempts to create a replacement chart, recognising this is a new version of Calc, is also not possible when the data is not in adjacent cells, using the traditional process
Comment 15 Christopher M. Penalver 2011-12-11 17:02:40 UTC
Friedmann Bruno, please do not toggle the Version. For more on Version please see: http://wiki.documentfoundation.org/BugReport_Details#Version

Changing Severity to Major as this does not fit the criteria of Critical: http://wiki.documentfoundation.org/BugReport_Details#Severity
Comment 16 A (Andy) 2014-03-08 20:16:13 UTC
@Markus: I tried to reproduce the bug reported by Colin to check whether this is still valid.  I used the sample file uploaded by Colin.  It seems to be strange, because the chart on sheet 2 seems not to be linked to the sheet 1 and that's why FORMAT / DATA RANGE is greyed out.  The data seems to come from VIEW / CHART DATA LABEL.  Therefore, the chart doesn't change/update if the data in sheet 1 are changed.  I didn't know this feature VIEW / CHART DATA LABEL.  
Can you or maybe anybody else help me?
Comment 17 Joel Madero 2015-05-02 15:44:38 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 18 Colin 2015-05-03 01:57:44 UTC
Currently using version 4.4.2.2