Download it now!
Bug 41788 - Framed images are exported from Writer incorrectly to html, if scaled
Summary: Framed images are exported from Writer incorrectly to html, if scaled
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HTML-Export
  Show dependency treegraph
 
Reported: 2011-10-14 06:40 UTC by Milos Sramek
Modified: 2019-12-04 16:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Original and the exported html (72.61 KB, application/x-zip-compressed)
2011-10-14 06:40 UTC, Milos Sramek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milos Sramek 2011-10-14 06:40:36 UTC
Created attachment 52333 [details]
Original and the exported html 

If an image is inside of a frame and it is not in its default size, it is exported incorrectly to html. See the attached file

Version: LibreOffice 3.4.3 
OOO340m1 (Build:302)

Btw, why are GIFs used? Why not PNGs?
Comment 1 tester8 2011-11-11 14:52:37 UTC
Reproduced with

LO 3.4.4
Ubuntu 10.04.3 x86
Linux 2.6.32-35-generic Russian UI

Works normally with "Export" and wrong with "Save as".
Related to https://bugs.freedesktop.org/show_bug.cgi?id=42038
Comment 2 Björn Michaelsen 2011-12-23 12:32:14 UTC Comment hidden (obsolete)
Comment 3 tester8 2011-12-29 14:51:50 UTC
Reproduced with

LOdev 3.5.0beta2 
4ca392c-760cc4d-f39cf3d-1b2857e-60db978
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI

Works normally with "Export" and wrong with "Save as".
Comment 4 A (Andy) 2013-05-01 08:15:34 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 5 QA Administrators 2015-03-04 02:18:41 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2015-03-22 12:11:26 UTC
Image in frame still gets cut off when Saved as HTML, but not as severely as in the original html example.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 7 tommy27 2016-04-16 07:26:07 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-05-22 13:22:00 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2019-12-03 13:58:29 UTC Comment hidden (obsolete)
Comment 10 Milos Sramek 2019-12-04 16:28:55 UTC
The situation has not changed:
Save As: image is not correct
Export: image is correct
Tested on LO 6.3.3.2