Bug 41827 - Better default background and shadow colors for Writer documents
Summary: Better default background and shadow colors for Writer documents
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-15 20:11 UTC by Jean-François Fortin Tam
Modified: 2014-12-18 15:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot - default colors (86.22 KB, image/png)
2011-10-15 20:12 UTC, Jean-François Fortin Tam
Details
screenshot - darker colors (85.33 KB, image/png)
2011-10-15 20:12 UTC, Jean-François Fortin Tam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2011-10-15 20:11:44 UTC
The current set of colors in Writer's appearance settings is gray for shadows around pages and light gray for the background behind the pages.

Instead, I would suggest pure black for the page shadows and a darker shade of gray for the background behind the pages.

The reasoning behind this is:
- It's much easier on the eyes, especially at night
- It provides a clearer visual separation between the "chrome" (UI elements such as toolbars, statusbar, rulers, etc.) and the contents because not everything is the same shade of grey anymore
- It makes the page itself more contrasted to the rest, easier to concentrate on
Comment 1 Jean-François Fortin Tam 2011-10-15 20:12:19 UTC
Created attachment 52370 [details]
screenshot - default colors
Comment 2 Jean-François Fortin Tam 2011-10-15 20:12:39 UTC
Created attachment 52371 [details]
screenshot - darker colors
Comment 3 Björn Michaelsen 2011-10-20 10:47:55 UTC
Needs advice from UX, I guess => Not an EasyHack for now.
@Christoph: Could you have a look or delegate as appropriate?
Comment 4 Christoph 2011-10-24 12:59:37 UTC
(In reply to comment #3)
> Needs advice from UX, I guess => Not an EasyHack for now.
> @Christoph: Could you have a look or delegate as appropriate?

Well, the background is determined by the operating system, so Windows sets something different (dark gray) than Gnome (light gray). So, currently the platform (e.g. Linux distribution) is responsible for that.

Nevertheless, a discussion concerning visual improvements started some time ago:
http://wiki.documentfoundation.org/Design/Whiteboards/DocumentBackground

Alternative: An additional appearance (color) setting might be delivered with LibreOffice - loading / saving settings is available. That would be an EasyHack, or?
Comment 5 Björn Michaelsen 2011-12-23 12:38:04 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 6 sasha.libreoffice 2012-02-16 06:21:42 UTC
in Tools->Options Libreoffice->Appearance we can change these settings. And create own themes. By default there only one theme "LibreOffice". Users can create their own themes. For example "High contrast".
Alas, there is no functionality to save theme to file and load from file.
Comment 7 Joel Madero 2012-07-03 09:23:11 UTC
Is there any progress on this? I looked at the link provided by Christoph has a last edited date of 2011-07-13, at 12:17:12. I think the idea sounds fantastic, just trying to figure out if it's being implemented or if it's been abandoned. If it's been abandoned can another dev pick it up and try to finish it? Not sure how much progress was made on it but the images look great. Marking as NEEDINFO, once one of the devs check it out we can mark it appropriately and hopefully have an update of the status for the new look.
Comment 8 Florian Reisinger 2012-08-14 13:59:35 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 9 Florian Reisinger 2012-08-14 14:00:45 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 10 Florian Reisinger 2012-08-14 14:05:28 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 11 Florian Reisinger 2012-08-14 14:07:30 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 12 Jean-François Fortin Tam 2012-09-10 01:19:18 UTC
This should not have been marked as needinfo in the first place. There was no outstanding question for the bug reporter to answer.
Comment 13 Joel Madero 2014-11-06 20:59:04 UTC
Needs confirmed by QA - moving to UNCONFIRMED. Thanks
Comment 14 sophie 2014-12-18 15:08:47 UTC
So, this can be solved using own setting for Application Background in Tools > Options > LibreOffice > Appearance, choose a color in the drop down list. I didn't check in the Advanced configuration options, but I guess it should be there too. This also can be solved by using another desktop theme. I'm closing this request, there is all the needs to customize defaults already. Sophie