Bug Hunting Session
Bug 41972 - TABLES: Graphics in table cell cell shifted to right page border after file save and reopen
Summary: TABLES: Graphics in table cell cell shifted to right page border after file s...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2011-10-18 12:42 UTC by Stephan van den Akker
Modified: 2017-05-14 11:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document with displaced graphics (9.28 KB, application/vnd.oasis.opendocument.text)
2011-10-18 12:42 UTC, Stephan van den Akker
Details
Test-case with Drawing Objects in a Cell on First and Second Page (10.75 KB, application/vnd.oasis.opendocument.text)
2012-01-22 10:37 UTC, famo
Details
Screenshot of Test-Case before closing (48.46 KB, image/png)
2012-01-22 10:38 UTC, famo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan van den Akker 2011-10-18 12:42:14 UTC
Created attachment 52495 [details]
Sample document with displaced graphics

How to reproduce:

1: Create a table in writer
2: Add lines in a cell until the cell spans two pages
3: Draw a graphics object on the second page of the cell, inside the cell
4: Set "Anchor to paragraph" or "Anchor to character" for the graphics object
5: Save the document, and then close it.
6: Reload the document

Expected result:
Graphics on original position

Actual result:
Graphic shifted to right page border

Reproducible: always

Observations:
- Problem is present if "Anchor to page" is selected.

- Problem is not present when the graphics are in the first part of the cell, before the page break.

Tested versions:
OpenOffice 3.1.0 on Windows XP
OpenOffice 3.1.0 (portable) under wine on openSuSE 11.4
OpenOffice 3.3.0 on Windows XP
LibreOffice 3.4.2 from OBS Stable on openSuSE 11.4 (64-bit)
LibreOffice 3.4.3 (portable) under wine on openSuSE 11.4 (64-bit)
Comment 1 Stephan van den Akker 2011-10-18 12:46:28 UTC
Correction: Problem is NOT present if "Anchor to page" is selected.
Comment 2 famo 2012-01-22 10:35:17 UTC
I can confirm this with LO 3.5 beta on Windows XP.
Comment 3 famo 2012-01-22 10:37:32 UTC
Created attachment 55984 [details]
Test-case with Drawing Objects in a Cell on First and Second Page
Comment 4 famo 2012-01-22 10:38:15 UTC
Created attachment 55985 [details]
Screenshot of Test-Case before closing
Comment 5 sasha.libreoffice 2012-02-04 07:08:30 UTC
reproduced in 3.3.4 and 3.6.0 master on Fedora 64 bit
Comment 6 A (Andy) 2013-05-02 19:04:02 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 7 Stephan van den Akker 2013-05-31 19:29:14 UTC
Reproducible on Ubuntu 12.04 (32-bit) with MASTER

Version: 4.2.0.0.alpha0+
Build ID: c2530b02311c46529eed53ee688bf6c83ce4b86
Comment 8 g4b0 2013-08-31 18:45:15 UTC
Reproducible on Version 4.1.1.2
Comment 9 Stephan van den Akker 2014-07-12 08:09:47 UTC
Reproducible in master on openSuSE 12.3 (64-bit)
Version: 4.4.0.0.alpha0+
Build ID: 8b499cea76577b4221fccb17703aa9e86b625e90
Comment 10 QA Administrators 2015-07-18 17:43:20 UTC Comment hidden (obsolete)
Comment 11 Stephan van den Akker 2015-07-19 10:38:53 UTC
WITH A FRESH DOCUMENT I can't reproduce this problem any more. Tested on:

Ubuntu 14.04 (64-bit) with Version: 4.2.8.2 Build ID: 420m0(Build:2)
OpenSuSE 13.2 (64-bit) with Version: 4.4.4.3 Build ID: 40m0(Build:3) Locale: en_US.UTF-8

The attached test document is still broken.

RESOLVED WORKSFORME?
Comment 12 Cor Nouws 2016-05-18 19:40:08 UTC
(In reply to Stephan van den Akker from comment #11)
> WITH A FRESH DOCUMENT I can't reproduce this problem any more. Tested on:

Thanks for testing!

> The attached test document is still broken.

Confirmed in master 5.2.0

> RESOLVED WORKSFORME?

Could do. What about the initial bug file? This means there is a difference between how anchoring (or whatever) was set in the time when the file was made.. Ignore that?
Ciao - Cor
Comment 13 Cor Nouws 2017-05-14 11:25:59 UTC
(In reply to Cor Nouws from comment #12)

> Could do. What about the initial bug file? This means there is a difference
> between how anchoring (or whatever) was set in the time when the file was
> made.. Ignore that?

or file e new bug, if needed ;)