Bug Hunting Session
Bug 41987 - LibreOffice hangs when "Save As..." tries to re-mount previously used, but now inaccessible network volumes
Summary: LibreOffice hangs when "Save As..." tries to re-mount previously used, but no...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 112091 (view as bug list)
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2011-10-19 01:44 UTC by Robert
Modified: 2019-10-12 04:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2011-10-19 01:44:27 UTC
This bug in LibreOffice exists since 3.3 (as far as I noticed):

When using the OS-X dialogs for "Save As ...", it tries to re-mount any previously used network volumes, even when trying to save a local document. This causes some considerable delay, and if they are inaccessible, a very long delay or it hangs altogether.

When activating the option to use "LibreOffice" dialogs for file saving, this does not happen.

But other programs on OS-X don't have this behavior, so it must still have to do with how LibreOffice interfaces with OS-X.

This is running OS-X 10.7.2

On an aside, it would also be nice if the LibreOffice dialogs would associate the Enter key with the default button (throughout).
Comment 1 Alex Thurgood 2012-09-13 12:52:50 UTC
Can not reproduce on OSX 10.8.1 with LO 3.5.6 and OSX file dialogs.

1) Open a docx file from an AFS share.
2) Edit document, re-save.
3) Close document.
4) Unmount AFS share.
5) Create a new ODF text document.
6) Save to Desktop

No slowdown, no search for previously unmounted share.


Alex
Comment 2 Alex Thurgood 2012-09-13 12:55:16 UTC
Perhaps I have misunderstood something ?

Please provide a step by step instruction, tested on a recent production version of LO.

Alex
Comment 3 Robert 2012-09-13 13:31:54 UTC
Hi Alex,

You are right, now I am no longer able to reproduce the bug, since I have also moved on to OS-X 10.8.1, so maybe it was linked to OS-X 10.7 ...

Please just close the case, and sorry of the loss of time!

Robert
Comment 4 Alex Thurgood 2012-09-13 13:38:58 UTC
Changing to WFM because we don't know the reason behind why it now works. We use "fixed" when we can assign it to definite code changes in the source by a dev commit.


Alex
Comment 5 Robert Imhoff 2014-04-21 06:33:01 UTC
Hello,

I've finally succeeded in figuring out how to reproduce this bug which still exists in Libreoffice 4.2.1:


1)On OS-X Mavericks (and previous versions at least back till 10.7), mount a network drive from another mac. 
2) Create an alias to the mounted network volume in the Finder, either on the Desktop or in any other directory.
3) Unmount the network volume and render it inaccessible (turn off the remote machine or unplug the network cable).
4) Launch Libreoffice and create a new document (text or spreadsheet or any type). Now when you select "Save As..." and navigate to the directory where the alias to the network volume is located, Libreoffice tries to remount that network volume and if it is inaccessible, it freezes until you force-quit it or replug the network to allow it to mount that network volume.

The normal OS-X Save As... dialog in other applications doesn't have this behavior.
Comment 6 Joel Madero 2014-11-06 00:08:00 UTC
Never confirmed by QA team - moving to UNCONFIRMED to get confirmation. Thanks for understanding.
Comment 7 Alex Thurgood 2014-11-10 12:07:17 UTC
Confirming

Version: 4.4.0.0.alpha2+
Build ID: c1358e5dc875bb923f4b5472ba615ebd19f0d057

reproduced according to comment 5
Comment 8 Mark Begbie 2014-11-24 21:23:24 UTC
Reproduced in line with comment 5, BUT using LibreOffice dialogs doesn't help.

Version: 4.3.4.1
Build ID: bc356b2f991740509f321d70e4512a6a54c5f243
Comment 9 Boudi 2015-04-27 07:25:48 UTC
It was delay. Now 4.4.2.2 the only way out is force stop.
Save as is impossible.
Comment 10 Boudi 2015-04-27 07:34:11 UTC
Also (automatically) reported to Apple.

Reproduce sequence:

1 - open with LO created .html file on afs server
2 - 'Save as'
3 - spinning wheel for ever ......
4 - force stop LO
Comment 11 QA Administrators 2016-09-20 09:33:05 UTC Comment hidden (obsolete)
Comment 12 Robert 2016-09-21 05:03:30 UTC
Bug is still present with current build of Libreoffice (5.2.1.2).

Hangs for a few minutes when trying to save a document into the same directory as the alias of a non-accessible network, then does finally realise that the network volume is not accessible and resumes normal operation.

OSX 10.11.6
Comment 13 Alex Thurgood 2016-10-12 09:49:59 UTC
*** Bug 100895 has been marked as a duplicate of this bug. ***
Comment 14 John 2017-05-12 19:55:23 UTC
Still present in 5.2.6.2 and El Cap. Hangs for me (at least long enough for me to force quit).
Comment 15 Alex Thurgood 2017-09-05 14:12:21 UTC
*** Bug 112091 has been marked as a duplicate of this bug. ***
Comment 16 QA Administrators 2018-09-06 02:59:25 UTC Comment hidden (obsolete)
Comment 17 Robert 2018-09-06 07:57:53 UTC
Still present in Version: 6.1.0.3 in MacOS Sierra
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 8; OS: Mac OS X 10.12.6; UI render: default; 
Locale: fr-FR (en_CH.UTF-8); Calc: group threaded
Comment 18 Robert 2018-09-06 08:27:54 UTC
Just tried with LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

and the bug is already present there (Mac OS X 10.12.6)
Comment 19 QA Administrators 2019-10-12 02:42:57 UTC Comment hidden (obsolete)
Comment 20 Robert 2019-10-12 04:28:20 UTC
Still present in Version: 6.3.2.2
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 16; OS: Mac OS X 10.14.6;

It hangs for 1 or 2 minutes when trying to save a file into a directory that contains an alias to an inaccessible network volume using the MacOS "Save as..." dialog.