Download it now!
Bug 42014 - LibreOffice Preferences list change hangs with Moom running in Mac OS X Lion
Summary: LibreOffice Preferences list change hangs with Moom running in Mac OS X Lion
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-macOS
  Show dependency treegraph
 
Reported: 2011-10-19 13:44 UTC by jive.email
Modified: 2012-10-03 11:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jive.email 2011-10-19 13:44:11 UTC
LibreOffice hangs when selecting a Preferences item with Moom (http://manytricks.com/moom/)running. Mac OS X Lion 10.7.2 (11C74). MacBook Air (mid-211). LibreOffice 3.4.3 OOO340m1 (Build:302). I get a beachball indefinitely when trying select LibreOffice / Preferences and change from the default top of list entry User Data to another item in the list with the trackpad only when Moom is running. Moom is a window management App that extends the maximize window button behavior too allow for fullscreen and tiled windows. Interestingly, if I use the down arrow key to navigate down in the list, I get a beachball for a short time, then the next item is selected. Neither problem occurs if Moom is not running. I have to force quit Libre to recover - quitting Moom will not allow LibreOffice to continue. There is a bug report at https://bugs.freedesktop.org/show_bug.cgi?id=31919 that mentions a problem with an accessibility app causing this or similar behavior. Thanks very much.
Comment 1 Roman Eisele 2012-04-19 01:57:37 UTC
In the mentioned bug 31919 it is not clear if the cause of the problems is really some sort of accessibility tool (the reported did not answer the question in comment 16). Bug another similar bug report which explicitely talks about the influence of accessibility tool on LibreOffice for MacOS X is:

Bug 47368 - "Many crashes when accessibility enabled on MAC".
Comment 2 Roman Eisele 2012-04-19 02:53:00 UTC
Very similar: bug 33359 (accessability settings clearly involved).

In general, for crashes in the Preferences/Settings dialog, compare bug 37913 ("LibreOffice crashes frequently when settings-dialog is opened"). But not in all cases listed in bug 37913 or marked as duplicates of this bug it is clear if accessability settings are involved.
Comment 3 Julien Nabet 2012-05-16 15:59:55 UTC
Could you give any update with the LO version 3.5.3 ?
Comment 4 jive.email 2012-05-21 00:20:54 UTC
Julien,

Indeed, this seems to have been fixed in:

LibreOffice 3.5.3.2 
Build ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80

No more beachball.

Thank you.
Comment 5 Julien Nabet 2012-05-21 01:44:50 UTC
Thank you for your feedback.
I update the tracker to RESOLVED/WORKSFORME
Comment 6 Roman Eisele 2012-09-12 09:36:12 UTC
Mac Accessibility Related Bugs Survey Results
---------------------------------------------

This bug is already marked as RESOLVED/WORKSFORME, and approved by the original reporter, therefore no more action is necessary.

Additional hints:

This bug is very similar to bug 52147 and bug 54282, which have been both
fixed by Michael Meek’s patch for bug 47368:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3234b715b5a6d13ee673b41066eb565706be5ec9

Therefore it seems probable that this bug, even if it was still reproducible under special circumstances, has been fixed by that commit, too, even if there is a little difference (the present bug is about a hang, but bug 52147 and bug 54282 are about crashes; but this difference may be explained easily by the different version of LibO and/or Mac OS X).

Cf. also bug 33359, which is even more similar to the present bug (about a hang, too), and which is very probably fixed by the commit cited above.

This fix will appear in LibreOffice 3.6.2 and 3.7.0.