Bug 42195 - Writer FILEOPEN functionality request: add Support for embedded fonts.
Summary: Writer FILEOPEN functionality request: add Support for embedded fonts.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: medium enhancement
Assignee: Lubos Lunak
QA Contact:
URL:
Whiteboard: target:4.1.0
Keywords:
: 49278 60750 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-25 03:55 UTC by Jos van den Oever
Modified: 2014-02-18 16:01 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
file with embedded font (4.00 KB, application/vnd.oasis.opendocument.text)
2011-10-25 03:55 UTC, Jos van den Oever
Details
.odt with embedded font, written by LO (10.11 KB, application/vnd.oasis.opendocument.text)
2013-01-31 16:34 UTC, Lubos Lunak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jos van den Oever 2011-10-25 03:55:53 UTC
Created attachment 52732 [details]
file with embedded font

ODF specification allows for embedded fonts since version 1.0.
The relevant specifications are:
  http://docs.oasis-open.org/office/v1.0/OpenDocument-v1.0-os.pdf "14.6 Font
Face Declaration"
  http://www.w3.org/TR/2003/REC-SVG11-20030114/fonts.html#FontFaceElement
  http://www.w3.org/TR/1998/REC-CSS2-19980512/fonts.html#referencing

Example:
  <office:font-face-decls>
    <!-- in this example, font matching is bypassed by using style:name -->
    <style:font-face style:name="myfont" svg:font-family="'AHEM'">
      <svg:font-face-src>
        <svg:font-face-uri xlink:href="AHEM____.TTF">
          <svg:font-face-format svg:string="truetype"/>
        </svg:font-face-uri>
      </svg:font-face-src>
    </style:font-face>
  </office:font-face-decls>
  <office:styles>
    <style:style style:name="embeddedfont" style:family="paragraph">
      <style:text-properties style:font-name="myfont" fo:font-size="12pt"
style:letter-kerning="true" fo:color="#000000"/>
    </style:style>
  </office:styles>
Comment 1 sasha.libreoffice 2012-04-17 03:26:32 UTC
Reproducible in 3.5.2 on Fedora 64 bit, embedded font not used

@ Caolan
What do You thinks about this bug?
Comment 2 Caolán McNamara 2012-04-17 04:04:44 UTC
unimplemented I think, could be implemented by extracting the fonts to some temporary file/dir and adding that to the font list. Might be a bit tricky to figure it all out though.

Not something I'll be personally working on in any reasonable foreseeable time frame though. A "to-do"
Comment 3 sasha.libreoffice 2012-04-18 01:58:41 UTC
Thanks for answer. This information is useful for me.
Changing status to Enhancement
Comment 4 vitriol 2012-04-29 11:53:02 UTC
*** Bug 49278 has been marked as a duplicate of this bug. ***
Comment 5 Brennan Vincent 2012-08-20 15:41:25 UTC
I can't promise that I will be able to figure out how to fix this, but I am going to try to work on it.
Comment 6 Lubos Lunak 2013-01-31 16:33:12 UTC
Jos: I have added support for this to LO, but Calligra Words 2.4.3 now locks up when trying to open the file after a LO roundtrip. See the attached file.
Comment 7 Lubos Lunak 2013-01-31 16:34:03 UTC
Created attachment 74004 [details]
.odt with embedded font, written by LO
Comment 8 Not Assigned 2013-02-01 13:29:37 UTC
LuboÅ¡ LuÅak committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=989d0953a4d69bef3c8aba8e9dc7758194adcdc4

basic support for embedded fonts in odt (fdo#42195)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Gerry 2013-02-01 16:38:43 UTC
Thank you very much for the great new possibility to add fonts in ODT files. As far as I understood Jos van den Oever's, it is generally possible to embed fonts in all types of ODF files. 

Is it complicated to add the same for ODP and ODS files? Particularly for presentations, this can be very helpful!

Do we need to open a new bug report with regards to ODT and ODS files?
Comment 10 vitriol 2013-02-13 10:37:00 UTC
*** Bug 60750 has been marked as a duplicate of this bug. ***
Comment 11 vitriol 2013-02-13 10:40:42 UTC
But there will be an UI option for fonts embedding in LibO?
Comment 12 Lubos Lunak 2013-02-18 14:49:19 UTC
*** Bug 60750 has been marked as a duplicate of this bug. ***
Comment 13 Not Assigned 2013-02-18 14:54:53 UTC
LuboÅ¡ LuÅak committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0210c3ef0ed56a6b45934e2ecb5b42b99808199

UI option for embedding fonts in a Writer document (fdo#42195)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Lubos Lunak 2013-02-18 15:01:32 UTC
UI: File->Properties.
ODP/ODS: Please create a separate request for that. It's lower importance and, although code from this one should be able to be reused, it needs changes in other code too.
Comment 15 Gerry 2013-02-18 17:01:52 UTC
Two follow-up bug reports have been created:

Bug 61072 - Impress, functionality request: add Support for embedded fonts in .odp file format

Bug 61073 - Calc, functionality request: add Support for embedded fonts in .ods file format

Particularly for Impress, the feature of embedding fonts is IMHO very important. If a presenter needs to use special fonts (which is often the case), the only way to present an Impress presentation is to export it to PDF and present it in the PDF viewer. For more details, please see the related bug 61072
Comment 16 Lubos Lunak 2013-03-08 15:41:32 UTC
Calligra problem reported at https://bugs.kde.org/show_bug.cgi?id=316373 , odp/ods support added, so there should be nothing more to do here.
Comment 17 George Nassar 2013-03-14 23:30:19 UTC
Does this feature request also include supporting OOXML embedded fonts?  I ask because I know there's been some discussion about that but search wasn't coming up with a related feature request for that specific functionality that I could find.
Comment 18 Adolfo Jayme 2013-05-08 12:37:27 UTC
The added UI tab is silly and wastes a horrible amount of space :-), so I’ve reported bug 64357.
Comment 19 kurt.pfeifle 2014-02-12 21:11:50 UTC
The implementation does not work (at least not on v4.2.0.4 on Mac OS X). See also bug #74890
Comment 20 Olivier R. 2014-02-12 21:15:56 UTC
On Windows and Linux, fonts are embedded but not used by the software.
Comment 21 Caolán McNamara 2014-02-18 16:01:21 UTC
don't reopen old bugs, create new ones. e.g. bugs remain assigned to people who might no longer be able to work on the project and/or the bug appears to be similar but is actually subtly different.