Bug 42418 - Recently used documents as a dropdown menu on open
Summary: Recently used documents as a dropdown menu on open
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
: 53052 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-31 03:59 UTC by Robert Roth
Modified: 2013-04-30 13:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Roth 2011-10-31 03:59:57 UTC
Forwarded from downstream Ubuntu: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/400008

It would be useful to be able to access recent documents through a dropdown menu on the Open Document toolbar button, like new document types are available from the New Document button.

This way people could more easily access their recently used documents from the main interface.
Comment 1 Florian Reisinger 2012-01-21 06:26:08 UTC
This would be a great idea.
thanks for sharing!
Comment 2 Samuel Mehrbrodt (CIB) 2013-02-07 21:43:50 UTC
Whoever implements this, gets a bounty: http://www.freedomsponsors.org/core/issue/157/recently-used-documents-as-a-dropdown-menu-on-open

Whoever wants this to be implemented, consider increasing that bounty.
Comment 3 Jorendc 2013-02-10 23:31:44 UTC
*** Bug 53052 has been marked as a duplicate of this bug. ***
Comment 4 Gabriel Diosan 2013-02-12 15:14:09 UTC
I have thrown some money at the bounty too. Looks like a good idea. Would be good if the recent documents menu only show documents specific for each component? For example, recent Writer documents only when accessing the Open Document from within Writer and Calc documents only when accessing the Open Document from within Calc? Just a thought.
Comment 5 Samuel Mehrbrodt (CIB) 2013-04-20 18:42:21 UTC
Gabriel, you have Bug 56696 :)