Bug 42428 - Split panes in same window for side-by-side or above-and-below editing of two (or more) parts a single document/file
Summary: Split panes in same window for side-by-side or above-and-below editing of two...
Status: RESOLVED DUPLICATE of bug 31481
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 34900 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-31 06:48 UTC by Alejandro Moreno
Modified: 2018-04-15 05:12 UTC (History)
25 users (show)

See Also:
Crash report or crash signature:


Attachments
Features (150.89 KB, image/png)
2015-05-25 09:15 UTC, Yan Pas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Moreno 2011-10-31 06:48:22 UTC
A feature I have found useful in other word processors is the ability to have a
split.

OOo issue 19291.
Comment 1 vitriol 2011-10-31 06:55:03 UTC
Little variant of Bug 31481. Marked as duplicate.
Comment 2 vitriol 2011-10-31 06:55:46 UTC

*** This bug has been marked as a duplicate of bug 31481 ***
Comment 3 robert.funnell 2011-12-02 19:33:34 UTC
As described by the title, and as explained in the discussion for issue 31481, this is not a duplicate of 31481. In 31481 people want to view 2 documents, in this issue people want to view 2 (or more) different parts of the same document. Please revert the status of this issue.

Note that one can already view a document in 2 windows, and even scroll one of the windows so one is looking at different parts of the document. However, as soon as something is done in one window the other window is automatically scrolled to display the same part of the document, which defeats the purpose.
Comment 4 HansPL 2011-12-03 12:19:52 UTC
I support this -- missing this feature sorely whenever f.i. writing documentation where I have to refer to other parts of this document.  My Winword 2.0 had it already 20 years ago!  Every decent editor has it!    Hans
Comment 5 hwtan 2011-12-04 18:19:34 UTC
On the Openoffice side, this is issue https://issues.apache.org/ooo/show_bug.cgi?id=19291, which has been there since 2003. The end of the discussion over there seems to be the issue https://issues.apache.org/ooo/show_bug.cgi?id=102365 is blocking the implementation of this feature. Coders please note. Thank you.
Comment 6 dE 2012-04-21 22:04:25 UTC
As an alternative, you may use your window manager to do the same.
Comment 7 hwtan 2012-04-22 20:11:28 UTC
dE,

Please go to the discussions/links listed in my previous comment for the reasons of the need of having a split screen instead of two windows.
Comment 8 dE 2012-04-23 06:52:50 UTC
(In reply to comment #3)
> As described by the title, and as explained in the discussion for issue 31481,
> this is not a duplicate of 31481. In 31481 people want to view 2 documents, in
> this issue people want to view 2 (or more) different parts of the same
> document. Please revert the status of this issue.
> 
> Note that one can already view a document in 2 windows, and even scroll one of
> the windows so one is looking at different parts of the document. However, as
> soon as something is done in one window the other window is automatically
> scrolled to display the same part of the document, which defeats the purpose.

No, that's not the case. I get independent scrolls here when a duplicate document is opened via Windows > New Window.(In reply to comment #7)


> dE,
> 
> Please go to the discussions/links listed in my previous comment for the
> reasons of the need of having a split screen instead of two windows.

But I do get the point. I just suggested the workaround.
Comment 9 robert.funnell 2012-04-23 12:47:34 UTC
Wow! It's true that Window > New Window allows one to scroll and edit independently at two locations in a document! When I made my comment (#3, 2011-12-02) it didn't work but now it does, both in OOo 3.3 and LO 3.4. I don't know why it's working now and wasn't then. This satisfies my needs, even if it takes some fiddling to get the windows arranged properly.
Comment 10 Zenaan Harkness 2012-08-04 03:13:43 UTC
*** Bug 34900 has been marked as a duplicate of this bug. ***
Comment 11 Kumāra 2013-02-17 08:17:04 UTC
(In reply to comment #9)
> Wow! It's true that Window > New Window allows one to scroll and edit
> independently at two locations in a document! When I made my comment (#3,
> 2011-12-02) it didn't work but now it does, both in OOo 3.3 and LO 3.4. I
> don't know why it's working now and wasn't then. This satisfies my needs,
> even if it takes some fiddling to get the windows arranged properly.

Hey! Thanks for that. I didn't get it earlier. Your post made it clear. It's a pretty good workaround. I suspect that it's meant to serve the same purpose as the split pane, though not as elegant. It's probably an easier implementation for the coders.

I can confirm dE's experience about having "independent scrolls... when a duplicate document is opened via Windows > New Window."

Still the split pane is a more elegant solution. You have my vote on this.
Comment 12 Joel Madero 2014-11-05 03:21:37 UTC
Removing VOTE as it's useless and no one uses it (no offense but even if it got a million votes, it wouldn't make it move any faster). 

Also moving to NEW as REOPENED is incorrect status.
Comment 13 Edmund Laugasson 2015-05-23 20:26:44 UTC
Marking duplicate of Bug 31481, which has much more discussion and ideas than current 42428.

*** This bug has been marked as a duplicate of bug 31481 ***
Comment 14 Kumāra 2015-05-25 02:44:30 UTC
(In reply to Edmund Laugasson from comment #13)
> Marking duplicate of Bug 31481, which has much more discussion and ideas
> than current 42428.
> 
> *** This bug has been marked as a duplicate of bug 31481 ***

Going by the OP in the other report, it's obvious to me it's a different matter:

"In MS Office 2010, you can open 2 docs in the same window (each doc in a
separate pane). When you scroll through the doc in one pane, the doc in the
other pane scrolls an equivalent amount. This is called "proofreading mode"."

This one however it's about having split panes for ONE doc.

Please double check and revert the duplication marking if you agree.
Comment 15 Edmund Laugasson 2015-05-25 08:53:53 UTC
(In reply to Kumāra from comment #14)
> (In reply to Edmund Laugasson from comment #13)
> > Marking duplicate of Bug 31481, which has much more discussion and ideas
> > than current 42428.
> > 
> > *** This bug has been marked as a duplicate of bug 31481 ***
> 
> Going by the OP in the other report, it's obvious to me it's a different
> matter:
> 
> "In MS Office 2010, you can open 2 docs in the same window (each doc in a
> separate pane). When you scroll through the doc in one pane, the doc in the
> other pane scrolls an equivalent amount. This is called "proofreading mode"."
> 
> This one however it's about having split panes for ONE doc.
> 
> Please double check and revert the duplication marking if you agree.

The split window feature allows you to view one or more documents. You can easily switch between documents using the "Window" pull-down menu. In programming it does not make sense of creating the feature itself. Actually the feature exist already in Calc - so there would be expected to implement it also in Writer and why not also in other apps of LibreOffice where possible.

There will be never two choices in menu like "split ONE document" and "split TWO documents".
If there would be developed diff like we know it in programming editors then this would be different funtionality than just splitting.
Comment 16 Edmund Laugasson 2015-05-25 09:03:27 UTC
If the functionality is planned not to allow change documents in split view - then these can be two different bugs. But I would propose to expand the split window functionality and allow also change documents in split view.
Comment 17 Yan Pas 2015-05-25 09:15:21 UTC
Created attachment 116006 [details]
Features

What implementation are we talking about? Like on the left or right? I guess there is no need to reinvent the wheel, so in Calc (like in Excel) it will be nice to have windows inside and in Writer (like in Word) split pane (tiling windows)
Comment 18 Edmund Laugasson 2015-05-25 09:22:04 UTC
(In reply to Yan Pashkovsky from comment #17)
> Created attachment 116006 [details]
> Features
> 
> What implementation are we talking about? Like on the left or right? I guess
> there is no need to reinvent the wheel, so in Calc (like in Excel) it will
> be nice to have windows inside and in Writer (like in Word) split pane
> (tiling windows)

If we would like to make it better than in MS Word then I would propose to implement it like it is currently already in Calc but allow also change the documents inside splitting function with scroll lock feature so the proof-of-read need will be also covered.
Comment 19 Koen 2016-07-01 14:21:18 UTC
(In reply to Edmund Laugasson from comment #18)
> If we would like to make it better than in MS Word then I would propose to
> implement it like it is currently already in Calc but allow also change the
> documents inside splitting function with scroll lock feature so the
> proof-of-read need will be also covered.

Current implementation in Calc (v 5.1: Window -> new window -> align manually) is not better than in MS Word, IMHO. But maybe I misunderstood what you meant?
Comment 20 opensuse.lietuviu.kalba 2016-09-10 15:03:59 UTC
(In reply to Yan Pas from comment #17)
> Created attachment 116006 [details]
> Features
> 
> What implementation are we talking about? Like on the left or right? 

I also vote for implementing right version of implementation, as already implemented in LibreOffice Calc (by menu View -> Split Window)
(but outdated documentation https://help.libreoffice.org/Calc/Split
says: Window -> Split)

Though this bug is marked is dublicate of bug#31481, but I suggest, that this feature is different from viewing two separate documents (this feature not implemented in Calc).
Comment 21 opensuse.lietuviu.kalba 2016-09-10 15:06:23 UTC
(In reply to Yan Pas from comment #17)
> Created attachment 116006 [details]
> Features
> 
> What implementation are we talking about? Like on the left or right? 

I also vote for implementing right version of implementation, as already implemented in LibreOffice Calc (by menu View -> Split Window)
(but outdated documentation https://help.libreoffice.org/Calc/Split
says: Window -> Split)

Analog functionallity for Word described here: https://support.office.com/en-us/article/View-two-parts-of-a-document-at-the-same-time-1adf3317-0ec4-4568-ad32-6f68b3e4b386

Though this bug is marked is dublicate of bug#31481, but I suggest, that this feature is different from viewing two separate documents (this feature not implemented in Calc).
Comment 22 opensuse.lietuviu.kalba 2016-09-10 15:07:29 UTC Comment hidden (obsolete)