Bug 42657 - PRINTING: LibreOffice won't save Printer Settings per Document.
Summary: PRINTING: LibreOffice won't save Printer Settings per Document.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: lowest enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: VOTE
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2011-11-07 01:36 UTC by cgaj
Modified: 2015-12-18 10:14 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT, A5, 4-pages, printer settings set to A4 Landscape, created under v4132. (26.41 KB, application/vnd.oasis.opendocument.text)
2013-12-22 03:01 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cgaj 2011-11-07 01:36:13 UTC
Problem description:
Note - I had to file this under WRITER but it applies to all components of LibreOffice...
Introduction - I have had OpenOffice in Ubuntu for some years, and saving Printer Settings works just fine.
My understanding of how it works is as follows (please correct if wrong):

A. I can set overall System-wide default printer settings via: Ubuntu > System > Administration > Printing > Printer > Properties > Printer Options.
B. I can set Document-specific printer settings via: OpenOffice > File > Printer Settings > Properties.
C. I can set printer settings for the next Print only via: OpenOffice > File > Print > Properties.

So what gets printed is whatever I set at A, unless I over-ride it for that Document at B, or for that particular Print at C.
If I make a change at A, it then appears at B & C.
If I make a change at B, it then appears at C.

Perfect!

With Ubuntu 11.04, OpenOffice was replaced by LibreOffice and something in the above is broken, at least for me:
What I set at A appears at B & C, prints as required, and stays until deliberately changed again - OK.
What I set at C prints as required (one time) then resets to default as A - OK.
But - Nothing I set at B has any effect at all on C, nor on what is printed!
This means I cannot set any Printer Settings to stick with a Document, but have to either set them as system-wide defaults at A, or reset them every Print at C.

Unacceptable!

Steps to reproduce:
1. Make a change in File > Printer Settings > Properties.
2. See if it appears in File > Print > Properties
3. See if it affects what you print.

Current behavior: Changes in File > Printer Settings > Properties are not taken into account, so settings cannot be saved per document

Expected behavior: Like OpenOffice - can save printer settings per document, using File > Printer Settings > Properties

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Comment 1 cgaj 2011-11-08 02:09:51 UTC
I'm sorry I didn't find the following information sooner, but anyway:

It looks like this bug report is pretty much similar to several previous ones - 33861 / 36591 / 37064.
All those have been classed as Duplicates of 33245, which is not really the same problem...

The latest comment on 33245 is dated 25/5/2011 & says it does not fix the problem in 33861 / 36591 / 37064 & now 42657.

Can I please ask that this problem be re-opened & not swept under the carpet with 33245?

Thanks!!
Comment 2 sasha.libreoffice 2012-02-06 08:08:17 UTC
As I can understand, LibreOffice saves printer settings per document, but not want to use these settings?
Or not saves?
And I cite advise from another bug, my be it will help:
in Tools->Options   LibreOffice->User data
Input values in all fields
Comment 3 Joel Madero 2012-07-16 15:48:06 UTC
This problem is not being swept under the carpet...

I agree that it's not the same problem as 33245. I'm going to add regression to the whiteboard status as you've stated that it worked in OOo before transitioning to LO. 

I havne't confirmed the bug so I won't mark it as confirmed as of yet but I am going to change the importance a bit. This is a minor bug (it's an inconvenience but an easy work around is just to set your printer settings...I know annoying, don't think that the importance will affect how fast the problem is solved). Also going to raise it to HIGHEST priority as it's a regression and it's probably affecting quite a few users. 

Thanks for sticking with this one. I'll confirm this tonight and see if we can find someone to tackle it.
Comment 4 Mas 2012-09-15 06:26:45 UTC
I am going to try and duplicate this .
Comment 5 Joel Madero 2012-09-15 14:36:53 UTC
@Mas, thanks. I got too much on my plate and haven't been able to test this one out. I'm almost 100% sure that it's the case though that we don't save printer settings per document - which would indeed be a nice feature
Comment 6 Mas 2012-09-20 21:34:16 UTC
This has been confirmed. The option to save printer setting per document is not available. As Joel stated this will be a feature enhancement and not a bug. 

The printer options can be saved at the operating system level under System Settings > printer > options 


I will keep this ticket open to determine if this can move this to a feature request.
Comment 7 Mas 2012-09-20 22:04:06 UTC
Added this to the voting list on the wiki
Comment 8 cgaj 2012-09-21 09:52:54 UTC
To me this does not sound like a "feature enhancement" - it is a regression from OpenOffice behaviour, isn't it?
Comment 9 Mas 2012-09-21 10:11:35 UTC
Libreoffice broke off from Openoffice since the release of 3.3. while you would be  correct if we were still on this release. I tested your scenario under our latest build and the option to save per document is not available . At the moment you can  change the printer setting within Ubuntu.

This option will need to be a feature enhancement for later builds if possible.
Comment 10 Joel Madero 2012-09-21 13:53:35 UTC
This could be either. If it is a bug it would be a minor bug as there are workarounds and it doesn't cause crashes or loss of data. I do think that it deserves a bit higher priority then lowest because I think a lot of people could potentially benefit from it. I'll raise this with a dev and see what they think.

We'll get this taken care of regardless of if it's listed as an enhancement or bug ;)
Comment 11 crxssi 2013-02-19 21:38:40 UTC
The newly redesigned File->Print dialog for writer and calc always completely ignores the paper size, paper orientation, and duplex settings that are stored/saved in the document.  Instead, it guesses what they should be, on the fly, based solely on the format->page size/page (guessing what the user might want).  If one changes any of those settings in the print dialog, none are them are saved in the document (plus they are ignored anyway the next time the print dialog appears).  Even worse, the File->Printer Settings Dialog STILL SHOWS what is saved in the document AND remembers any changes you make there, which is then subsequently ignored by the new File->Print dialog.

Example (just paper size):
* Create new writer document with defaults (letter sized page in our case).
* File->Printer Settings change paper size to legal and say "OK".
* Go back into File->Printer Settings, see that the setting is saved in the document and it still says "legal".
* Go into File->Print and see that the paper size has changed to letter.
* Go back to File->Printer Settings, see that it is still set to legal.
* Go into File->Print and change paper size from letter to A4 and print it.
* Go back into File->Print and see that it is back to letter again.
* Go into File->Printer Settings and see that it is actually still legal saved as the paper size.
* Save document, close it, open it, and go into File->Printer Settings to prove that it was saved in the document as legal.

This current behavior is inconsistent, confusing, and messy.  I understand why the designers of the new File->Print dialog might have it ignore the saved settings and not allow any of those changed settings to be saved- perhaps to try and reduce confusion by less experienced users who simply don't understand the need for PAGE size/orientation to be different from PAPER size/orientation.  However, mis-matching the two is needed when using brochure printing, posterizing, and printing N-up.  It is still possible to do all those functions with the current behavior, but it is far more frustrating, since it is not possible to have the settings remembered/saved/honored in that document.  And having the File->Printer Settings dialog not follow the same logic as File->Print is just insane.

There are cases where certain types of print settings should not be saved or remembered, like number of copies, page ranges, or maybe even n-up printing.  With some other settings it is far less clear.  I don't know the "perfect" behavior for all use cases, but the current behavior is worse than the previously used behavior.  (I would vote for this to be corrected back to the old behavior, except for some reason voting is not turned "on" on this bugzilla.)

Tested Using LO 4.0.0, vanilla RPM, under RHEL 6.2 Linux.  Also verified on several other Linuxes and versions of LO.
Comment 12 Joel Madero 2013-02-19 21:40:30 UTC
Seems like that is a separate bug.....
Comment 13 crxssi 2013-02-20 01:07:18 UTC
(In reply to comment #12)
> Seems like that is a separate bug.....

I wish I could say.  Reading through all the stuff it is confusing.  Took me forever to even find this particular bug report, which SEEMS to match what I was describing.  If you think I should make it a new bug report, I will.

((To make matters worse, I just discovered today that PDF printing is completely broken in LO when it comes to paper sizes- they simply don't work at all under CUPS/Linux!  So now I have to switch my 150 user implementation back to PS (which seems to be working) and have to go find if THAT bug has been reported already. ))
Comment 14 Joel Madero 2013-02-20 01:43:30 UTC
yes please report a new bug and CC me in it. I can confirm what you're saying and it looks like it's a problem in 3.6.4.3 as well. I will try to find a developer to tackle this as I understand your frustration. Also CC me on the PDF bug. Don't spend too much time searching for a bug, that's our job as QA. Try for just a few minutes, if you can't, just report a new one and if we recognize it as a dupe we'll mark it as such.

Thanks for helping and apologies for the inconvenience
Comment 15 crxssi 2013-02-20 20:47:12 UTC
(In reply to comment #14)
> yes please report a new bug and CC me in it. [...]
> Thanks for helping and apologies for the inconvenience

Thank YOU so much for your assistance.  I have placed my observations into a new bug as requested- 61186  https://bugs.freedesktop.org/show_bug.cgi?id=61186
Comment 16 Owen Genat (retired) 2013-12-22 03:01:01 UTC
Created attachment 91109 [details]
ODT, A5, 4-pages, printer settings set to A4 Landscape, created under v4132.

I want to make clear(er) the distinction between this report and bug 33245, as there are references to "File > Print Settings" in the related bug. This report seems limited to settings under File > Printer Settings (option "B" from the description) being mirrored when accessed via File > Print > General tab > Properties (option "C") i.e., mainly Paper size and Orientation. The related bug has "print driver" in the summary and is largely concerned with the paper size setting, so there would seem to be a certain amount of overlap, although in honesty this report seems clearer and more specific than the related one. Basically, it is desirable to have the printer settings (option "B") saved in the ODF and retrieved at the time of printing (option "C"). This now appears to be the case (i.e., fixed) under v4.1.

I have restricted what follows to only Paper size and Orientation aspects for the reason indicated (except for one reference at the end). Testing with a basic 4-page A5 document with all pages in portrait orientation and printer settings set to A4 Landscape (attached) shows that paper size and orientation have never been saved or at least read from the document, until v4.1. Under Ubuntu 10.04 x86_64 these versions all indicate identical behaviour:

- v3.3.0.4 OOO330m19 Build: 6
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24

For example, using the attached document (and with a reset user profile):

1. File > Printer Settings > printer (e.g., for me this is a HP LaserJet 4050TN exposed via CUPS) > Properties. 
2. Confirm Paper size is A4, Orientation is Landscape > click OK > click OK.
3. File > Print > General tab > same printer > Properties.
4. Paper size is A5 and Orientation is Portrait (thus need to be adjusted) > click OK > click Print.
5. File > Print > General tab > same printer > Properties.
6. Same as for (4) above.

Observed behaviour:
- In step (4) initial paper size and orientation settings are not loaded from document, and even once set, revert to the initial value each time the print dialog is re-initiated (6).

Expected behaviour:
- In step (4) initial paper size and orientation settings ARE loaded from document, and once set REMAIN each time the print dialog is re-initiated (6).

The expected behaviour now occurs using v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a to open / print the attached document.

(In reply to comment #12)
> Seems like that is a separate bug.....

I agree with Joel. The focus in this bug is on option "B" and option "C" (in the original description) being consistent for paper size and orientation. That is pretty much all.

(In reply to comment #15)
> I have placed my observations into a new bug as requested- 61186 
> https://bugs.freedesktop.org/show_bug.cgi?id=61186

Since the indicated bug 61186 has been fixed, it also alters the manner in which paper size / orientation is obtained and displayed in the preview under v4.1. There is now File > Print > Options tab > "Use only paper size from printer preferences" that affects how paper size / orientation is handled when other (e.g., Layout) options are included. Unfortunately, this blurs the distinction between this report and the related bug 33245, as a print (option "C") setting is now required to determine / access a printer (option "B") setting for Layout issues (which have not been discussed in this comment as they appear unrelated to the original report). This matter is a separate issue covered by bug 62995.
Comment 17 Owen Genat (retired) 2013-12-22 03:07:59 UTC
As per comment #0 and comment #11 Component set to Printing and PDF Export. As per comment #16, Version set to Inherited From OOo. 

Can others please check my understanding in comment #16 and whether v4.1.x+ does indeed maintain the consistency of printer settings and print settings, with respect to paper size and orientation? Thanks.
Comment 18 Owen Genat (retired) 2014-01-06 10:36:00 UTC
Setting version back from "Inherited From OOo" to what it was prior (for bugs marked enhancement), for QA tracking purposes. My mistake. Apologies.
Comment 19 cgaj 2014-02-05 10:52:49 UTC
Hi!

Reacting to comment #17:
I am the originator of this Bug report.
I just upgraded to Ubuntu 13.10 with LibO 4.1.3.2.

For me, this bug is now fixed.

Quote:
Steps to reproduce:
1. Make a change in File > Printer Settings > Properties.
2. See if it appears in File > Print > Properties
3. See if it affects what you print.

That now works as expected & settings are saved with the document.

Thanks!
Comment 20 Owen Genat (retired) 2014-02-08 00:13:04 UTC
As per comment 19, status set to RESOLVED as FIXED.
Comment 21 Joel Madero 2014-02-08 00:28:11 UTC
WFM since we don't know what patch fixed it :) Thanks for spotting this one
Comment 22 Cor Nouws 2014-02-23 23:32:26 UTC
(In reply to comment #0)

> But - Nothing I set at B has any effect at all on C, nor on what is printed!

Works fine for me (in 4.2.1.1 on UBuntu) I guess in earlier versions too..
So I confirm WorksForMe
Comment 23 Robinson Tryon (qubit) 2015-12-18 10:14:07 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval)
[NinjaEdit]