Bug Hunting Session
Bug 42692 - SVG export ignores "Selection" option
Summary: SVG export ignores "Selection" option
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 43129 63804 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-07 23:41 UTC by Ulrich Windl
Modified: 2015-03-23 08:52 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Kit (46.45 KB, application/x-7z-compressed)
2012-08-21 05:05 UTC, Rainer Bielefeld Retired
Details
Source for tests (4.27 KB, image/svg+xml)
2015-03-03 20:02 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Windl 2011-11-07 23:41:53 UTC
When trying to export a "selection" as SVG, the whole page is exported instead of the selected part (other export filters do it properly).
Note: IMHO there should be an "export" component in bugzilla
Comment 1 Ulrich Windl 2011-12-12 23:47:27 UTC
The bug is still in LibreOffice 3.4.4 (Windows/XP).
Comment 2 Regina Henschel 2012-01-13 16:20:44 UTC
I see the bug in LO3.5Beta3 on WinXP too.
Comment 3 Rainer Bielefeld Retired 2012-01-13 23:07:51 UTC
*** Bug 43129 has been marked as a duplicate of this bug. ***
Comment 4 Rainer Bielefeld Retired 2012-01-13 23:20:36 UTC
[Reproducible] with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]", too.
Comment 5 Rainer Bielefeld Retired 2012-08-21 04:57:49 UTC
Back to list due to facts
Comment 6 Rainer Bielefeld Retired 2012-08-21 05:05:58 UTC
Created attachment 65862 [details]
Test Kit

Attached you find a test kit. Steps to reproduce:
1. open "source.odg"
2. <control+a>
3. Menu 'File -> Export -> Selection -> Filetype .SVG - Name="MySVG.svg" -> 
   <Save>
   > MySVG.svg" created
   Expected: only heating scheme visible
   Actual: all Page even with hidden contents visible
4. For comparison redo step 3, but export to .png
   > Export to PNG will respect selected area
Comment 7 Rainer Bielefeld Retired 2012-08-21 09:22:42 UTC
So Inhterited from OOo, I modify OS due to AOOo bug without own tests.

@Regina:
Thank you for research
Comment 8 Rainer Bielefeld Retired 2013-04-22 14:15:19 UTC
*** Bug 63804 has been marked as a duplicate of this bug. ***
Comment 9 bugquestcontri 2013-06-09 12:33:27 UTC
I can confirm the problem in Version 

- 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
- 3.6.6.2 (Build ID: f969faf)

for XP prof / SP3

I followed the procedure as Rainer described it in Comment 6 including the png test. However in my case the png-export also resulted in the export of the entire page.

There is also a discussion thread in AskLibO http://ask.libreoffice.org/en/question/18611/what-is-the-best-way-to-draw-in-libreoffice-that/?comment=18701#comment-18701
Comment 10 Ulrich Windl 2013-10-21 06:33:43 UTC
Still present in 4.0.5.2. Close to celebrate the two years anniversary of this bug ;-)
Comment 11 Regina Henschel 2013-10-21 20:46:55 UTC
Or eight years from https://issues.apache.org/ooo/show_bug.cgi?id=56084
Comment 12 Ulrich Windl 2013-11-15 07:14:19 UTC
Still present in 4.1.3...
Comment 13 Ulrich Windl 2013-11-15 07:17:33 UTC
Can we raise the importance (as done), because SVG is the only vector format Writer understands that can handle transparent colors. (I don't want to use PNG to import the stuff in Writer).
Comment 14 etiffany 2013-11-27 15:26:04 UTC
Yes, this is sort of pathetic.  Over two years.  

I just opened a similar support ticket with EazyDraw (to allow that app to export just the selected items to SVG) and it was done in 2 *days*.  Sadly, EazyDraw doesn't open .ODG files.
Comment 15 Greg Wilson 2013-12-12 14:15:17 UTC
I would be happy to send a Mozilla Firefox sweatshirt to whoever closes this bug --- we're using LibreOffice Draw to create diagrams for the new Software Carpentry teaching materials (http://software-carpentry.org), and having to export SVG, load that into Inkscape, open document properties, resize the page to fit the image, then re-save is painful and error-prone.  Please mail greg [at] mozillafoundation [dot] org to claim your shirt :-)
Comment 16 blargh 2014-06-23 11:10:08 UTC
This bug is still present in LibreOffice 4.1.6.2.
Comment 17 Rodolfo 2015-02-14 00:35:02 UTC
Works for me on 4.3.3.2 (Debian Testing/Jessie)
Comment 18 Buovjaga 2015-03-03 16:17:30 UTC
Yep, works ok for me, too. Well, it does somehow produce a result, where the bottom is cut off at the level of the three-way valves, but that's another story.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 19 Regina Henschel 2015-03-03 19:55:33 UTC
No it is not solved. It does not export the whole page, but it uses clip-paths where it should not. The result is, that the shape is cut. In AOO the bug is fixed in the meantime.
Comment 20 Regina Henschel 2015-03-03 20:02:18 UTC
Created attachment 113861 [details]
Source for tests

Open the attached document and export the circle with checked "selection" to svg. Open the resulted file for example in browser Seamonkey or in Inkscape. Notice that the circle is cut to a rectangle, landscape shape on a background, which has the original size of the circle.

BTW, the export adds a lot of not used stuff and so makes the svg source larger as necessary and confusing.
Comment 21 Buovjaga 2015-03-03 20:22:49 UTC
(In reply to Regina Henschel from comment #20)
> Created attachment 113861 [details]
> Source for tests
> 
> Open the attached document and export the circle with checked "selection" to
> svg. Open the resulted file for example in browser Seamonkey or in Inkscape.
> Notice that the circle is cut to a rectangle, landscape shape on a
> background, which has the original size of the circle.
> 
> BTW, the export adds a lot of not used stuff and so makes the svg source
> larger as necessary and confusing.

Attachment 113861 [details] displays as a clipped circle to begin with in Firefox or Inkscape.
In LibreOffice it opens as a full circle.
Selecting the circle and exporting as selection, results in an SVG that displays as a full circle in Firefox, Inkscape & LibreOffice.

Whatever the problem, it is not the original topic of this bug report.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 22 Matthew Francis 2015-03-23 08:52:50 UTC
As far as I can see,

- The originally reported bug has already been fixed *1. As of 4.3, exporting a selection to SVG appears to select an appropriate canvas size for the selection, not the whole drawing.

- The unrelated bug mentioned in comment 18 which causes the test file to be incorrectly clipped at the bottom has already been raised as bug 90017.

- The unrelated bug mentioned on comment 20 / comment 21 regarding clipping on import has been split into bug 90168.

I don't see that there's anything more to do here, so closing.


*1 It appears to have been this commit - so any T-shirts can be forwarded back to Apache
commit de37aa18faf03da14dc453e843b1419edbedbfa9
Author:     Armin Le Grand <alg@apache.org>
AuthorDate: Mon Apr 7 14:58:01 2014 +0000
Commit:     Caolán McNamara <caolanm@redhat.com>
CommitDate: Tue Apr 8 15:22:00 2014 +0100

    Resolves: #i124608# functionality to export only selected objects...