Bug Hunting Session
Bug 43017 - FILEOPEN: .docx hyperlink changes to blue from black text
Summary: FILEOPEN: .docx hyperlink changes to blue from black text
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: BSA target:6.0.0
Keywords: filter:docx
: 84340 103929 112490 (view as bug list)
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2011-11-17 02:16 UTC by Edward Sanford Sutton, III
Modified: 2019-10-08 15:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
.docx with hyperlink that appears blue and doublestrikethrough instead of normal black formatted text. (14.54 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-11-17 02:16 UTC, Edward Sanford Sutton, III
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Edward Sanford Sutton, III 2011-11-17 02:16:14 UTC
Created attachment 53626 [details]
.docx with hyperlink that appears blue and doublestrikethrough instead of normal black formatted text.

Problem description: 
I received a file which this small sample tries to display. The original had multiple occurences of hyperlinks that were formatted as the text around them. Opened in MS Word 2007 they appear blended with the surrounding text; opened in LibO 3.4.4-release they contain a double strikethrough and are colored blue. Resaving as a .doc in Word2007 results in link appearing blue in libreoffice which I can provide if needed. I am not yet sure of the original application the source file was created in.

Steps to reproduce:
Not yet sure how the link was originally created, but my manual attempts to reproduce it fail so I included the smaller sample; open file in libreoffice and link is no longer formatted the same as surrounding text.

Current behavior:
Link appears blue with double strikethrough. A .doc created form this file in Word2007 will open with link in blue text. Also confirmed on OOo2.4, OOo3.3, and LibO3.3 on FreeBSD as filetypes permitted.

Expected behavior:
Link appears black without any formatting differences from adjacent text under Word 2007.

Platform (if different from the browser):
Windows Vista

Browser: Mozilla/5.0 (X11; FreeBSD amd64; rv:5.0) Gecko/20100101 Firefox/5.0
Comment 1 tester8 2012-01-10 12:14:00 UTC
Reproduced with

LOdev 3.5.0beta2 
4ca392c-760cc4d-f39cf3d-1b2857e-60db978
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI

Link is blue but not double strikethrough.
Comment 2 A (Andy) 2013-05-04 08:50:16 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

Result: As per tester8 the link is blue but not with a double strikethrough.  In Word 2007 the link is black as the rest of the text.
Comment 3 Xisco Faulí 2014-02-28 13:05:42 UTC
it's still present in:
   - Libreoffice 4.1.4.2 Build  ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
   - Libreoffice 4.2.1.1 Build  ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b
   - Libreoffice 4.3.0.0.alpha0 ID: f839b5dd16c05c0eda21345ec36ec0cb024eb732

Change Description from:
   FILEOPEN: .docx hyperlink changes to blue double strikethrough from black text
to:
   FILEOPEN: .docx hyperlink changes to blue from black text
Comment 4 Xisco Faulí 2014-02-28 13:06:03 UTC Comment hidden (obsolete)
Comment 5 Joel Madero 2015-05-02 15:41:19 UTC Comment hidden (obsolete)
Comment 6 Gordo 2015-06-16 18:13:14 UTC
Link is still blue but now it is blinking.

There is a character style named "Internet Link" which has blue and blinking but placing the cursor in the link does not show that as being applied.  Unticking the blinking from the style does affect it though.

Selecting the link and going into Character and unchecking the blinking stops the blinking and makes the text black.  After saving and reloading the text is black but it is still blinking.

Windows Vista 64
Version: 4.4.4.2
Build ID: f784c932ccfd756d01b70b6bb5e09ff62e1b3285
Comment 7 QA Administrators 2016-09-20 10:00:53 UTC Comment hidden (obsolete)
Comment 8 Telesto 2016-12-07 14:15:21 UTC
Reproducible with
Version: 5.4.0.0.alpha0+
Build ID: a9f56091b6422ec8c42f09b8472200ae4ab12548
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-05_23:12:26
Locale: nl-NL (nl_NL); Calc: CL
Comment 9 Xisco Faulí 2017-09-19 12:04:55 UTC
Also reproduced in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 10 Xisco Faulí 2017-09-19 12:05:33 UTC
*** Bug 112490 has been marked as a duplicate of this bug. ***
Comment 11 Justin L 2017-11-01 18:05:46 UTC
<w:hyperlink r:id="rId5" w:tooltip="Kick the bucket" w:history="1">
  <w:r w:rsidRPr="00CD4B83">
    <w:rPr><w:rFonts w:ascii="Times New Roman" w:eastAsia="Times New Roman" w:hAnsi="Times New Roman" w:cs="Times New Roman"/>
      <w:sz w:val="24"/>
      <w:szCs w:val="24"/>
    </w:rPr>
    <w:t>kick the bucket</w:t>
  </w:r>
</w:hyperlink>

Converted into a hyperlink field in LO, and thus it will take on LO hyperlink values and really no long pays any attention to character formatting.
Processed in writerfilter/source/ooxml/Handler.cxx.

@Vasily: still assigned? Good luck to you - looks difficult to solve.
Comment 12 Justin L 2017-11-02 14:35:06 UTC
(In reply to Justin L from comment #11)
> Converted into a hyperlink field in LO, and thus it will take on LO
> hyperlink values and really no long pays any attention to character
> formatting.

bug 96062 seems to have the opposite problem - where character formatting DOES override the hyperlink.
Comment 13 Vasily Melenchuk (CIB) 2017-11-03 08:50:07 UTC
(In reply to Justin L from comment #11)
> @Vasily: still assigned? Good luck to you - looks difficult to solve.
Thanks, but seems I already have a solution: https://gerrit.libreoffice.org/#/c/41784/
In my case and for attached here files it works.

But there are still some things to do left, so it is "-1" for now.
Comment 14 Commit Notification 2017-11-10 01:03:01 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eaa9cf6a3069fba3d82c046f0041bfb537d9e648

tdf#43017: Support for DOCX hyperlinks character properties

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Justin L 2018-08-11 18:33:03 UTC
*** Bug 84340 has been marked as a duplicate of this bug. ***
Comment 16 Justin L 2018-08-23 14:00:21 UTC
*** Bug 103929 has been marked as a duplicate of this bug. ***