Download it now!
Bug 43041 - Add option to choose default slide layout
Summary: Add option to choose default slide layout
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Impress-UX Slide-Layout
  Show dependency treegraph
 
Reported: 2011-11-17 12:27 UTC by ade
Modified: 2017-06-08 12:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ade 2011-11-17 12:27:56 UTC
In 3.4.4 the Layout in Impress defaults to "Title Slide". Add an option for users to choose another default Layout.
Comment 1 sasha.libreoffice 2012-04-21 01:02:40 UTC
Thanks for bugreport
IMHO it done for compatibility with msPower point. It is not problem to do 1 additional click after creating new presentation. 

More important problem is that we can not adjust existing Layouts and Table Designs to our needs.
Comment 2 Joel Madero 2012-07-03 09:50:18 UTC
I tend to agree with Sasha on this one. I think that as it's built is best as it makes it open Impress immediately without a prompt asking what default slide you'd like. I'm going to close this as NOTABUG, it works as intended. Thanks for the suggestion, please feel free to continue recommending changes so that we can continue making LO better for all of our users :)
Comment 3 ade2 2013-06-22 10:21:29 UTC
@Joel Madero: You misunderstood. This concerns a one time option to set the default layout. Let the current "Title Slides" be default on a fresh install, just like now. But let users who want another default layout to go once and for all to tasks pane > layouts, right click the icon for their preferred layout and select "set as default" or something like that. Mark the currently default layout with a colored border (or a green checkmark or...) so the users sees what the current default is.


@sasha: "It is not problem to do 1 additional click after creating new presentation."
It is potentially 4 separate action steps:
click view 
click task pane
click layouts
click the layout you want
Comment 4 sasha.libreoffice 2013-06-24 07:22:14 UTC
@ ade2
Thanks for additional explanations. Sorry for I have forgotten that pane "Tasks" may be closed.

IMHO button "Task pane" can be added on any toolbar for enabling/disabling this pane by one mouse click. At least in 4.0.3 it works. Or assigned on keyboard. I just assigned on F12 and it works. It will spare one mouse click because no need to click on menu.

In any case thanks for idea about disabling this pane. It indeed spares place on screen. And button "FullScreen" not working in Impress (described in another bugreport)
Comment 5 Yousuf Philips (jay) (retired) 2017-06-06 13:39:01 UTC
Have to agree with Sasha and Joel that it defaulting to 'Title Slide' is the best option by default and users shouldnt need to have a configuration option to set it differently, especially as we want users to use templates, either bundled or from elsewhere, which will have its own layout set for the predefined styles.

Heiko, Stuart, Cor: please reopen if you disagree.