Bug 43136 - FILESAVE Unable to use custom paper size if saving in xls and xlsx formats.
Summary: FILESAVE Unable to use custom paper size if saving in xls and xlsx formats.
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
Keywords: filter:xls, filter:xlsx
Depends on:
Blocks: XLS
  Show dependency treegraph
Reported: 2011-11-21 06:36 UTC by ZioTibia81
Modified: 2021-07-05 07:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

Screenshot ilustrating possible options in MS Office (22.68 KB, image/png)
2019-07-03 22:24 UTC, Bartosz

Note You need to log in before you can comment on or make changes to this bug.
Description ZioTibia81 2011-11-21 06:36:33 UTC
- Open a new sheet
- Format -> Page

... see default page format (A4 in my case)

- Change page format on a custom size (45x32cm in my case)
- File -> save as
- Select a name and save in Excel 97/2000/XP/2003

... close calc

Reopen file just saved and you can see that page size is A4 and not custom.

There are no problems saving on ODS format.
Comment 1 ZioTibia81 2012-01-31 00:31:40 UTC
Found in LibO 3.4.3, 3.4.4 and 3.4.5
Comment 2 ZioTibia81 2012-03-19 04:27:05 UTC
Still on
Comment 3 Roman Eisele 2012-05-03 09:22:14 UTC
This is a Calc issue, therefore changed 'Component' field accordingly. Therefore, 'CALC' is no longer necessary in the Summary field.

Changing the version back to LibO 3.4.3 (according to comment #1). Please note that the 'Version' field should contain the EARLIEST version in which the problem is known to exist, NOT the newest one!

Lowering the severity a bit: IMHO this may be an important issue, of course, but not a 'critical' one (no crash, no loss of data, if I understand correctly).
Comment 4 A (Andy) 2014-11-28 22:05:17 UTC
Reproducible with LO, Win 8.1
Comment 5 QA Administrators 2015-12-20 16:10:52 UTC Comment hidden (obsolete)
Comment 6 ZioTibia81 2015-12-20 21:30:06 UTC
Not solved

Version: (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: it-IT (it_IT)
Comment 7 QA Administrators 2017-01-03 19:57:29 UTC Comment hidden (obsolete)
Comment 8 ZioTibia81 2017-01-03 21:38:24 UTC
Not solved.

Build ID: 1:5.1.4-0ubuntu1
Thread CPU: 8; Versione SO: Linux 4.4; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT.UTF-8)
Comment 9 ZioTibia81 2017-01-04 09:46:37 UTC
Not Solved:

Build ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0
Thread CPU: 2; Versione SO: Windows 5.1; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT); Calc: group
Comment 10 QA Administrators 2018-01-05 03:41:27 UTC Comment hidden (obsolete)
Comment 11 ZioTibia81 2018-01-05 08:20:24 UTC
Not solved:

Versione: (x64)
Build ID: 92a7159f7e4af62137622921e809f8546db437e5
Thread CPU: 12; SO: Windows 6.19; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT); Calc: group
Comment 12 Bartosz 2019-07-03 22:24:50 UTC
Created attachment 152545 [details]
Screenshot ilustrating possible options in MS Office

The issue is a limitation of the xlsx and xls format (see above screenshot). 

Maybe we could workaround it by introducing margins?
Comment 13 QA Administrators 2021-07-03 04:03:34 UTC Comment hidden (obsolete)
Comment 14 ZioTibia81 2021-07-05 07:25:05 UTC

Version: (x64) / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 24; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: it-IT (it_IT); UI: it-IT
Calc: threaded