Download it now!
Bug 43193 - Invalid view victor image in DOC
Summary: Invalid view victor image in DOC
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 44868 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-23 03:21 UTC by vilisvir
Modified: 2012-04-08 08:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test file (57.00 KB, application/msword)
2011-11-23 03:21 UTC, vilisvir
Details
Same problem with MS-ODRAW with PPT file in LO Impress (106.50 KB, application/vnd.ms-powerpoint)
2012-01-16 00:20 UTC, Valek Filippov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vilisvir 2011-11-23 03:21:48 UTC
Created attachment 53799 [details]
test file

In LO version 3.3 normal view http://itmag.es/4O4F
In LO version 3.4.4 invalid view http://itmag.es/4z0Re
Regress.
Comment 1 Sebastian@SSpaeth.de 2011-11-25 00:34:13 UTC
Hello, thanks for reporting. Could you elaborate on what is exactly broken? I looked at both screenshots, but could not detect any flaw of difference...
Comment 2 vilisvir 2011-11-25 12:10:10 UTC
The office version 3.4 no longer rotate at a given angle vector elements in the image In 3.3 everything was fine.
Comment 3 tester8 2012-01-11 13:15:41 UTC
Reproduced with

LOdev 3.5.0beta2 
4ca392c-760cc4d-f39cf3d-1b2857e-60db978
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI
Comment 4 Valek Filippov 2012-01-15 18:32:30 UTC
Looks like a regression in [MS-ODRAW] support.
Comment 5 Valek Filippov 2012-01-16 00:20:30 UTC
Created attachment 55625 [details]
Same problem with MS-ODRAW with PPT file in LO Impress
Comment 6 Ivan Timofeev (retired) 2012-01-16 11:13:38 UTC
It seems I've found the guilty commit: http://cgit.freedesktop.org/libreoffice/core/commit/?id=1fbbd6134573beedc72a3839d65b27dfc829f2fb 
Need a partial revert, no time right now, will do it soon.

P.S. The bad code design is more guilty here I think...
Comment 7 Ivan Timofeev (retired) 2012-01-16 22:18:41 UTC
fixed in master (future 3.6):
http://cgit.freedesktop.org/libreoffice/core/commit/?id=005d6524977bd51ce2f859b5ae5352a2fba68dd0
sent a proposal to mailing list for pushing it to 3-5 and 3-4...
Comment 8 Ivan Timofeev (retired) 2012-01-17 20:21:31 UTC
*** Bug 44868 has been marked as a duplicate of this bug. ***
Comment 9 Ivan Timofeev (retired) 2012-01-17 20:24:08 UTC
Cherry-picked to the libreoffice-3-5 branch (will be in RC1):
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=5854477486daafbca2a91df6a16701c358f81f6e
Comment 10 sasha.libreoffice 2012-01-18 01:32:03 UTC
Thanks for repair!
Comment 11 Ivan Timofeev (retired) 2012-01-25 20:38:28 UTC
Backported to the libreoffice-3-4 branch (will be in 3.4.6)
http://cgit.freedesktop.org/libreoffice/filters/commit/?h=libreoffice-3-4&id=3475d300ef29866542007e295569075e592bde66
Comment 12 tester8 2012-01-28 10:00:41 UTC
> Cherry-picked to the libreoffice-3-5 branch (will be in RC1)
Still reproducible for me with 3.5RC2.

LOdev 3.5.0rc2
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI
Comment 13 Ivan Timofeev (retired) 2012-01-28 10:40:58 UTC
(In reply to comment #12)
> > Cherry-picked to the libreoffice-3-5 branch (will be in RC1)
> Still reproducible for me with 3.5RC2.

Hmmm, very strange. Are you sure that your test file was not modified?...
Comment 14 tester8 2012-02-03 01:04:02 UTC
>Are you sure that your test file was not modified?...
I am Sure.

Anyway now it is ok with 3.5rc3.
Comment 15 Rainer Bielefeld Retired 2012-04-08 08:37:04 UTC
Checked this on during my research for "Bug 43752 - VIEWING: Rotated flipped shapes in 3.4 drawings loose rotation opened in 3.5" again with 3.5.2, looks OK