Bug 43383 - FILEOPEN: via Hyperlink from document does not work
Summary: FILEOPEN: via Hyperlink from document does not work
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected)
Master old -3.6
Hardware: Other Windows (All)
: medium blocker
Assignee: Not Assigned
Whiteboard: BSA
Keywords: regression
Depends on:
Reported: 2011-11-30 09:19 UTC by Rainer Bielefeld Retired
Modified: 2011-12-08 07:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

Test kit (10.35 KB, application/zip)
2011-11-30 09:19 UTC, Rainer Bielefeld Retired

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-11-30 09:19:18 UTC
Created attachment 53974 [details]
Test kit

Steps to reproduce with Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: a653e50-1f92ab1-3bd0388]" Win-x86@6  - 111128):

1. download and unzip "TestKitLinktest.zip"
2. Start LibO from WIN All Programs
   LibO Start Center appears
3. Menu 'File -> open -> "WithLink2.ods" - <open>'
   Spredsheet document will be opened
4. Click one of the links (with pressed <control> if necessary
   due to your security settings
   Expected: Document "Linktarget.ods" should be opened 
   Actual: Nothing

- Reported with Bug Submission Assistant -

Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0.1) Gecko/20111121 Firefox/8.0.1 SeaMonkey/2.5
Comment 1 Rainer Bielefeld Retired 2011-11-30 09:21:28 UTC
Currently only WIN tested

An internal link to an other sheet worked
Comment 2 Rainer Bielefeld Retired 2011-12-01 02:00:13 UTC
Works with Server installation of  Master "LibO-dev 3.5.0 – WIN7 Home Premium
(64bit) GERMAN UI [Build ID: 130028f-b211287-090bcba-45cf606-05891e7]"
Win-x86@9-Voreppe  - 111130)

Bug gone or build specific?
Comment 3 manj_k 2011-12-01 13:02:20 UTC
Tried steps 1-4 from 'Description':
document "Linktarget.ods" has been opened (as expected).
Works for me.

Tested with
LibO-dev 3.5.0 · Build ID: 2d0998f-090bcba-45cf606
(UI en-US; on WinXP 32b)
[ master~2011-12-01_08.37.54_libodev35.msi · 01-Dec-2011
http://dev-builds.libreoffice.org/daily/Win-x86@6-fast/master/ ].
Comment 4 Rainer Bielefeld Retired 2011-12-01 22:02:17 UTC
No longer reproducible with Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID:  2d0998f-090bcba-45cf606]" Win-x86@6 - 2011-12-01_08.37.54)
Comment 5 Rainer Bielefeld Retired 2011-12-02 11:24:10 UTC
Problem is back with Server Installation of  "LibreOffice 3.5.0 Beta0  - WIN7 Home Premium (64bit) German UI [Build:ef91e38-b1d4df6-090bcba-45cf606-05891e7]".
I did a Server installation because of [Bug 43454] Break-off with message "Terminate Quick Starter", modified Bootstrap.ini:
  UserInstallation=$SYSUSERCONFIG/LibreOffice/3 ->
What created a fresh new profile folder.
I did that often, with 3.4 betas, always worked.
Comment 6 manj_k 2011-12-02 11:58:13 UTC
(In reply to comment #5)
> Problem is back with Server Installation of  "LibreOffice 3.5.0 Beta0  - WIN7
> Home Premium (64bit) German UI
> [Build:ef91e38-b1d4df6-090bcba-45cf606-05891e7]". [...]

Yes, that happened for me (on WinXP 32b) with LibO 3.5.0 Beta0, too.
My more complete result (tested with Writer or Calc):
I cannot open any second file via
File > Open ...
File > Recent Documents ...
File > New ...
Comment 7 manj_k 2011-12-02 14:38:11 UTC
For the record:

That bug (see 'Description', and 'Comment #6') doesn't occur with
LibO-dev 3.5.0 · Build ID: 0f1b0e5-090bcba-f9c8e88
[ master~2011-12-02_09.45.42_libodev35.msi  02-Dec-2011 14:44
http://dev-builds.libreoffice.org/daily/Win-x86@6-fast/master/current/ ].

It is not worth the trouble.  ;)
Comment 8 Rainer Bielefeld Retired 2011-12-02 22:06:08 UTC
New due to Comment 6

Modification of "bootstrap.ini": "UserInstallation=$ORIGIN/../Data/settings" does not help, and it's not only a problem in CALC, Also links (old or new ones) in WRITER will not work.

3.5.0 can't be shipped with that bug, correct function in Master does not help, that would be too late for 3.5.0

I can open lots of documents until I tried a hyperlink. From that moment opening further documents is completely broken.
Comment 9 Pedro 2011-12-04 04:17:29 UTC
Seems to be fixed in 3.5.0 (Build ID: a286353-090bcba-3bf3b94) running under Win XP Pro x86 SP3
Comment 10 Rainer Bielefeld Retired 2011-12-04 07:24:10 UTC
Today NOT reproducible with Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID:  a286353-090bcba-3bf3b94]" Win-x86@6 – 2011-12-02_22:36:35)

Let's wait for 1 further build and test before we close it, might be an intermitting problem.

Please add tinderbox timestamp to build info
Comment 11 Petr Mladek 2011-12-08 07:01:28 UTC
I think that the bug was there only few days or hours. Unfortunately, we did beta0 with it :-(

It is well reproducible with beta0 but not with newer daily builds => look fixed => closing.