Bug 43442 - Calc UI: Preselected options in Paste Special dialog are not sensible
Summary: Calc UI: Preselected options in Paste Special dialog are not sensible
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 42933 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-01 17:08 UTC by Ed
Modified: 2015-07-14 21:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed 2011-12-01 17:08:03 UTC
I am running Calc on Windows XP.  

When you bring up the Paste Special dialog (using Shift-Ctrl-V for example), it has the 'Paste all' option preselected.  Surely it does not make sense to have this preselected, since the reason we opened that dialog is precisely because we didn't want to paste everything?  

If you then deselect 'Paste all', you get all the options beneath it preselected.  This amounts to paste-all I believe.  The above criticism applies to this as well.  

Would it not make sense to have NONE of these options preselected?  

If we must have something preselected, I would suggest that the commonest use of the Paste Special operation is to paste a formula without pasting the formats of its source cell, so to have just 'Formulae' preselected could be sensible.
Comment 1 sasha.libreoffice 2012-04-27 07:17:59 UTC
Thanks for bugreport
reproduced in 3.3.4 and 3.5.2 on Fedora 64 bit
After removing "Paste all", selected all options except "Numbers".
If we change those options, they not saved after closing/opening office
Comment 2 Carl 2012-11-30 09:53:41 UTC
I and others ( http://ask.libreoffice.org/question/7950/how-to-paste-special-without-8-clicks-the-1st-time/ ) heartily concur.  In my case, I most often paste only numbers, or only formats. As it is, it takes me 8 clicks after the Paste Special dialog is open before I can click OK. Yeah, this is only the first time it is used, but it is every first time, and an unnecessary, counter-intuitive, nuisance.  

To please the most people, I would think the default/initial option should be either the last method used, or nothing selected at all. I would prefer the former.  

The most ridiculous option being the current behavior, PasteAll selected, since that is the one thing you for sure will NOT be wanting to do.  Followed closely by having everything BUT Numbers selected when PasteAll is deselected. When PasteAll is deselected, everything should be deselected, except (if possible) the previously used single selection.
Comment 3 bugquestcontri 2012-11-30 14:03:04 UTC
My propsal would be 

1 - nothing is selected by default and every user can choose what he/she wants to paste without deselecting what is not needed 

2 - add a customized "remember" - click what should be pasted and behind the text another checkmark "remember". The "remember can be kept checked or changed on the fly depending on the work a user is doing. A default setting in the Options is too time consuming to change. 
I  would most often keep "Numbers" remembered, sometimes #Comments" and "Formula"

This would increase productivity a lot!
Comment 4 Robert Roth 2013-02-05 09:24:24 UTC
*** Bug 42933 has been marked as a duplicate of this bug. ***
Comment 5 p199999991 2013-07-07 08:51:00 UTC
I would like (at least) to be able to paste:
1. Just all Text, Numbers and Date & Time.
2. Just the Formats.

In a reproducible (consistent) way without using the mouse. This seems to be impossible in LibreOffice without using macros or external programs.

Would be glad to see an improvement in this :)
Comment 6 p_kongstad 2014-06-02 13:28:22 UTC
Hi,

Please be kind and back port this to 4.2.x for 4.3

i#123626 change default for paste special dialog of Calc... [Tsutomu Uchino]
Comment 7 Cor Nouws 2014-10-18 20:08:17 UTC
Hi,

Since 4.3 (?) there is the new Paste Special dialog. With preset of often used settings. Hurray :)
Comment 8 Nis Jørgensen 2015-07-08 23:07:16 UTC
This had been set to resolved, apparently based on the "Paste Only X" context menu options having been added.

This doesn't cover all use cases, and doesn't change the fact that the current default for "Paste Special" is illogical. Thus I reopen the bug.
Comment 9 Cor Nouws 2015-07-09 07:06:04 UTC
Hi Nis,

(In reply to Nis Jørgensen from comment #8)
> This had been set to resolved, apparently based on the "Paste Only X"
> context menu options having been added.

You missed that there is a whole new paste special dialog with new sensible default options and three extra most used choices at the top..?

> This doesn't cover all use cases, and doesn't change the fact that the
> current default for "Paste Special" is illogical. Thus I reopen the bug.

Please give clear information on what you think could be further improved.
thanks,
Cor
Comment 10 Cor Nouws 2015-07-14 21:27:14 UTC
(In reply to Cor Nouws from comment #9)
> Please give clear information on what you think could be further improved.
> thanks,

Working on some issues, I close this one as WorksForMe.
If you give clear information as asked, then please reopen the issue.
Thanks,
Cor