Bug Hunting Session
Bug 43868 - FILEOPEN document saved with password: correct password not recognized
Summary: FILEOPEN document saved with password: correct password not recognized
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.5 RC1
Hardware: x86-64 (AMD64) All
: highest blocker
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard: target:3.5.0
Keywords: regression
: 44095 44541 44542 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-12-15 14:10 UTC by gerdl
Modified: 2012-02-26 23:34 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gerdl 2011-12-15 14:10:45 UTC
thank god, 3.5 beta 1 opened them. terrible scenery. 
it seems, that no changes have been made on the file by (mis-)trying to open it.
15.12.2011
please save a calc-file under 3.4.5 rc1 with password and try to reopen it.
3.5 beta 1 was able to open it with the correct password.
os: win 7 64 
15.12.2011
Comment 1 Markus Mohrhard 2011-12-15 17:24:14 UTC
Could you add a simple test document?
Comment 2 Rainer Bielefeld Retired 2011-12-15 23:43:38 UTC
[Reproducible] with "LibreOffice 3.4.5 RC1  - WIN7 Home Premium (64bit) German UI [Build ID: OOO340m1 (Build:501)]"

steps to reproduce:
1. Start LibO
   > Start Center appears
2. New Spreadsheet Document
   > opens
3. Type an "x" to A1
4. Menu (LibO dialogs) 'File -> Save as - Filename = "test" - 
   Save sith PW checked
   > WP dioalog appears
5. type password "password" and confirm "password"  <ok>
6. Menu 'File -> Close'
7. Menu 'File -> Recent Documents - select "test.ods"  <open>
   > PW dialog appears
8. Type  "password" <ok>
   Expected: document will be opened
   Actual: Message "Invalid Password"
   
Document will be opened without problems with 3.5.0 Beta1 or Portable 3.3.3

Same with document created with 3.4.4, so FILEOPEN problem

@Markus:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 3 Cor Nouws 2011-12-15 23:54:31 UTC
Hi, I guess this is Bug 40006 - default ODF encryption etc algorithms changed, so encrypted/protected documents from master cannot be opened in <= 3.4.X
Comment 4 Rainer Bielefeld Retired 2011-12-16 00:07:24 UTC
@Cor:
I can't tell whether there is a relation. Here we are speaking about the problem that Libo 3.4.5 can't open a document that it saved 3 seconds ago, no different LibO versions are involved.
Comment 5 Cor Nouws 2011-12-16 00:12:58 UTC
@Rainer: I bet there is a relation. Stephan may want to have a look?
BTW: gerdi: thanks for testing/finding this!
Comment 6 Stephan Bergmann 2011-12-16 00:29:03 UTC
<irc://chat.freenode.net/libreoffice-dev>:

"Dec 15 11:22:52 <sberg> thorsten, 309f56174aca6adca879f70958892492361dac6e apparently broke password protected documents; opening old ones does no longer work ('wrong password,' cf sc_subsequent_filters_test testPassword), and writing new ones gives 'warn:legacy.osl:2705:1:/data/lo/core/package/source/xstor/owriteablestream.cxx:1336: Can't write encryption related properties!' (and opening again does not work either)"

"Dec 15 11:30:45 <thorsten> sberg: shit, that fix went to 3.4.5 - how twisted is that thing, manual review didn't turn up anything :("
Comment 7 Rainer Bielefeld Retired 2011-12-16 01:10:18 UTC
Not only CALC is affected, I also failed to open a WRITER document created with 3.5.0Beta1. Here the difference is that 3.4.5RC1 WRITER even is unable to save a document with password protection, Error message (General input output error) appears.
Comment 8 Rainer Bielefeld Retired 2011-12-16 01:11:51 UTC
To avoid misunderstanding: Also a protected document created with 3.3.3 Portable will not be opened with 3.4.5 RC1
Comment 9 Petr Mladek 2011-12-22 02:19:45 UTC
Thorsten, I think that you worked on this. Was it solved in the libreoffice-3-4,
libreoffice-3-4-5, and libreoffice-3-5 branches?

Note that there is also problem with saving password protected files, see the bug #41089.
Comment 10 Thorsten Behrens (CIB) 2011-12-22 15:34:18 UTC
(In reply to comment #9)
> Thorsten, I think that you worked on this. Was it solved in the
> libreoffice-3-4,
> libreoffice-3-4-5, and libreoffice-3-5 branches?
> 
Properly fixed for master and -3-5, reverted original fix for -3-4, pending review for -3-4-5 (thanks for the poke, had missed the branch-off there).
Comment 11 Petr Mladek 2011-12-23 02:49:24 UTC
Fix has been approved and pushed to 3-4-5 => FIXED
Comment 12 Rainer Bielefeld Retired 2011-12-23 10:04:57 UTC
*** Bug 44095 has been marked as a duplicate of this bug. ***
Comment 13 manj_k 2012-01-05 11:56:21 UTC
Verified - 
FILEOPEN with password protection works fine with LibO 3.4.5 RC2 
(tested: Writer · on WinXP 32b).

For the record:
Also OK for password protected files, created with
LibO 3.3.4 release
LibO 3.4.4 release
LibO 3.5.0 Beta2
LibO 3-5 LOdev 3.5.0beta2+ Build ID: 2650c80-7ef74e0-dee380a
(libreoffice-3-5~2012-01-02_22.09.08...)
Comment 14 Rainer Bielefeld Retired 2012-01-06 23:48:45 UTC
*** Bug 44541 has been marked as a duplicate of this bug. ***
Comment 15 Rainer Bielefeld Retired 2012-01-07 11:06:56 UTC
*** Bug 44542 has been marked as a duplicate of this bug. ***
Comment 16 Ismael Cedillo 2012-01-10 08:59:55 UTC
I saw that the testes for this report were made on Windows 32b, and I really don't know if with a report for this bug in Windows-32b is enough... but I forgot to mark that it was identified on

Ubuntu 11.10
X86-64 system
and LibreOffice 3.4.5 OOO340m1 (Build:501)

Thanks,
Comment 17 Ismael Cedillo 2012-01-10 09:22:02 UTC
The bug was solved in the 3.4.5 RC2 build 502. 

Thanks
Comment 18 Rainer Bielefeld Retired 2012-01-10 10:11:37 UTC
*** Bug 44542 has been marked as a duplicate of this bug. ***
Comment 19 Rainer Bielefeld Retired 2012-01-10 10:15:16 UTC
I revert pickers to correct selections
Comment 20 manj_k 2012-01-10 12:58:10 UTC
*** Bug 44541 has been marked as a duplicate of this bug. ***
Comment 21 Rainer Bielefeld Retired 2012-01-24 09:03:16 UTC
"Bug 44542 - FILEOPEN impossible for documents that were saved with password" still does not work with "LibreOffice 3.4.5 German UI
[Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7
Home Premium (64bit).
Comment 22 Cor Nouws 2012-01-24 10:37:14 UTC
(In reply to comment #21)
> "Bug 44542 - FILEOPEN impossible for documents that were saved with password"
> still does not work with "LibreOffice 3.4.5 German UI
> [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7
> Home Premium (64bit).

then a bug in that version? reopen I would say...
I tried (again) with Linux International/Dutch langpack this weekend. 3.3.4 <> 3.4.5 <> 3.5.0.
Was OK.
Comment 23 Rainer Bielefeld Retired 2012-01-24 10:53:37 UTC
(In reply to comment #22)

> then a bug in that version? reopen I would say...

May be that there is a little damage in my installation (my LibOs have a hard life), 3.4.5 on WIN XP (VirtualBox) opens sample from "Bug 44542 - FILEOPEN impossible for documents that were saved with password" without problems. Or can it be a problem of a server installation?
Comment 24 Petr Mladek 2012-01-25 05:52:03 UTC
It works here on Windows XP SP3 i586 with "LibreOffice 3.4.5 EN_US UI
[Build ID: OOO340m1 (Build:502)]" with the server installation.

So, it rather looks like a problem with your local installation.

Note that we simply reverted the commit that caused all these problems with passwords => 3.4.5-rc2 should work the same way as 3.4.4 in this regard.
Comment 25 Raould 2012-02-26 20:30:18 UTC
I have LibreOffice 3.4.5 OOO340m1 (Build:502) on Ubuntu 11.10.
Last week I could open my password-protected file, this week I cannot (with 3.4.5).  On Linux Mint, with LibreOffice 3.4.4, the same file opens fine.
Comment 26 Raould 2012-02-26 20:37:51 UTC
(In reply to comment #25)
> I have LibreOffice 3.4.5 OOO340m1 (Build:502) on Ubuntu 11.10.
> Last week I could open my password-protected file, this week I cannot (with
> 3.4.5).  On Linux Mint, with LibreOffice 3.4.4, the same file opens fine.

I also cannot save a file with password protection (test file is also a Calc spreadsheet).  Message is "Error saving the document pwtest:  General Error.  General input/output error."
Comment 27 Markus Mohrhard 2012-02-26 23:32:48 UTC
(In reply to comment #25)
> I have LibreOffice 3.4.5 OOO340m1 (Build:502) on Ubuntu 11.10.
> Last week I could open my password-protected file, this week I cannot (with
> 3.4.5).  On Linux Mint, with LibreOffice 3.4.4, the same file opens fine.

Can you check if the firefox or thunderbird version changed in this week?
Comment 28 Markus Mohrhard 2012-02-26 23:34:22 UTC
And correct bug for this problem is bug 45171.

Sorry did not notice it earlier.