Bug Hunting Session
Bug 44275 - Letter-size landscape 2-column document shown as Custom size in Laser PRINTING properties dialog
Summary: Letter-size landscape 2-column document shown as Custom size in Laser PRINTIN...
Status: RESOLVED DUPLICATE of bug 33791
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-29 06:43 UTC by lanasth
Modified: 2013-01-29 05:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Zip contains an example screenshot and an ODT with the problem (174.86 KB, application/x-zip-compressed)
2011-12-29 06:43 UTC, lanasth
Details
ZIP contains an ODT, DOC, DOCX, and PNG illustrating the landscape issue (71.83 KB, application/unknown)
2012-02-28 05:24 UTC, lanasth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lanasth 2011-12-29 06:43:01 UTC
Created attachment 54941 [details]
Zip contains an example screenshot and an ODT with the problem

I haven't tested how many different kinds of printers this bug affects, but it definitely applies to all of the old HP 'workhorse' laser printers at my work.  It DOES NOT affect exporting to PDF or any PDF/XPS psuedo-printers.  The key problem appears to arise when two columns are added to a landscape document.

I've attached a screenshot to demonstrate the printing problem.  To reproduce:

1) Create a new letter-size (i.e.the default) document with two columns of text in landscape. (I typically enter the page-style dialog by double-clicking "Default" in the Writer status bar)
2) Print this document with a business-class (older) laser printer.
3) If you're not careful, the print preview shows you that the page is not oriented properly.  To get the preview (and print) correct, you must enter the printer 'Properties' and change both the "Original size" and "Printout paper size" dialogs to say Letter size paper -- and get these settings to stick (i.e. check this by repeating the 'Properties' dialog.

I cannot figure out what consistently makes the two printer settings "stick", but I usually have to adjust it several times.
Comment 1 Cor Nouws 2012-02-06 15:13:59 UTC
Knowing all the comments, I confirm this 'unseen' ;-)

Obviously related to Bug 33791 - Print system fails to use or allow user to select correct paper size for printing
Comment 2 sasha.libreoffice 2012-02-16 02:01:58 UTC
@ lanasth@gmail.com
My be workaround from this bug will help:
Bug 44664 - Calc PRINTING: printer prints Landscape page orientation as Portrait
Comment 3 lanasth 2012-02-16 04:35:10 UTC
I have no such option for changing any PS/PDF setting for my Cannon PIXMA 870 (Win 7 64bit). I'm not sure that my old HP lasers at work even have a PDF option either.  I think they're all PS by default. But this workaround sounds suspicious to me anyway.
Comment 4 lanasth 2012-02-27 13:17:19 UTC
(In reply to comment #3)
> I have no such option for changing any PS/PDF setting for my Cannon PIXMA 870
> (Win 7 64bit). I'm not sure that my old HP lasers at work even have a PDF
> option either.  I think they're all PS by default. But this workaround sounds
> suspicious to me anyway.

Following up, I cannot find any such PDF-setting in any of these old PS-printer.
Comment 5 sasha.libreoffice 2012-02-28 02:22:16 UTC
Sorry for bad advice. It is completely another bug.
So, in short:
Document is Landscape and printer proposes print it as Portrait, and we need change settings each time before print?
In preview of "Print" dialog document seen as it will be printed (we can see problem before printed) ?
Changes to printing settings disappear after printing (but before close Writer) or only after closing Writer?
If available for testing, how behaves Open office, msWord, other version of Windows?
Comment 6 lanasth 2012-02-28 05:24:34 UTC
Created attachment 57765 [details]
ZIP contains an ODT, DOC, DOCX, and PNG illustrating the landscape issue
Comment 7 sasha.libreoffice 2012-02-28 05:36:23 UTC
Thanks for attachment. As I can understand, in "Print" dialog we can see
problem before printed. But, please, answer on another questions from comment 5. And which version of Windows is used?
Comment 8 lanasth 2012-02-28 06:01:08 UTC
(In reply to comment #5)
> Sorry for bad advice. It is completely another bug.
> So, in short:
> Document is Landscape and printer proposes print it as Portrait, and we need
> change settings each time before print?
> In preview of "Print" dialog document seen as it will be printed (we can see
> problem before printed) ?
> Changes to printing settings disappear after printing (but before close Writer)
> or only after closing Writer?
> If available for testing, how behaves Open office, msWord, other version of
> Windows?

Ugh, this bug report forgot all my replys when I went to attach a file.
1) Actually, since updating to the official 3.5.0 release (which in the credits still says 3.5.0rc3), I cannot get the ODT print settings to "stick" at all. The "Original size:" option in the printer settings is stuck on "Custom paper size...".
2) I have tested that the preview in the "Print" dialog matches what actually prints numerous times after each new release. My only recourse for getting a correct printout is to either save as PDF, or use a PDF/XPS pseudo-printer (e.g. PDF Creator), and then print the PDF or XPS file.
3) Even when I was able to change the settings (one time), those settings did not stick even for the next time I told Writer to Print, much less any other document or editing session.
4) I have tested saving as a DOC and DOCX in the new attachment. They look fine in Word 2007. I don't have OpenOffice or another Windows OS to test it on. Between home and office I have tested on 4 boxes, which all have Windows 7 64-bit SP1 (some Premium and some Professional). The problem only affects all of our workhorse HP postscript laser printers at work -- not our heavy duty copy/printer, a Canon iR C4080/C4580 UFR II, or any other inkjet that I've tried. It is affecting all of the network printers that show up in my printer devices as RICOH Aficio AP610N RPCS, even though they are actually different HP printers. What I just now realized, though, is that the problem also DOES affect a RICOH Aficio AP600N PS printer that shows up in my immediate network neighborhood -- only the RICOH Aficio AP610N RPCS printers that only show up on a different (but related) network. Thus, it appears to be related to network printers that are not in the same local network as the computer with LO.
Comment 9 lanasth 2012-02-28 06:06:07 UTC
(In reply to comment #5)
> Sorry for bad advice. It is completely another bug.
> So, in short:
> Document is Landscape and printer proposes print it as Portrait, and we need
> change settings each time before print?
> In preview of "Print" dialog document seen as it will be printed (we can see
> problem before printed) ?
> Changes to printing settings disappear after printing (but before close Writer)
> or only after closing Writer?
> If available for testing, how behaves Open office, msWord, other version of
> Windows?

Ugh, this bug report forgot all my replys when I went to attach a file.
1) Actually, since updating to the official 3.5.0 release (which in the credits still says 3.5.0rc3), I cannot get the ODT print settings to "stick" at all. The "Original size:" option in the printer settings is stuck on "Custom paper size...".
2) I have tested that the preview in the "Print" dialog matches what actually prints numerous times after each new release. My only recourse for getting a correct printout is to either save as PDF, or use a PDF/XPS pseudo-printer (e.g. PDF Creator), and then print the PDF or XPS file.
3) Even when I was able to change the settings (one time), those settings did not stick even for the next time I told Writer to Print, much less any other document or editing session.
4) I have tested saving as a DOC and DOCX in the new attachment. They look fine in Word 2007. I don't have OpenOffice or another Windows OS to test it on. Between home and office I have tested on 4 boxes, which all have Windows 7 64-bit SP1 (some Premium and some Professional). The problem only affects all of our workhorse HP postscript laser printers at work -- not our heavy duty copy/printer, a Canon iR C4080/C4580 UFR II, or any other inkjet that I've tried. It is affecting all of the network printers that show up in my printer devices as RICOH Aficio AP610N RPCS, even though they are actually different HP printers. What I just now realized, though, is that the problem also DOES affect a RICOH Aficio AP600N PS printer that shows up in my immediate network neighborhood -- only the RICOH Aficio AP610N RPCS printers that only show up on a different (but related) network. Thus, it appears to be related to network printers that are not in the same local network as the computer with LO.
Comment 10 sasha.libreoffice 2012-02-28 06:11:38 UTC
Thanks for additional testing and information. Yet one question I have:
Problem appears in version 3.5.0? In 3.4 or 3.3 all was correctly working?
Comment 11 lanasth 2012-02-28 06:38:09 UTC
(In reply to comment #10)
> Thanks for additional testing and information. Yet one question I have:
> Problem appears in version 3.5.0? In 3.4 or 3.3 all was correctly working?

I'm not sure about 3.3, but I am sure that it has been around since the 3.4 betas. I upgraded from XP Pro 32 bit to Win 7 64 bit (both at home and work) around the time the 3.4 betas were released, which is when the problem started for me. I just can't remember now if I ever tested a new landscape print in XP with LO 3.3 (in Win 7). I am sure that I printed an OpenOffice-generated ODT in landscape with LO 3.3 on my old XP machines. I just don't know if I ever tested LO 3.3 with a new landscape doc since Win 7. I'm only sure that the problem affected LO since Win7 64 and the 3.4 betas.
Comment 12 lanasth 2012-02-28 06:39:14 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > Thanks for additional testing and information. Yet one question I have:
> > Problem appears in version 3.5.0? In 3.4 or 3.3 all was correctly working?
> 
> I'm not sure about 3.3, but I am sure that it has been around since the 3.4
> betas. I upgraded from XP Pro 32 bit to Win 7 64 bit (both at home and work)
> around the time the 3.4 betas were released, which is when the problem started
> for me. I just can't remember now if I ever tested a new landscape print in XP
> with LO 3.3 (in Win 7). I am sure that I printed an OpenOffice-generated ODT in
> landscape with LO 3.3 on my old XP machines. I just don't know if I ever tested
> LO 3.3 with a new landscape doc since Win 7. I'm only sure that the problem
> affected LO since Win7 64 and the 3.4 betas.

I don't have the old OO landscape document anymore to test now.
Comment 13 sasha.libreoffice 2012-02-28 06:47:10 UTC
So, how I understand:
In printer settings in field "Original size" appears "Custom paper size", but should be "Letter", this happens each time when we print document, even if not exit Writer.
In previous LibreOffice version on current Windows not tested and in version 3.5.0 on XP not tested.
Comment 14 lanasth 2012-02-28 07:10:14 UTC
(In reply to comment #13)
> So, how I understand:
> In printer settings in field "Original size" appears "Custom paper size", but
> should be "Letter", this happens each time when we print document, even if not
> exit Writer.
> In previous LibreOffice version on current Windows not tested and in version
> 3.5.0 on XP not tested.

1) correct.
2) I have tested and noticed this bug ever since the LO 3.4 betas on several up-to-date Win 7 64 bit machines. It did not affect LO 3.3 with XP Pro (32 bit), and I do not know if it affected LO 3.3 with Win 7 64bit.
Comment 15 Rainer Bielefeld Retired 2013-01-29 05:40:22 UTC
It seems that reporter's problem never has been confirmed. Currently it's only known tat reporter suffers from the Bug, so not a MAB.

I modify Version due to comment 14

To be honest, I am not sure whether I understand the problem, I took sasha's summary in comment 13 for my tests.

NOT reproducible with "LibO  4.0.0.2 rc   -  GERMAN UI / German Locale  [Build ID: 5991f37846fc3763493029c4958b57282c2597e)]"  {tinderbox: @6, pull time 2013-01-24  07:20(?)} on German WIN7 Home Premium (64bit) with User Profile automatically created form renamed /3 User profile used by 3.6.5.2
With a Samsung CLX 3185 for all documents from Untitled.zip the correct paper size has been recognized in all dialogs I checked

I mark this one as DUP of "Bug 33791 - Print system fails to use or allow user to select correct paper size for printing" for now.

@lanasth:
All here in Bugzilla is about bugs, so "printig bug" is not very meaningful. Please always contribute a brief, but precise summary line. And we need 1 precise description how to reproduce with 1 document.

Please feel free to reopen this Bug if you find evidence that we have an independent issue here  (for example because the fix for the other bug does not work for you).

*** This bug has been marked as a duplicate of bug 33791 ***
Comment 16 Rainer Bielefeld Retired 2013-01-29 05:55:48 UTC
Forgot to mention: also with Server Installation of   "LibreOffice 3.4.5 English UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit) and Samsung Printer always the correct Lettr Size paper format was shown in menu 'file -> Print -> General -> Printer Properties'