Bug 44399 - UI: Format Cells dialog displays misleading value for 'Decimal places'
Summary: UI: Format Cells dialog displays misleading value for 'Decimal places'
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Laurent BP
URL:
Whiteboard: BSA target:5.1.0 target:5.0.2
Keywords:
: 70316 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-02 13:30 UTC by Ed
Modified: 2016-10-25 19:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed 2012-01-02 13:30:22 UTC
LibO on Windows XP.  

When you open the Format Cells dialog for a cell you have not previously formatted, the 'Format' is preselected as "General", and the 'Decimal places' is preselected as 0.  This is contradictory: the General format has no defined number of decimal places, and will display as many decimal places as the value has that is in the cell (up to a point).  Furthermore this presentation may lead the user to think that he/she can set the decimal places to zero just by pressing Return on this dialog presented in this state, but this, of course, does not set the decimal places.  

I would suggest that this dialog contains a blank value for 'Decimal places' when 'Format' is "General".
Comment 1 sasha.libreoffice 2012-04-02 07:34:34 UTC
reproduced in 3.3.4 and 3.5.1 on Fedora 64 bit and Windows XP 32 bit
Changing version to 3.3.4 as most early reproducible
Comment 2 ign_christian 2013-10-09 12:59:43 UTC
*** Bug 70316 has been marked as a duplicate of this bug. ***
Comment 3 QA Administrators 2015-04-01 14:41:40 UTC Comment hidden (obsolete)
Comment 4 Ed 2015-04-01 21:02:08 UTC
Retested in LO 4.3.3.2 on Debian Linux: issue is still present.
Comment 5 Commit Notification 2015-07-31 11:31:31 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0db37d785311aa2294f60b750fce4dadff6c75e0

tdf#44399 Do not display 0 decimal for General format

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2015-08-17 10:21:01 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=26b3ca54aff24c34718c572675ad72b9687b3adb&h=libreoffice-5-0

tdf#44399 Do not display 0 decimal for General format

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.