Bug Hunting Session
Bug 44469 - VIEWING: PPT slides containing Picture Objects pasted from Excel not displayed correctly
Summary: VIEWING: PPT slides containing Picture Objects pasted from Excel not displaye...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-04 15:49 UTC by dr_tak
Modified: 2018-01-04 17:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of slide that is not displayed as expected (207.50 KB, application/vnd.ms-powerpoint)
2012-04-02 10:01 UTC, dr_tak
Details
screenshot of attachment made in msPP 2003 on Windows XP (74.90 KB, image/jpeg)
2012-04-03 03:07 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dr_tak 2012-01-04 15:49:03 UTC
Problem description: 

Steps to reproduce:

1. Open PPT presentation containing slides depicting MS Excel 2003 graphs pasted as Picture Objects (not bitmap)

2. Try viewing the slide in Edit mode or Slide show mode

Current behavior: Legends, grids and axes are visible in Slideshow mode only, no graph is visible in either modes.

Expected behavior: the entire graphs should be displayed in all cases, including the thumbnails.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; en-us) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1
Comment 1 dr_tak 2012-01-05 12:45:20 UTC
May be related to bug # 42927.
Comment 2 sasha.libreoffice 2012-04-02 07:37:19 UTC
Thanks for bugreport
Please, attach ppt file with one slide that demonstrates this problem
Comment 3 dr_tak 2012-04-02 10:01:42 UTC
Created attachment 59390 [details]
Example of slide that is not displayed as expected

Microsoft Powerpoint Slide (2003-present)
Comment 4 dr_tak 2012-04-02 10:04:36 UTC
The slide is displayed best (as it was displayed in Excel) in Neo Office, and somewhat differently (thicker lines and slightly different colors) but still legibly in OpenOffice.
Comment 5 sasha.libreoffice 2012-04-03 03:05:05 UTC
Thanks for attachment
reproduced in 3.3.4 and 3.5.1 on Fedora 64 bit (no graphs)
on Windows not reproducible, therefore Unix specific bug
Changing version to 3.3.4 as most early reproducible and OS to Linux as more widely used.
PS: We should not forget retest it on MacOS X after bug will be fixed
Comment 6 sasha.libreoffice 2012-04-03 03:07:39 UTC
Created attachment 59412 [details]
screenshot of attachment made in msPP 2003 on Windows XP
Comment 7 A (Andy) 2013-04-24 21:53:23 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

in MSO 2007 everything looks fine
Comment 8 QA Administrators 2015-03-04 02:20:21 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2015-03-22 13:08:46 UTC
Confirmed.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 10 tommy27 2016-04-16 07:26:39 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2017-05-22 13:22:45 UTC Comment hidden (obsolete)
Comment 12 Xisco Faulí 2018-01-04 17:55:43 UTC
I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: 2bf1cc7372088ec31ac5f0fb60de57feda59d3b7
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

Closing as RESOLVED WORKSFORME