Bug Hunting Session
Bug 44786 - PRINTING: Draw ignores global print options, forgets print dialog settings
Summary: PRINTING: Draw ignores global print options, forgets print dialog settings
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.1
Keywords:
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2012-01-14 11:54 UTC by Phil Wolff
Modified: 2019-08-02 14:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Wolff 2012-01-14 11:54:04 UTC
Using Ubuntu 11.10, LibreOffice 3.4.4 OOO340m1 (Build:402)

In Tools->Options->LibreOffice Draw->Print, I have checked the Page name, Date, and Time boxes. These settings persist across invocations of Draw, as expected.

In File->Print, on the LibreOffice tab, the Page name and Date and time boxes come up unchecked, regardless of the settings in Tools->Options...

What is the purpose of having global options, if their values are ignored?

If I check the boxes in File->Print, do my printing, make some changes, and invoke File->Print again, the boxes are again initialized to unchecked.

This doesn't make any sense, either. Multiple print operations during the same instance of the application are very likely to demand the same option settings.
Comment 1 sasha.libreoffice 2012-05-08 03:55:35 UTC
Thanks for bugreport
reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit
IMHO looks like unfinished feature. UI added, but code not yet.

Changing version to 3.3.4 as most early reproducible
Comment 2 A (Andy) 2015-04-04 11:11:53 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 3 tommy27 2016-04-16 07:26:22 UTC Comment hidden (obsolete)
Comment 4 Phil Wolff 2016-04-18 17:16:46 UTC
Now using Ubuntu 15.10, LO 5.0.5.2. Bug is still present, no changes in behavior noted.
Comment 5 QA Administrators 2017-10-23 14:10:13 UTC Comment hidden (obsolete)
Comment 6 Phil Wolff 2017-10-23 18:31:08 UTC
Retested against LO 5.4.1.2, Build ID: 1:5.4.1-0ubuntu1 on Ubuntu 17.10.

Nothing has changed.
Comment 7 QA Administrators 2018-10-24 02:56:45 UTC Comment hidden (obsolete)
Comment 8 Phil Wolff 2018-10-24 22:01:54 UTC
Version: 6.1.2.1
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk2; 
Locale: en-US (en_PW.UTF-8); Calc: group threaded

Now running Ubuntu 18.10. Nothing has changed.
Comment 9 Commit Notification 2019-07-26 08:23:51 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/844be49e7e511f0c397e1faebca10b4fa25ea937%5E%21

tdf#39742 tdf#44786 Consider Impress/Draw default printing settings

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-08-02 14:38:45 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/c542a385ce100f8f52a4aff6ab12312f9fbb674e%5E%21

tdf#39742 tdf#44786 Consider Impress/Draw default printing settings

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.