Bug 45115 - BorderLine UNO API broken in LibreOffice 3.4 / 3.5
Summary: BorderLine UNO API broken in LibreOffice 3.4 / 3.5
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:3.4.6 target:3.5.1 target:3.6....
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-01-23 03:37 UTC by mail
Modified: 2012-02-08 08:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
BorderLine Java test code (2.52 KB, text/x-java)
2012-01-23 03:37 UTC, mail
Details
BorderLine screenshot from LibreOffice 3.3 (166.02 KB, image/jpeg)
2012-01-23 03:38 UTC, mail
Details
BorderLine screenshot from LibreOffice 3.4 (127.09 KB, image/jpeg)
2012-01-23 03:38 UTC, mail
Details
BorderLine screenshot from LibreOffice 3.5 (163.80 KB, image/jpeg)
2012-01-23 03:38 UTC, mail
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mail 2012-01-23 03:37:06 UTC
Created attachment 56028 [details]
BorderLine Java test code

BorderLine is broken since LibreOffice 3.4 (also in 3.5)

You can reproduce the bug with this java code:
http://dl.dropbox.com/u/4170695/BorderLineError/BorderLineTest.java

Also some other user reports similar problems with BASIC macros or import from MS *.doc files:
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=39740
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=42784
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=36825

LibreOffice 3.3.4.1 (OOO330m19 (Build:401-401-402) is the last WORKING version. Since 3.3.99.1 (LibreOffice 3.4  300m103(Build:1) the BorderLine dosent work anymore. This may depend on this change:
 + fixed BorderLine(2) convertion to SvxBorderLine (fdo#34226) [Cédric Bosdonnat]
see:
http://download.documentfoundation.org/libreoffice/src/bugfixes-libreoffice-3-4-release-3.3.99.1.log

also see this commit:
http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=0d209ac289dd5c79da6950b4c01b0cec9b7fbe6d

Here some screenshots from working 3.3:
http://dl.dropbox.com/u/4170695/BorderLineError/LibreOffice_3.3_BorderLine_OK.jpg

and broken 3.4 / 3.5
http://dl.dropbox.com/u/4170695/BorderLineError/LibreOffice_3.4_BorderLine_ERROR.jpg
http://dl.dropbox.com/u/4170695/BorderLineError/LibreOffice_3.5_BorderLine_ERROR.jpg

Java Libs used by 3.3:
/usr/share/java/juh.jar
/usr/share/java/jurt.jar
/usr/share/java/ridl.jar
/usr/share/java/unoloader.jar
/usr/share/libreoffice/basis3.3/program/classes/officebean.jar
/usr/share/libreoffice/basis3.3/program/classes/unoil.jar

Libs used in my CLASSPATH by LibreOffice 3.5:
/opt/libreoffice3.5/ure/share/java/java_uno.jar
/opt/libreoffice3.5/ure/share/java/juh.jar
/opt/libreoffice3.5/ure/share/java/jurt.jar
/opt/libreoffice3.5/ure/share/java/ridl.jar
/opt/libreoffice3.5/ure/share/java/unoloader.jar
/opt/libreoffice3.5/program/classes/officebean.jar
/opt/libreoffice3.5/program/classes/unoil.jar

Lets me know if you need some further info / tests.

BR

Pawel
Comment 1 mail 2012-01-23 03:38:15 UTC
Created attachment 56029 [details]
BorderLine screenshot from LibreOffice 3.3
Comment 2 mail 2012-01-23 03:38:34 UTC
Created attachment 56030 [details]
BorderLine screenshot from LibreOffice 3.4
Comment 3 mail 2012-01-23 03:38:52 UTC
Created attachment 56031 [details]
BorderLine screenshot from LibreOffice 3.5
Comment 4 Eike Rathke 2012-01-27 10:45:08 UTC
@Cedric: probably a similar cause as in bug 42784, just for Writer.
Comment 5 Michael Stahl (CIB) 2012-02-03 13:21:13 UTC
problem is that when the GuessLineWidths function gets SOLID parameter,
it does not consider any double line styles.
and the API implementation hard-codes a SOLID style.

fixed on master:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ef9881001e4ddfa6bfbe7d83f482393bb76d926a

calc has the exact same problem, fixed on master:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ef9881001e4ddfa6bfbe7d83f482393bb76d926a