Bug Hunting Session
Bug 45178 - Impress UI: changes of animated objects not displayed on "Custom animation" pane
Summary: Impress UI: changes of animated objects not displayed on "Custom animation" pane
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: Sidebar-Custom-Animation
  Show dependency treegraph
 
Reported: 2012-01-24 06:42 UTC by sasha.libreoffice
Modified: 2019-09-02 09:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test case and step-by-step explanation (19.33 KB, application/vnd.oasis.opendocument.presentation)
2012-01-24 06:42 UTC, sasha.libreoffice
Details
Screenshot after testing (166.39 KB, image/png)
2013-05-11 05:15 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-01-24 06:42:27 UTC
Created attachment 56081 [details]
test case and step-by-step explanation

Impress has very useful functionality: Custom animation. It is used very often. And if animation is complex, then it is makes sense to give names for objects, used in animation. 
But here is one problem: when we change name of object, this is not displayed on "Custom animation" pane.
Test case and step-by-step explanations placed inside of attachment

reproducible in LibO 3.6.0 and 3.3.4 on Fedora 64 bit and LibO 3.5.0 on Windows XP 32 bit
Comment 1 Robert Großkopf 2012-09-29 18:13:36 UTC
I can reproduce this bug on LO 3.6.2.1, openSUSE 12.1 64bit. Changed the status to "New".
It isn't as problem of the functionality, but the displayed name is wrong.
Comment 2 ign_christian 2013-05-11 05:15:26 UTC
Created attachment 79128 [details]
Screenshot after testing

Confirmed this bug on LO 3.6.6.2 (Ubuntu 12.04.2 32bit)

But I found something different on the pane name after double clicking rectangle & clicking outside that slide -> see Screenshot.png
Comment 3 QA Administrators 2015-03-04 02:18:01 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-03-22 11:10:36 UTC
Reproduced with attachment 56081 [details].

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 5 tommy27 2016-04-16 07:24:15 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-05-22 13:25:07 UTC Comment hidden (obsolete)
Comment 7 Commit Notification 2018-06-24 01:52:45 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3e768ce8260ed442b02c884c5a6bfac421dbcec9

tdf#45178 notify object rename and update effect description.

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2018-07-25 08:56:58 UTC
A polite ping to Mark Hung:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 9 Xisco Faulí 2018-08-25 14:36:47 UTC
(In reply to Xisco Faulí from comment #8)
> A polite ping to Mark Hung:
> Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
> Otherwise, Could you please explain what's missing?
> Thanks

@Mark hung, ping ?
Comment 10 QA Administrators 2019-09-02 09:25:36 UTC
Dear sasha.libreoffice,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug