Bug Hunting Session
Bug 45516 - FILESAVE: "Restart Numbering" is not properly saved
Summary: FILESAVE: "Restart Numbering" is not properly saved
Status: RESOLVED DUPLICATE of bug 40929
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-01 12:56 UTC by Uwe Kindler
Modified: 2015-03-14 12:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The attached screenshots are taken before save and after reload of the document. They show that the setting "Restart Numbering" is not properly saved to the very first number of a list style. (139.87 KB, image/jpeg)
2012-02-01 12:56 UTC, Uwe Kindler
Details
master document with 2 documents (22.69 KB, application/zip)
2012-04-04 08:23 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Kindler 2012-02-01 12:56:13 UTC
Created attachment 56469 [details]
The attached screenshots are taken before save and after reload of the document. They show that the setting "Restart Numbering" is not properly saved to the very first number of a list style.

Problem description: 
The setting "Restart Numbering" is not properly saved for the very first number of a list style. Normally this is not a problem for a single document because if it is the first number, then there are no numbers before and a restart is not necessary. But if the document if used in a Master Document then this becomes a big issue. If the master document contains multiple documents that use the same document or list styles, then the numbering of the first number of a certain list style is wrong in a Slave Document if another Slave Document that comes before uses the same list style.

Steps to reproduce:
1. Create a new text document
2. Enter 3 words with linebreaks
3. Select the 3 lines and select from List Styles the style Numbering 1 - now you should have a numbered list
4. Select the first number (number 1.) and select "Restart Numbering" from the "Bullets and Numbering" toolbar
5. Save the document.
6. Close the document.
7. Reopen the document
8. Click the first number of the list (number 1.) - the option "Restart Numbering" in the "Bullets and Numbering" list is not active anymore - so it was not properly saved.
9. Save the document with another name
10. Create a Master Document
11. Insert both documents.
12. Now try to make the list of the second document restarts from zero - this is not possible.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

Windows 7 Professional 32-Bit
Comment 1 sasha.libreoffice 2012-04-04 08:23:55 UTC
Created attachment 59480 [details]
master document with 2 documents
Comment 2 sasha.libreoffice 2012-04-04 08:27:05 UTC
Thanks for bugreport
reproduced in 3.3.4 and 3.5.2.2 on Fedora 64 bit
after step 4 on my comp I changed style Numbering 1, enabled numbering
changing version to 3.3.4 as most early reproducible
Comment 3 Sina Momken 2013-07-25 04:59:52 UTC
I can admit that LibreOffice (v3.5.4.2) doesn't save "Restart Numbering" for the first number of a list when saving as ODT format. Also when LibreOffice saves as DOC format it separates the lists by using different list-styles (e.g. WW8Num3, WW8Num4, ...) for every list and then it ignores every "Restart Numbering" attribute for separating restarting lists at all.
Comment 4 tommy27 2014-10-26 05:49:53 UTC
please retest with current LibO 4.3.2.2
is the bug still reproducible?
Comment 5 Uwe Kindler 2014-10-26 12:13:58 UTC
The bug is still reproducible in LibreOffice 4.3.2.2
Comment 6 Owen Genat (retired) 2015-01-18 08:42:11 UTC
Highly likely a duplicate of bug 40929.
Comment 7 Owen Genat (retired) 2015-03-14 12:54:15 UTC

*** This bug has been marked as a duplicate of bug 40929 ***