Bug Hunting Session
Bug 45600 - Jump List items in Windows 7 are not visible in Libreoffice 3.4.5
Summary: Jump List items in Windows 7 are not visible in Libreoffice 3.4.5
Status: RESOLVED DUPLICATE of bug 35785
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 54097 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-02-03 12:23 UTC by Jan Eijgenraam
Modified: 2014-10-08 13:34 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Eijgenraam 2012-02-03 12:23:33 UTC
In Libreoffice 3.4.5 the jump list items are not visible or not available. I checked them with the icons of scalc.exe and swriter.exe on the taskbar. No recently opened files are shown and as a consequence it is not possible to pin documents.

In order to make sure that for previous release (Libreoffice 3.3.4) it still worked I de-installed Libreoffice 3.4.5 and re-installed 3.3.4
This confirmed to me that the jump list items were available with 3.3.4

I knew already that you must open a document by double clicking on the file name in Windows Explorer in order to add the document to the jump list. Opening a file within Libreoffice does not add the file to the jump list.
Comment 1 sasha.libreoffice 2012-03-16 08:56:06 UTC
Thanks for bugreport
Which version of Windows used?
Comment 2 Jan Eijgenraam 2012-03-16 12:03:59 UTC
Windows 7 Home Premium Service Pack 1

regards,
Jan Eijgenraam

Op 16-3-2012 16:56, bugzilla-daemon@freedesktop.org schreef:
> https://bugs.freedesktop.org/show_bug.cgi?id=45600
>
> sasha.libreoffice@gmail.com changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |sasha.libreoffice@gmail.com
>
> --- Comment #1 from sasha.libreoffice@gmail.com 2012-03-16 08:56:06 PDT ---
> Thanks for bugreport
> Which version of Windows used?
>
Comment 3 sasha.libreoffice 2012-03-17 00:20:56 UTC
Thanks for additional information
Sorry, but I can not understand or reproduce this bug 
What is jump list? It is something like Start->Documents->Recent documents? Or it is inside of LibreOffice?
Comment 4 Jan Eijgenraam 2012-03-17 09:19:57 UTC
Jump Lists are a feature in Microsoft Windows 7 
<http://blogs.techrepublic.com.com/window-on-windows/> and 8 that are 
designed to make it easier to find what you want and perform common 
operations associated with an application. Jump Lists appear on the 
Start menu as well as on the Taskbar when you right-click on an icon. 
The most common use is access to recent documents. In addition it gives 
the ability to pin documents to make them permanent on the list.


    Jump List feature in a nutshell

The Jump List feature is designed to provide you with quick access to 
the documents and tasks associated with your applications. You can think 
of Jump Lists like little application-specific Start menus. Jump Lists 
can be found on the application icons that appear on the Taskbar when an 
application is running or on the Start menu in the recently opened 
programs section. Jump Lists can also be found on the icons of 
applications that have been specifically /pinned/ to the Taskbar or the 
Start menu.

Jump Lists on the Start menu will appear a little different than Jump 
Lists on the Taskbar. However, they will provide the same functionality.

By default, the Jump List can contain the application’s shortcut, the 
ability to toggle pinning, the ability to close one or all windows, 
access to specific tasks associated with the application, and once you 
begin using the application, a list of recent documents or destinations 
depending on the application.


regards,
Jan

Op 17-3-2012 8:20, bugzilla-daemon@freedesktop.org schreef:
> https://bugs.freedesktop.org/show_bug.cgi?id=45600
>
> --- Comment #3 from sasha.libreoffice@gmail.com 2012-03-17 00:20:56 PDT ---
> Thanks for additional information
> Sorry, but I can not understand or reproduce this bug
> What is jump list? It is something like Start->Documents->Recent documents? Or
> it is inside of LibreOffice?
>
Comment 5 sasha.libreoffice 2012-03-19 07:57:42 UTC
Thanks for explanations. I found this.
To reproduce this:
1. Open LibreOffice, open some file using File->Open, close office
2. Press Start button in Windows 7
3. Place mouse cursor on LibreOffice Writer item. To right from this item appears list of recently opened by Writer files.
Expected: file name from step 1 appears there
Actually: no such file name
Reproduced in 3.4.3 on Windows 7 32 bit, changing version to 3.4.3 as most early reproducible
Comment 6 Brent H 2012-09-20 05:41:44 UTC
This has been an issue since February 2012 and version 3.4.5. It is now mid September 2012 and version 3.6.1.2 and this problem STILL EXISTS!
Comment 7 sasha.libreoffice 2012-09-20 08:19:23 UTC
IMHO it is because TDF have currently no free Windows-experts. They both are very busy.
Comment 8 Michael Meeks 2012-09-20 09:09:05 UTC
Brent: one problem is that this is not marked as a regression vs 3.3.

Andras: any ideas here ? could it be some installation / registry snafu ? :-)
Comment 9 Brent H 2012-12-01 00:51:00 UTC
This has been an issue since February 2012 and version 3.4.5. It is now mid September 2012 and version 3.6.1.2 and this problem STILL EXISTS!

Now it is December and version 3.6.3.2 and this problem STILL EXISTS!
Comment 10 gioni 2012-12-03 09:18:54 UTC
I'm agree.
In version 3.6.3.2 this problem STILL EXISTS!
Comment 11 sasha.libreoffice 2012-12-03 09:35:52 UTC
Thanks for additional testing and information
"Version" is most early version of LO where bug appears, not current version.
Changing back to 3.4.3 release
Comment 12 Michael Meeks 2012-12-03 09:57:19 UTC
Hi Brent:

> Now it is December and version 3.6.3.2 and this problem STILL EXISTS

My question would be - what have you done to help diagnose the problem in the in-between times :-) bugs don't fix themselves. What docs have you dug out on jump lists, the registry keys they use, how the implementations work ? have you dug through your registry to see if there is something simple going wrong there etc. etc. ? There is lots a clueful user can do to narrow down such a problem. Finding the exact version it stopped working is also helpful 3.4.5 to 3.3.4 is useful but not a terribly narrow window etc.

Thanks !
Comment 13 gioni 2012-12-16 07:45:29 UTC
I'm agree.
In version 3.6.4.3 the problem STILL EXISTS!
Comment 14 Steve Taylor 2013-01-09 18:09:10 UTC
I just upgraded from 3.3.3 to the latest (3.6.4.3), on Windows 7. Yes, my taskbar jump lists of recent / pinned documents has vanished. It's become a part of my everyday workflow, so it's very disappointing (1) that there's been such a basic regression and (2) it's been left unfixed for so long.

I looked on ask.libreoffice.org and someone on a relevant thread said that commenting there would make no difference to how quickly a bug is fixed, they directed people here. Here, people are adding comments saying "Please fix this" and being asked to contribute to development. I'm not a developer, I'm a user who's sorely missing a simple feature. I appreciate that it's free and generally great software, but *some* way in which users can +1 bugs would be great - to help users feel their voice is being heard, and to help developers prioritize their work most effectively.
Comment 15 Michael Meeks 2013-01-10 11:25:46 UTC
Hi Steve:

> adding comments saying "Please fix this" and being asked to contribute to 
> development. I'm not a developer, I'm a user who's sorely missing a simple 
> feature. 

There are a -lot- of things users can do to help here. Users filing bugs are already reasonably competent. Such things included digging out useful MSDN documentation on how this feature is implemented in windows; developer docs on "how to add your app to the jump list" whatever and adding links here. Anything that can be done to make life easier for the developers as/when they have time to look at it helps - the less time it takes to fix, the more likely someone is.

Then - some careful reading of those docs [ again no development skills required ] and tinkering with the registry, searching in openGrok to find bits of relevant code would help too - and adding the results to this bug.

etc. absent that - someone else will have to do this, and (thus far) they are not :-) Failing any interest in doing this basic no-skills-required research - paying someone to take an interest on your behalf works.

I hope that helps; sorry for the bug.

    Michael.
Comment 16 Jan Eijgenraam 2013-01-20 13:47:13 UTC
I'm still running release 3.3.4.1 since that's the last version where the jump list items are available. I have reported all tests results and documented the bug and the jump list feature as good as possible.
I have now installed the version 3.4.1 of OpenOffice (Apache) and there the jump list feature is working fine, so I intend to uninstall LibreOffice.
regards,
Jan
Comment 17 gioni 2013-02-14 22:14:49 UTC
nothings changed in 4003. The problem still remain.
Comment 18 Michael Meeks 2013-03-01 10:50:14 UTC
Andras:

This may well be a simple registry key issue; according to:

http://msdn.microsoft.com/en-us/magazine/dd942846.aspx#id0420086

It should be pretty clear that it's possible to get the jump list to
work for you without a significant effort. For recent items to appear
in your application's jump list, follow these steps:

    Make sure that your application's file type is associated with
    your application in the Windows registry (as a registered
    handler). Note that your application does not have to be the
    primary or default handler for the file type. (See
    msdn.microsoft.com/en-us/library/dd378402(VS.85).aspx for more
    information.)

Which seems the most likely cause of the problem, or perhaps we are not calling:

void WinSalInstance::AddToRecentDocumentList(const rtl::OUString& rFileUrl, const rtl::OUString& /*rMimeType*/)
{
    rtl::OUString system_path;
    osl::FileBase::RC rc = osl::FileBase::getSystemPathFromFileURL(rFileUrl, system_path);

    OSL_ENSURE(osl::FileBase::E_None == rc, "Invalid file url");

    if (osl::FileBase::E_None == rc)
        SHAddToRecentDocs(SHARD_PATHW, system_path.getStr());
}

In the right place - can you dig into that ?
Comment 19 V Stuart Foote 2013-03-01 11:15:56 UTC
Is this really a LibreOffice bug--seems more an issue with Windows 7 shell.

In effect, the Windows builds for LibreOffice do not fully integrate with the default SHAddToRecentDocs routines of Windows 7 shell to populate recent used items listing that then populates the Taskbar Jump List.

Unclear why Windows is not correctly handling LibreOffice components, but the default Windows behavior should be to add to files to the list if you "have a registered handler and an Application ID"--I believe LibreOffice does that much in a Windows installation, maybe a conflicting handler and muddled AppID. Possibly it even is something to do with LibreOffice's minimal use of the Windows registry.

Activating the LO "Windows Explorer Extension" during installation (LO documents parsed and rendered as icons in Windows Explorer) does not improve behavior of the SHAddtoRecentDocs and function of Taskbar Jump Lists. Nor does launching the document from out of Windows Explorer (assuming correct file association).

Microsoft would probably not agree to fix this. But since the default Windows shell behavior is not correctly handling LibreOffice components, simplest solution may lay with an enhancement to develop an ICustomDestinationList and a set of ApplicationIDs for the LibreOffice components.

Seems pretty straight forward to implement, as in these refs:

http://blogs.windows.com/windows/archive/b/developers/archive/2009/06/18/developing-for-the-windows-7-taskbar-application-id.aspx

http://blogs.windows.com/windows/archive/b/developers/archive/2009/06/25/developing-for-the-windows-7-taskbar-jump-into-jump-lists-part-2.aspx

http://msdn.microsoft.com/en-us/library/ff770767.aspx
Comment 20 V Stuart Foote 2013-03-01 11:20:25 UTC
*** Bug 54097 has been marked as a duplicate of this bug. ***
Comment 21 pjw 2013-03-21 09:33:47 UTC
Another relevant question here is: whap happened between 3.5.x and 3.6/4 to break these: for me they worked in 3.5.x.
Comment 22 Michael Meeks 2013-03-21 13:17:20 UTC
I talked to Andras about this; apparently it's related to our renaming (and adding component names eg. "LibreOffice Writer") to some launcher files / registry pieces somewhere else and this breaks the auto-magic linking between soffice.bin and these other more descriptive names (or something).

So it seems like the best, and cleanest fix is to implement the simple interface necessary to populate the jump-list with exactly what we want, rather than using the Windows built-in support - the examples are there, the MSD docs are there - so with a few more code pointers we should turn this into an easy hack :-) [ prolly best as a separate bug ].
Comment 23 Julien Nabet 2013-04-03 20:39:06 UTC
Michael: On Win7 x64 with 4.0.1.2 installed (I uninstalled previous version and I think I had clean Windows registry), I can see the recent documents opened by LO when I right click on Windows taskbar. Did I miss something?

BTW, as indicated here: https://bugs.freedesktop.org/show_bug.cgi?id=35785#c15, it seems this tracker a dup of fdo#35785, may we mark this tracker as a dup?
Comment 24 V Stuart Foote 2013-04-03 23:37:22 UTC
Resetting version to 3.4.5 of OP, and closing as duplicate of mab 4.0 bug 35785 which reports initial problems with version 3.3.2 Windows builds. OP says worked in 3.3.4, so unclear which build exactly Windows Jump list items became unstable.

*** This bug has been marked as a duplicate of bug 35785 ***
Comment 25 horus 2013-04-04 13:17:59 UTC
(In reply to comment #23)
> Michael: On Win7 x64 with 4.0.1.2 installed (I uninstalled previous version
> and I think I had clean Windows registry), I can see the recent documents
> opened by LO when I right click on Windows taskbar. Did I miss something?

Yes, you miss the fact that you can only have the list of recent documents *after* you have a LO application window already open. In other words, suppose I want to reopen an old LO writer doc, I have to:
1. open LO writer to open an *empty* document
2. right-click on the empty document icon on the task bar
3. choose the old document

But this workaround does not give us the jump list.  And it's not user-friendly to tell every Win7 to change their habit, ie tell them NOT to use the jump list but to follow the steps I have just written.

(In reply to comment #24)
> Resetting version to 3.4.5 of OP, and closing as duplicate of mab 4.0 bug
> 35785 which reports initial problems with version 3.3.2 Windows builds. OP
> says worked in 3.3.4, so unclear which build exactly Windows Jump list items
> became unstable.

I'm unable to get access to old versions.  If someone can tell me how to download them, I can tell you when it was broken.
Comment 26 horus 2013-04-04 13:20:52 UTC
Please forget about my last comment on "getting access to old versions of LO".  I have just seen the links to them in the other bug.  Thanks
Comment 27 horus 2013-04-05 20:16:27 UTC
I have just done a typical installation of 3.4.5 in:
. Win7 Pro SP1 64bit,
. Win7 Pro "SP0" 64bit and
. Win7 Pro SP1 32bit
but I'm *unable* to reproduce this problem.

Don't mistake me. I'm not saying LO has no problem with jump list in win7. I'm just saying that the problem didn't exist at ver 3.4.5 for me.

I downloaded 3.4.5 from these two URLs:
http://downloadarchive.documentfoundation.org/libreoffice/old/3.4.5.2/win/x86/
http://www.oldapps.com/libreoffice.php?old_libreoffice=7190

Note that 3.4.5.2 setup is the same as 3.4.5 setup.

For comment 5 from sasha.libreoffice@gmail.com, I have an explanation:
Jump list is populated by Win7 O/S. If you open a LO file from *inside* LO application's "File -> Open", it's normal that the file is not found in the jump list. And since LO had just been installed by Sasha, the jump list was *empty* and therefore it was not shown at all. But if he had double-clicked a LO file from Windows Explorer, the file would have been added to the jump list and the jump list would have been shown.  For me, this has always been a normal behaviour.

But for original poster, Jan Eijgenraam, I have no idea.  If Jan still has his 3.4.5 setup and is able to send it to me, I can do a test.
Comment 28 Oliver 2014-10-08 12:56:59 UTC
follow up : this is still a problem with LibreOffice 4.3.0.4 running on a Windows seven professional 64 bit : 
even when a file is opened by doubleclicking (so not from within Libreoffice), it will not appear on the jump list.
Comment 29 V Stuart Foote 2014-10-08 13:34:39 UTC
@brendel, *,
(In reply to brendel from comment #28)
> follow up : this is still a problem with LibreOffice 4.3.0.4 running on a
> Windows seven professional 64 bit : 
> even when a file is opened by doubleclicking (so not from within
> Libreoffice), it will not appear on the jump list.
I just verified this is functioning correctly in Windows 7 sp1, 64-bit en-US with correctly installed current release build
Version: 4.3.2.2
Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d

We'll assume that your LibreOffice installation went correctly, i.e. "Run as Administrator" and not done in parallel as an /A administrative install. 

Have you configured Taskbar and Start Menu properties on the Start Menu tab, checking in the Privacy box one of the display options -- Start Menu, or Start Menu and Taskbar. Also, with the Customize button to open its dialog and checked that "Recent items" is selected and that at the bottom set the spinner "Number of recent items to show in jump lists"?

Then, for the Start Menu launchers for LibreOffice, have you pinned them to the Start Menu (the jump list will be the right pointing triangle) or to the Taskbar (where the jump list will be the popup context menu listing).

Finally, rework for the Jump lists was done under bug 35785.  This issue was closed as a duplicate of that bug. Please review its specifics of configuration and function of the Jump lists.