Bug 45624 - Problem with plugins in new version of LO
Summary: Problem with plugins in new version of LO
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-04 09:51 UTC by Petr Valach
Modified: 2013-04-24 23:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Valach 2012-02-04 09:51:40 UTC
Hi,

I just want to refer about some plugins for openoffice.org (but they could be used in older version of libreoffice too). They cannot be used in version 3.5. They are from Euroofice team and they weren´t publish for LO. But I think that problem is with LO 3.5, because they can be used in all versions of OOo and LO.

Hope that this problem will be solved before releasing of stable version.

Good luck.
Comment 1 sasha.libreoffice 2012-05-14 08:36:06 UTC
Thanks for bugreport
May be related: Bug 46131, Bug 47318
Comment 2 Joel Madero 2012-10-16 21:25:06 UTC
Marking as NEEDINFO as there is no link to the plugin. Please link us to it so that we can try. Also, just because an extension works for OOo doesn't mean that it will work in LibO, our code has some differences and thus can result in this kind of a scenario. If the developer of the extension explicitly states they are making it for OOo, might be good to ask them to make sure it works on LibO as well.
Comment 3 retired 2013-03-20 13:42:29 UTC
No further feedback from bug reporter.

@Petr: If you are still able to reproduce this problem with LO 4, please provide a link to the plugin in question and re-open this bug, so this can be investigated.
Comment 4 Petr Valach 2013-03-24 23:38:16 UTC
OK, look at http://www.multiracio.com/index.php?lang=en&style=eurooffice&page=eo_ext and try some of their plugins. No-one is available for LibreOffice, only for AOO. I don't know where is problem (so I little think).
Comment 5 sasha.libreoffice 2013-03-25 09:40:30 UTC
Thanks for link
I have downloaded extension EuroOffice_Formula_Converter.oxt , then renamed extension to zip and entered it. There is program on Python version 2. But this version is prohibited in LO 4. Only version 3 of Python is allowed. 

Changing status to NotOurBug because problem is in extension
Comment 6 Petr Valach 2013-04-24 23:43:22 UTC
Thank you for testing. Hope that we can use those plugins in future, after rewriting in Python 3.