Bug 45771 - SVG: Incorrect text size
Summary: SVG: Incorrect text size
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:5.2.0 target:5.1.1
Keywords: filter:svg
Depends on:
Blocks:
 
Reported: 2012-02-08 05:25 UTC by Poustre Lakos
Modified: 2016-10-25 19:11 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshots of svg in writer and in firefox. (156.21 KB, application/x-gzip)
2012-02-08 07:58 UTC, Poustre Lakos
Details
visio svg (148.89 KB, image/svg+xml)
2012-08-04 12:54 UTC, Poustre Lakos
Details
libreoffice draw svg (1.24 MB, image/svg+xml)
2012-08-04 12:54 UTC, Poustre Lakos
Details
Backtrace log extract of crash under GNU/Linux v4.0.3.3 for Visio SVG. (28.63 KB, text/x-log)
2013-06-08 08:09 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Poustre Lakos 2012-02-08 05:25:50 UTC
Problem description:
SVG images do not display at all when inserted in a document.

Steps to reproduce:
1. Insert an SVG image into a document.

Current behavior:
What is actually inserted is an empty frame. I tested this with an image that would render normally in web browsers.

Expected behavior:
Actually show the SVG image in the document.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0
Comment 1 Poustre Lakos 2012-02-08 07:58:56 UTC
Created attachment 56754 [details]
Screenshots of svg in writer and in firefox.
Comment 2 tester8 2012-02-08 09:39:18 UTC
Please, upload the svg file.
Comment 3 Jean-Baptiste Faure 2012-03-17 10:33:35 UTC
Please could you attach the svg file itself ?

Best regards. JBF
Comment 4 Poustre Lakos 2012-08-04 12:54:03 UTC
Created attachment 65119 [details]
visio svg
Comment 5 Poustre Lakos 2012-08-04 12:54:43 UTC
Created attachment 65120 [details]
libreoffice draw svg
Comment 6 Poustre Lakos 2012-08-04 12:54:57 UTC
Actually, some svg images are rendered correctly, some are not. I believe this has to do with svg images being faulty, and not with Libreoffice Writer.

I am using two programs to create the svgs. Microsoft visio creates svgs that appear normally in libreoffice, but they have some resizing issues in firefox. LibreOffice Draw creates faulty svgs: They appear with stuff missing in Draw, and in browsers they are placed in the middle of the browser and cannot be resized.

This should be re-opened as a Libreoffice Draw bug.
Comment 7 Owen Genat (retired) 2013-06-08 08:09:13 UTC
Created attachment 80510 [details]
Backtrace log extract of crash under GNU/Linux v4.0.3.3 for Visio SVG.

I experience a crash under Crunchbang 11 running TDF/LO v4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539) if I try and insert the Visio-generated SVG from comment #4 into a Writer document. The gdbtrace.log file was nearly 50MB and appeared to terminate once gdb reached around ~750-800MB of RAM. I have head and tailed the first and last 100 lines as the rest appears to be repetition of the same detail.

On another note, what is happening with this bug? Is the description going to be updated to reflect how SVGs generated by Draw appear faulty / suffer information loss? Or should it concentrate on the problem I have indicated here with the Visio SVG?
Comment 8 Jean-Baptiste Faure 2013-06-16 12:25:13 UTC
(In reply to comment #7)
> Created attachment 80510 [details]
> Backtrace log extract of crash under GNU/Linux v4.0.3.3 for Visio SVG.
> 
> I experience a crash under Crunchbang 11 running TDF/LO v4.0.3.3 (Build ID:
> 0eaa50a932c8f2199a615e1eb30f7ac74279539) if I try and insert the
> Visio-generated SVG from comment #4 into a Writer document. 

Original description of this bug report does not mention a crash, so your problem id different. So, please, file another bug report for that problem.

Best regards. JBF
Comment 9 Jean-Baptiste Faure 2013-06-16 12:26:50 UTC
REOPENED is not the right status because this bug report has never been marked fixed.

Best regards. JBF
Comment 10 Owen Genat (retired) 2013-06-16 13:41:08 UTC
Thanks for the assistance JBF and my apologies for the noise. I have opened a new bug #65825 as requested.
Comment 11 Jorendc 2014-07-24 19:45:35 UTC
Looks like there is only an incorrect text size. Other issues are solved. I'll change summary accordingly.
Comment 12 QA Administrators 2015-09-04 02:48:24 UTC Comment hidden (obsolete)
Comment 13 Buovjaga 2015-11-19 09:21:16 UTC
Incorrect text size and no shading for the server objects.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 66d2b72667792cb18b25805387824d636e2a455c
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-18_02:35:53
Locale: fi-FI (fi_FI)
Comment 14 Robinson Tryon (qubit) 2015-12-10 04:34:43 UTC Comment hidden (obsolete)
Comment 15 Commit Notification 2016-01-28 06:49:56 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=701324a1e1f7e0c181ff1a50956ced686785ea53

SVGIO: tdf#45771: Fix issue when text size is twice its size...

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Xisco Faulí 2016-01-28 08:48:43 UTC
Text size issue has been fixed in 701324a1e1f7e0c181ff1a50956ced686785ea53.
Regarding the problem with the server objects, I created a different ticket:
https://bugs.documentfoundation.org/show_bug.cgi?id=97383.
So I consider I can already close this ticket. Best Regards
Comment 17 Commit Notification 2016-02-02 12:23:30 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f9f51e90196101ba0e545fc2631c7414760fa6b5&h=libreoffice-5-1

SVGIO: tdf#45771: Fix issue when text size is twice its size...

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2016-02-09 12:03:58 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1dad3e2a1277e6602142e97096b1f6b9965bb0f5

SVGIO: tdf#45771: Add import test

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.