Bug Hunting Session
Bug 45998 - Pasted text does not overwrite existing text in overwrite mode
Summary: Pasted text does not overwrite existing text in overwrite mode
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2012-02-13 07:02 UTC by oc-spam65
Modified: 2018-08-07 13:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oc-spam65 2012-02-13 07:02:54 UTC
Hello,

A text pasted in overwrite mode does not overwrite the existing text (it is inserted instead).

This bug happens in every component (writer, draw, calc).

Best regards
Comment 1 sasha.libreoffice 2012-03-21 08:37:42 UTC
Thanks for bugreport
Sorry, but pasted text should not overwrite existing text if it not selected. Just select text, needed to be overwrited before pasting.
Comment 2 oc-spam65 2012-03-21 11:35:14 UTC
I expect "paste in overwrite mode" to behave exactly as if I had typed the text that I'm pasting, thus it should overwrite the existing text. 

Your answer means that the behavior of pasting text should not depend on the "overwrite" setting, which to my mind is just an arbitrary limitation. Maybe there's a consensus on this, but I'm not aware of it.
Comment 3 Hashem Masoud 2012-09-05 08:20:47 UTC
(In reply to comment #2)
> I expect "paste in overwrite mode" to behave exactly as if I had typed the text
> that I'm pasting, thus it should overwrite the existing text. 

Confirmed in:
Version 3.6.0.4 (Build ID: 932b512) Slackware Linux 13.37
Calc application. Pasting in overwrite mode doesn't work, typing in overwrite mode works.

> Your answer means that the behavior of pasting text should not depend on the
> "overwrite" setting, which to my mind is just an arbitrary limitation. Maybe
> there's a consensus on this, but I'm not aware of it.
Comment 4 QA Administrators 2015-01-05 17:50:55 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2016-01-17 20:01:36 UTC Comment hidden (obsolete)
Comment 6 Oliver Maxwell 2016-02-04 20:48:40 UTC
For comment #3 looks like there's a bug filed to the same issue in the Calc component regarding pasting in overwrite mode (bug 54953). In regards to that, thanks to the help of beluga_ on IRC we've been able to repro that behavior in Calc in a 5.2 Alpha build.

Otherwise I've been able to reproduce the behavior described by the reporter in Writer on v5.0.4.2 en-US on OSX El Capitan
Comment 7 QA Administrators 2017-03-06 14:51:46 UTC Comment hidden (obsolete)
Comment 8 oc-spam65 2017-05-25 21:06:40 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2018-06-14 02:39:40 UTC Comment hidden (obsolete)
Comment 10 Timur 2018-08-06 14:58:26 UTC
Please write exact:
Reproducible steps:
Actual Results:
Expected Results:
Comment 11 oc-spam65 2018-08-06 16:33:35 UTC
Bug is still present in LO version 6.0.4.1
Comment 12 Timur 2018-08-06 16:49:42 UTC
Bug report is not clear. Please do as I asked.
Comment 13 oc-spam65 2018-08-06 18:21:04 UTC
Reproducible steps: 
Open lowriter, write some text (called 'initial text' thereafter), put the cursor in the middle of that text, go in overwrite mode (press the 'Insert' key), paste some other text (with 'Ctrl+V' for example). 

Actual Results:
The pasted text does not overwrite the initial text, it is inserted instead of overwriting.

Expected Results:
The pasted text should overwrite the initial text.
Comment 14 Timur 2018-08-07 07:44:10 UTC
OK, it's clear now. 
In my view this is WontFix with explanation similar to Comment 1. 
But let's put needsUXEval and wait.
Comment 15 Heiko Tietze 2018-08-07 13:14:39 UTC
The overwrite mode is a dangerous thing as Ins is often pressed inadvertently without proper feedback on the keyboard like shift. You may think edit and paste are the same but when typing the visual focus is close to the input whereas pasting might change a lot more. 

By the way, the mode is called "overtype" in MSO and works exactly the same as in LibreOffice. And I do not know any tool that works as requested.