Bug Hunting Session
Bug 46123 - UI: No progress indicator shown when updating external data
Summary: UI: No progress indicator shown when updating external data
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Progress-Indicator
  Show dependency treegraph
 
Reported: 2012-02-15 10:07 UTC by Rainer Bielefeld Retired
Modified: 2017-06-16 13:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (139.08 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-02-15 10:07 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-02-15 10:07:38 UTC
Created attachment 57109 [details]
Sample Document

While CALC updates data from the web, only a grey area visible.

Steps how to reproduce with [Reproducible] with "LibreOffice 3.5.0 German UI/Locale [Build-ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735] on German WIN7 Home Premium (64bit).

1. open attached sample.ods
   > Document will be opened and loaded, progress bar visible
2. confirm "Update?" if necessary
   Expected: info concerning further open progress
   Actual: nothing, document window with grey area instead of document contents
           for a minute, looks similar to a hang, after app. 1 minute contents 
           appears

There should be some progress bar or status bar information (loading contents from ... xx%) or similar
Comment 1 sasha.libreoffice 2012-05-21 03:38:25 UTC
Thanks for bugreport
Reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit
LO becomes unresponsive for few minutes, users can think that it hangs
Comment 2 Joel Madero 2016-07-04 06:40:10 UTC
Version: 5.3.0.0.alpha0+
Build ID: c89294233b6a9ffc1bd75e6e9226ad723b7d5538
CPU Threads: 2; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8)

Still a valid request.