Bug Hunting Session
Bug 46172 - Recent Documents list does not work
Summary: Recent Documents list does not work
Status: RESOLVED DUPLICATE of bug 46074
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-16 07:12 UTC by Leon Stringer
Modified: 2012-02-21 05:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leon Stringer 2012-02-16 07:12:35 UTC
1. Start Writer.
2. Type some text and save the file.
3. Close Writer.
4. Start Writer. File->Recent Documents says "No Documents".

Same problem with Calc and presumably other apps.

This is seen with LibreOffice 3.5.0rc3/Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735 on Windows 7 SP1 (64-bit). This was after upgrading from 3.4.5.

This looks the same as https://bugs.freedesktop.org/show_bug.cgi?id=39026 but the powers that be have closed this again.
Comment 1 Leon Stringer 2012-02-16 07:25:08 UTC
It looks like the problem is with the way the recent documents list is stored in registrymodifications.xcu (on Windows this is in %APPDATA%\LibreOffice\3\user). I don't know whether these were touched during the upgrade but following the upgrade, recently used items were stored thus:

<item oor:path="/org.openoffice.Office.Histories/Histories/org.openoffice.Office.Histories:HistoryInfo['PickList']/ItemList">
  <node oor:name="file:///C:/Users/lstringer/Documents/Testing.odt" oor:op="replace">
    <prop oor:name="Filter" oor:op="fuse">
      <value xsi:nil="true"/>
    </prop>
    <prop oor:name="Password" oor:op="fuse">
      <value xsi:nil="true"/>
    </prop>
    <prop oor:name="Title" oor:op="fuse">
      <value xsi:nil="true"/>
    </prop>
  </node>
</item>
:
<item oor:path="/org.openoffice.Office.Histories/Histories/org.openoffice.Office.Histories:HistoryInfo['PickList']/OrderList">
  <node oor:name="0" oor:op="replace">
    <prop oor:name="HistoryItemRef" oor:op="fuse">
      <value xsi:nil="true"/>
    </prop>
  </node>
</item>

If I rename registrymodifications.xcu, Recent Documents starts working with LO 3.5.0 now including the file name in the order list (the first <item> element above stays the same):

<item oor:path="/org.openoffice.Office.Histories/Histories/org.openoffice.Office.Histories:HistoryInfo['PickList']/OrderList">
  <node oor:name="0" oor:op="replace">
    <prop oor:name="HistoryItemRef" oor:op="fuse">
      <value>file:///C:/Users/lstringer/Documents/Testing.odt</value>
    </prop>
  </node>
</item>

With the first format in place the Recent Documents list never gets updated. If you remove these items from registrymodifications.xcu (or convert them to the new format) then the list starts working.
Comment 2 Barry Rueger 2012-02-20 17:53:27 UTC
I am using LibreOffice 3.5.0rc3 on Mint Linux Release 12 Linux Kernel 3.0.0-12 Generic.

I can confirm this bug - no documents are displayed in the "Recent Documents" List in either Calc or Writer.
Comment 3 Christian Lohmaier 2012-02-21 05:40:29 UTC

*** This bug has been marked as a duplicate of bug 46074 ***