Bug 46497 - FILEOPEN: Line elements in SmartArt in particular .pptx distorted
Summary: FILEOPEN: Line elements in SmartArt in particular .pptx distorted
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target: 4.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-22 22:05 UTC by Rainer Bielefeld Retired
Modified: 2013-05-31 22:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (2.25 MB, image/png)
2012-02-22 22:05 UTC, Rainer Bielefeld Retired
Details
Problem screenshot from LO 3.6.0 (71.89 KB, image/png)
2012-08-26 18:33 UTC, Lekow
Details
Screenshot of 4.2.0 master (148.22 KB, image/png)
2013-05-31 22:58 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-02-22 22:05:24 UTC
Created attachment 57502 [details]
Screenshot

Steps how to reproduce with  "LibreOffice 3.5.0 German UI/Locale [Build-ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735] on German WIN7 Home Premium (64bit) 

1. open sample from "Bug 46487 - FILEOPEN: Pictures invisible in .pptx created 
   by MS PowerPoint 2007"
   <https://bugs.freedesktop.org/attachment.cgi?id=57492>
2. Compare to view in PPT (see attached screenshot)
   Expected: looks equal
   Actual: blue lines between the rectangles are cruelly distorted

For the other differences (3D look, ...) we already have other reports.
Comment 1 sasha.libreoffice 2012-05-23 06:09:33 UTC
Thanks for bugreport
reproduced in 3.3.4 : no lines at all

in 3.5.3 on Fedora 64 bit and 3.5.2 on Windows 7 32 bit:
lines presents, but outside of slide
On Linux also Impress works very slow with this slide
Comment 2 Rainer Bielefeld Retired 2012-05-23 08:17:49 UTC
With Master pictures are monochrome black, for that Problem I submitted "Bug 50283 - FILEOPEN: pictures in particular .pptx (MSO2007) VIEWING greyscale instead of color".

@Sasha:
I also can't see your slow down problem with WIN, so it would be kind if you could submit a separate bug. If you put me to CC I can do a test with Ubuntu / LibO 3.5.3. My be you find the time to check Bug 50283?

@Thorsten:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 3 Thorsten Behrens (CIB) 2012-06-05 10:37:36 UTC
This is incomplete smartart import. Saving & re-exporting this document in MSO2010 should make this display much better.
Comment 4 Lekow 2012-08-26 18:33:18 UTC
Created attachment 66145 [details]
Problem screenshot from LO 3.6.0

Confirmed in LO 3.6.0.4. I have added the screenshot.
Comment 5 sasha.libreoffice 2012-08-27 07:37:17 UTC
@ Lekow
Thanks for additional testing
"Version" is most old version of LO where bug appears. Not current version.
Changing back to 3.3.4
Comment 6 Lekow 2012-08-28 13:42:09 UTC
(In reply to comment #5)

> "Version" is most old version of LO where bug appears. Not current version.
> Changing back to 3.3.4

Thank you! I will take this into account in future. 

I have a hypothesis that this bug is related with the bug 54095 . 
I do not know is it needed to add it into "Depends on" or "See also" list...
Comment 7 Jorendc 2013-05-31 22:58:16 UTC
Created attachment 80106 [details]
Screenshot of 4.2.0 master

Can't reproduce this using Linux Mint 15 x64 with LibreOffice Version: 4.2.0.0.alpha0+ Build ID: 467d5e0a2e074ff2afb4d1b1a37cff2094b0895

Can reproduce this using LibreOffice Versie 4.0.3.3 .3.3 (Bouw-id: 400m0(Build:3)); Dutch UI

So -> Fixed, but not backported to 4.0 versions. Don't know about upcomming 4.1.0.