Bug 46563 - FILEOPEN .doc (MSO97): Pictures and frames with missing border or wrong border line width
Summary: FILEOPEN .doc (MSO97): Pictures and frames with missing border or wrong borde...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:3.7.0 target:3.6.0.0.beta2...
Keywords: regression
: 50581 51457 (view as bug list)
Depends on:
Blocks: 44768
  Show dependency treegraph
 
Reported: 2012-02-24 03:14 UTC by Christian
Modified: 2015-12-22 01:30 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
doc-MS Word95/2003/XP-document with a picture formatted 4 pt black border, created with LO 3.3.4 (1.74 MB, application/msword)
2012-02-28 02:48 UTC, Christian
Details
The way it looks in LO 3.3.4. (843.39 KB, application/pdf)
2012-02-28 02:56 UTC, Christian
Details
The way it looks in LO 3.5. (848.03 KB, application/pdf)
2012-02-28 03:03 UTC, Christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian 2012-02-24 03:14:09 UTC
Problem description: On opening a doc-document (MS Office 97, 2000, XP borders the pictures are missed or have the wrong width. 

Steps to reproduce:
1. Create a document with LO/OO 3.3 or MS Office 2003. Insert a picture. Format the border to line width for example 3 pts and save.
2. Open the document with LO 3.5 (Windows XP or openSUSE 12.1). Borders of the picture are not displayed or wrong displayed.

Current behavior: Missing or wrong borders of the picture

Expected behavior: Picture with the right borders

Platform (if different from the browser): Windows XP and openSUSE 12.1
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:10.0.2) Gecko/20100101 Firefox/10.0.2

If you need further information please contact me.

Christian
Comment 1 Rainer Bielefeld Retired 2012-02-24 09:03:25 UTC
I am pretty sure that this one is a DUP of one of the bugs listed under "Bug 44768 - [Task]: FILEOPEN border compatibility issues". 

@Christian:
We need a sample document.
Comment 2 Christian 2012-02-28 02:48:20 UTC
Created attachment 57748 [details]
doc-MS Word95/2003/XP-document with a picture formatted 4 pt black border, created with LO 3.3.4
Comment 3 Christian 2012-02-28 02:56:05 UTC
Created attachment 57752 [details]
The way it looks in LO 3.3.4.
Comment 4 Christian 2012-02-28 03:03:31 UTC
Created attachment 57753 [details]
The way it looks in LO 3.5.
Comment 5 Christian 2012-05-07 04:16:49 UTC
Hallo Rainer!

Sorry for my delayed answer!

The error still exists in LO 3.5.3, original rpm's from libreoffice/ OS openSuse 12.1

The linewidth of borders of pictures is not displayed and saved correctly.

I have provided samples of the error.

BR


Christian 

> From: bugzilla-daemon@freedesktop.org
> To: christian.lo@hotmail.de
> Subject: [Bug 46563] FILEOPEN: Missing or wrong line width borders of pictures in doc-documents (MS Office 97, 2000, XP)
> Date: Fri, 24 Feb 2012 17:03:25 +0000
> 
> https://bugs.freedesktop.org/show_bug.cgi?id=46563
> 
> Rainer Bielefeld <LibreOffice@bielefeldundbuss.de> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |NEEDINFO
>                  CC|                            |LibreOffice@bielefeldundbus
>                    |                            |s.de
>      Ever Confirmed|0                           |1
> 
> --- Comment #1 from Rainer Bielefeld <LibreOffice@bielefeldundbuss.de> 2012-02-24 09:03:25 PST ---
> I am pretty sure that this one is a DUP of one of the bugs listed under "Bug
> 44768 - [Task]: FILEOPEN border compatibility issues". 
> 
> @Christian:
> We need a sample document.
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 6 Michael Stahl (CIB) 2012-05-23 03:30:36 UTC
border displayed with OOo 3.4beta,
missing in LO 3.4.3, LO 3.5.4 => regression.

possibly duplicate of bug 43249
Comment 7 Michael Stahl (CIB) 2012-06-11 11:52:01 UTC
this was fixed by e652ba3c7357e0396498629891a1391ace67c4d7,
which i've backported to libreoffice-3-5:

http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=0b8e6b2ba733719fc09dfe379b0d6b738723cdee
Comment 8 Christian 2012-06-26 07:44:21 UTC
I have tested it with LO 3.6beta2 and it works.
Thank's a lot!

Christian
Comment 9 Rainer Bielefeld Retired 2012-08-03 09:13:34 UTC
We need exact and correct target information for automated lists in Wiki and LibO Web Site.
Comment 10 Michael Stahl (CIB) 2012-08-21 09:27:26 UTC
*** Bug 51457 has been marked as a duplicate of this bug. ***
Comment 11 Michael Stahl (CIB) 2012-08-21 14:50:31 UTC
*** Bug 50581 has been marked as a duplicate of this bug. ***
Comment 12 Christian 2013-02-11 11:51:26 UTC
Problem description: On opening a doc-document (MS Office 97, 2000, XP) borders of pictures are not displayed. 

Steps to reproduce:
1. Create a document with LO 4.0. Insert a picture. Format the border to line width for example 3 pts and red color and save.
2. Open the document with LO 4.0 (Windows XP). Borders of the picture are not displayed. 
3. Open the same document with MS-Word 2003 (Windows XP). Borders of the picture are displayed with the right border width and color. 

Current behavior: Missing borders of pictures.

Expected behavior: Pictures with the right borderss

If you need further information please contact me.

Christian
Comment 13 Rainer Bielefeld Retired 2013-02-11 12:24:13 UTC
Reverted Version change

@Christian:
<http://wiki.documentfoundation.org/BugReport_Details#Version>,
please do not touch the dashboard, only contribute your observations in a comment. 

Did you really also see no border at all with 3.4 (where the bug appeared)? what was the borders info in picture-borders dialog in those cases?

@Michael: 
A picture border problem again is [Reproducible] with Server Installation of "LibO  4.0.0.3 rc   -  GERMAN UI / German Locale  [Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)]"  {tinderbox: @6, pull time 2013-01-31 11:30(?)} on German WIN7 Home Premium (64bit) with separate  new User Profile
Might be the same, might be a different Problem?

LibO 3.3.3:   Border 4pt                                           was ok
LibO 3.4.:    Border 0,25pt black (due to properties dialog)       !!!
LibO 3.5.7.2: Border 4pt                                           fixed
LibO 3.6.5.2: Border 4pt                                           fixed

LibO 4.0.0.3: NO Border  (due to properties dialog)    new Bug?    !!!
  Same with few days old 4.1.0.0+ Master

I think we close this one and submit a new one for the new problem?
Comment 14 Christian 2013-02-11 14:16:50 UTC
Sorry my mistake. It is a new bug for the version 4.0.0.3 and not a bug which reappears in LO 3.4.

BR

Christian

From: bugzilla-daemon@freedesktop.org
To: christian.lo@hotmail.de
Subject: [Bug 46563] FILEOPEN .doc (MSO97): Pictures and frames with missing border or wrong border line width
Date: Mon, 11 Feb 2013 12:24:13 +0000


    
      
    
     Rainer Bielefeld
 changed
              bug 46563
        

             
          
            What
            Removed
            Added
          

         
           Summary
           FILEOPEN: Missing or wrong line width borders of pictures in doc-documents (MS Office 97, 2000, XP)
           
           FILEOPEN .doc (MSO97): Pictures and frames with missing border or wrong border line width
           
         

         
           Version
           4.0.0.3 release
           
           3.4.3 release
           
         
      
        
            Comment # 13
              on bug 46563
              from  Rainer Bielefeld

        Reverted Version change

@Christian:
<http://wiki.documentfoundation.org/BugReport_Details#Version>,
please do not touch the dashboard, only contribute your observations in a
comment. 

Did you really also see no border at all with 3.4 (where the bug appeared)?
what was the borders info in picture-borders dialog in those cases?

@Michael: 
A picture border problem again is [Reproducible] with Server Installation of
"LibO  4.0.0.3 rc   -  GERMAN UI / German Locale  [Build ID:
7545bee9c2a0782548772a21bc84a9dcc583b89)]"  {tinderbox: @6, pull time
2013-01-31 11:30(?)} on German WIN7 Home Premium (64bit) with separate  new
User Profile
Might be the same, might be a different Problem?

LibO 3.3.3:   Border 4pt                                           was ok
LibO 3.4.:    Border 0,25pt black (due to properties dialog)       !!!
LibO 3.5.7.2: Border 4pt                                           fixed
LibO 3.6.5.2: Border 4pt                                           fixed

LibO 4.0.0.3: NO Border  (due to properties dialog)    new Bug?    !!!
  Same with few days old 4.1.0.0+ Master

I think we close this one and submit a new one for the new problem?
        
      
      
      You are receiving this mail because:
      
      
          You reported the bug.
Comment 15 Michael Stahl (CIB) 2013-02-11 22:57:58 UTC
the new bug in 4.0 is a different bug that has some common symptoms
with this one; i have filed bug 60703 to track it.
Comment 16 Robinson Tryon (qubit) 2015-12-22 01:30:59 UTC
Removing comma from Whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
[NinjaEdit]