Bug 46646 - FORMATTING: ### in cells
Summary: FORMATTING: ### in cells
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-26 05:58 UTC by 16heads
Modified: 2012-02-27 08:07 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
file wich shows wrong behavior on rendering (29.50 KB, application/vnd.ms-excel)
2012-02-26 05:58 UTC, 16heads
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 16heads 2012-02-26 05:58:48 UTC
Created attachment 57661 [details]
file wich shows wrong behavior on rendering

Problem description: 
some formatted cells masked with '###' characters(adress:x4-as4;n26),
when cells formating emptied(cleared) document works as suggested.
in LO3.4.4 opens normally without '###'.

Steps to reproduce:
1. file created not by me(msoffice version is unknown for me)

Current behavior: some formatted cells are masked with '###'

Expected behavior: properly displaying formated cells from msoffice.

Platform (if different from the browser): Calculate Linux Desktop 11,12 amd64(gentoo based).
Comment 1 Michael Meeks 2012-02-27 02:32:51 UTC
So - this is a font and cell sizing issue - the ### just means the number and it's format are larger than the column size which they're inside. Just re-size the column :-)

On Linux this is a particularly hard problem to get right due to the lack of Microsoft fonts etc.

I suspect you are simply missing a good equivalent for "Times New Roman" on your machine, this works perfectly on mine :-)
Comment 2 16heads 2012-02-27 08:07:15 UTC
Hi Michael.
Thank you for suggestion, I will try to change font name.
I wanna admit that on ubuntu 11.10 it shows all fine, without '###'

27 лютого 2012 р. 12:32 <bugzilla-daemon@freedesktop.org> написав:

> https://bugs.freedesktop.org/show_bug.cgi?id=46646
>
> Michael Meeks <michael.meeks@novell.com> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>         OS/Version|All                         |Linux (All)
>             Status|UNCONFIRMED                 |RESOLVED
>         Resolution|                            |NOTOURBUG
>
> --- Comment #1 from Michael Meeks <michael.meeks@novell.com> 2012-02-27
> 02:32:51 PST ---
> So - this is a font and cell sizing issue - the ### just means the number
> and
> it's format are larger than the column size which they're inside. Just
> re-size
> the column :-)
>
> On Linux this is a particularly hard problem to get right due to the lack
> of
> Microsoft fonts etc.
>
> I suspect you are simply missing a good equivalent for "Times New Roman" on
> your machine, this works perfectly on mine :-)
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>