Download it now!
Bug 46832 - uno.util.Bootstrap.bootstrap() throws exception in .NET.
Summary: uno.util.Bootstrap.bootstrap() throws exception in .NET.
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Noel Power
URL:
Whiteboard: target:3.6.0 target:3.5.2
Keywords:
: 46224 46682 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-01 08:28 UTC by christer.bergstrom.se
Modified: 2020-02-11 16:05 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
time (deleted)
2016-03-04 15:03 UTC, petrqidisakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christer.bergstrom.se 2012-03-01 08:28:07 UTC
Hi,

Problem when bootstrapping from C# via  "uno.util.Bootstrap.bootstrap()"

This problem was present in pre version 3.4. Works in 3.4.5 but after installing 3.5 the problem has returned:

System.Runtime.InteropServices.SEHException
error code: -2147467259 
"An external component thrown an Exception" 
source: cli_cppuhelper

Found an old bug report #35108 regarding this. 
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=35108#c2

Have also seen others mention the problem in 3.5 on the web, but haven't seen any bug reports yet.

Best regards
Christer B
Comment 1 Petr Mladek 2012-03-01 08:50:57 UTC
I guess that it is related to the 3-layer removal. We need to update a path somewhere.
Comment 2 Petr Mladek 2012-03-01 08:52:14 UTC
Of course, we need to fix it but it affects only limited group of users. So, it can't block the 3.5.1 release. So, lower the severity a bit.
Comment 3 Marten Feldtmann 2012-03-06 13:15:42 UTC
A "limited group of users" - actually all those persons doing some kind of programming under Windows using .NET.

After having so many problems in this area with pre 3.4 versions and now again with 3.5 versions I guess, that our company simply will give up (direct) support for this software from our software tools simply due to heavy QA problems in this area.
Comment 4 Martho 2012-03-06 23:28:06 UTC
+1 We are using the SDK in a professional environment as well but with C++, the same error occurs there. If we cannot rely that it works in every version or is at least fixed quickly in the next minor version our company has to abandon libreoffice and recommend our customers either to switch back to openoffice or to microsoft office.
Comment 5 Marten Feldtmann 2012-03-07 00:21:34 UTC
One writer mentioned this error also in:

https://bugs.freedesktop.org/show_bug.cgi?id=46224
Comment 6 Noel Power 2012-03-07 12:17:33 UTC
hmm, after some debugging it seems binaryurp.uno.dll fails to load, no real info I could see in osl_loadModule either, just no handle returned ( and path is good ) I don't have the windows smarts to detect where else to look for errors
Tried running it in the VS debugger I see that there is nag dialog complaining about msvcp90.dll not being found ( at the point it tries to load binaryurp.uno.dll ). I'm not being familiar with windows but I do know that there are certain security whatnots around loading runtimes etc. I notice that there is a soffice.bin.manifest that contains some dependecy/dependentAssembly nodes relating to this runtime. In fact when I copied the soffice.bin.manifest to csharptestclient.exe.manifest ( to match the csharpclient.exe I was using to test this bug ) it works fine. Perhaps there is a similar solution for some of the .net bridge dll(s) that might get over this problem

Creating such a manifest might be a usable workaround? until a better solution
Comment 7 Noel Power 2012-03-08 02:25:46 UTC
(In reply to comment #4)
> +1 We are using the SDK in a professional environment as well but with C++, the
> same error occurs there.
and I suppose you reported the bug right?
 If we cannot rely that it works in every version or is
> at least fixed quickly in the next minor version our company has to abandon
> libreoffice
I'd say right now people are shaking in their boots that you might abandon libreoffice. You do realise that libreoffice is a community opensource project, if you expect enterprise level support then you should pay for it. There are companies like Suse, Red Hat and others that employ paid developers, I'm sure they offer paid support too. 
I wonder why do you use opensource at all?, If like you imply you are building software commercially that uses libreoffice then clearly you are developers and should be able to help yourselves. One of the compelling reasons for using opensource is that if and when there are problems then you really can change things, 
 o if there is a bug you can help fix it by debugging, fixing and sending a patch or even just by opening quality bug reports with decent descriptions and steps to reproduce, 
 o if there is a feature gap you can help fill it.
But, sadly it seems you think that using opensource software just you access to free software and and a team of volunteers who will slave over your problem when you demand it 
> and recommend our customers either to switch back to openoffice or
> to microsoft office.
good luck with that :)
Comment 8 Noel Power 2012-03-08 02:36:28 UTC
seems there might be a build problem, binaryurp has no embedded manifest containing the dependency on VC90 runtime stuff
Comment 9 Stephan Bergmann 2012-03-08 04:02:05 UTC
*** Bug 46682 has been marked as a duplicate of this bug. ***
Comment 10 Martho 2012-03-08 07:55:33 UTC
> I'd say right now people are shaking in their boots that you might abandon
> libreoffice. You do realise that libreoffice is a community opensource project,
> if you expect enterprise level support then you should pay for it.
You are right with everything you say. I was just wondering how Petrs comment was about to be understood: That the SDK is not important enough to be fixed as soon as possible, even if it's a critical bug? In the past we were very fine how things were handled, but if there is a change in the communities opinion concerning the SDK I just want to know. I just got the feeling from here and from the mailing-lists that the SDK is not supported very much anymore.
Comment 11 Not Assigned 2012-03-08 08:05:07 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3d806be7d30a437607d924a4d33f13fe20dd1ba

fix uno bootstrapping for .NET ( and perhaps c++ ) fdo#46832
Comment 12 Lafriks 2012-03-08 08:57:18 UTC
Will this fix go also in 3.5.1?
Comment 13 Not Assigned 2012-03-16 08:01:45 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c6246139df005d6ac4627bc8f4665539effb6e94&g=libreoffice-3-5

fix uno bootstrapping for .NET ( and perhaps c++ ) fdo#46832


It will be available in LibreOffice 3.5.2.
Comment 14 Rainer Bielefeld Retired 2012-04-05 08:10:28 UTC
I added Fix submitter as assignee because this will ease queries and bug tracking.
Comment 15 Thomas Arnhold 2013-02-20 07:42:34 UTC
*** Bug 46224 has been marked as a duplicate of this bug. ***
Comment 16 petrqidisakov 2016-03-04 15:03:08 UTC
Created attachment 123233 [details]
time
Comment 17 Christian Lohmaier 2016-03-04 15:21:21 UTC
The content of attachment 123233 [details] has been deleted
Comment 18 dnahrblock 2018-01-22 09:59:20 UTC Comment hidden (spam)
Comment 19 zian rizky 2018-11-25 07:38:03 UTC Comment hidden (spam)
Comment 20 canlitv 2019-07-26 22:12:36 UTC Comment hidden (spam)
Comment 21 babelite 2019-08-07 08:08:25 UTC Comment hidden (spam)