Bug 46839 - Writer: Drawing Object Properties toolbar: Turn Combobox Line Color into Split Button
Summary: Writer: Drawing Object Properties toolbar: Turn Combobox Line Color into Spli...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 RC1
Hardware: All All
: medium normal
Assignee: Maxim Monastirsky
QA Contact:
URL:
Whiteboard: target:4.3.0
Keywords:
: 46840 (view as bug list)
Depends on:
Blocks: 45671
  Show dependency treegraph
 
Reported: 2012-03-01 10:19 UTC by Stefan Knorr (astron)
Modified: 2015-04-21 15:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2012-03-01 10:19:58 UTC
We should try to use split buttons for all toolbar color choosers, for a longer
rationale, see: bug 45671.

How to get to see the combo box:
* Open Writer
* Add a shape or a fontwork (with the Drawing toolbar)
Result: Drawing Object Properties toolbar appears on top, below the Standard toolbar.
* In the aforementioned toolbar, see the first combobox (Line Color)

This is a combo box, but ideally, it should be a split button.
Comment 1 sasha.libreoffice 2012-08-07 10:31:51 UTC
Thanks for bugreport
reproduced in 3.6.0rc in Writer in "Text object" toolbar only. In "Formatting" toolbar all already splitted.
Comment 2 leighman 2012-08-08 11:44:17 UTC
Comment from metabug:
-46839 (writer line colour) this control is of a completely differently type
and doesn't allow straightforward conversion to split button. I don't know how
and where the types of the controls of the UI are set.
Comment 3 Maxim Monastirsky 2014-05-18 11:10:08 UTC
*** Bug 46840 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2014-05-18 11:52:49 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e4ce7d286a5039e5a65ba994bd1b168679d4a7c3

fdo#46839 Convert line color picker to split button



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.