Download it now!
Bug 46923 - CRASH EDITING Thai text
Summary: CRASH EDITING Thai text
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Windows (All)
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:3.6.0 target:3.5.2
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-03-03 02:20 UTC by panyazone
Modified: 2012-12-22 01:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Problem description with sample data (37.87 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-03-03 02:20 UTC, panyazone
Details
probable fix (1.04 KB, patch)
2012-03-14 06:57 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description panyazone 2012-03-03 02:20:15 UTC
Created attachment 57959 [details]
Problem description with sample data

LibreOffice crashes by some Thai character sequence input in Calc

LibreOffice 3.5.0rc3 under Windows 7 Professional.

While using Calc and keying in some specific pattern of mixed Thai and English texts at the Input Line, the whole LibreOffice application, i.e., all opened Calc files, Writer files, etc., crash with the last entry of a specific Thai character string. See attached file for detail.

Other minor problem with Thai characters which might relate to this bug.
1. Cell content starting with Thai character is displayed right aligned. It should be left-aligned by default.
2. Some character combinations cause Input Line, Tab name, Input Line of "Rename Sheet" pop-up window to display strange characters.
3. Some long mixed Thai-English text are displayed with wrongly-spaced characters at the Input Line.
Comment 1 Rainer Bielefeld Retired 2012-03-03 04:01:13 UTC
[Reproducible] with reporter's sample and "LibreOffice 3.5.1.1 German UI/Locale [Build-ID: 45a2874-aa8c38d-dff3b9c-def3dbd-62463c8] on German WIN7 Home Premium (64bit) 

No problem with 3.4.5, so REGRESSION

Related to "Bug 45355 - CRASH if characters in text of BENGALI, TIBETAN, MALAYALAM, MARATHI, NEPALI, ORIYA, TAMIL, TELUGU"? But that one is not visible for me with 3.5.1.1 or 3.5.0 RC2

@panyazone@gmail.com
Can you please check whether it's related to Bug 45355?
Comment 2 panyazone 2012-03-04 18:17:26 UTC
Bug 45355 is on Writer, but this bug 46923 is on Calc. They are different.

I have tested Bug 45355 with Writer LibreOffice 3.5.0 Released version on Windows 7 Professional by using the given Asian Language Strings in the bug report, one string at a time. 

First I copy one string and paste it on Writer. Nothing happen s for a while, then the cursor changes to waiting (round spinning) icon and Program Title bar show "(Not responding)" for about 30 seconds, then the LO is back to normal. LO does not crash. The text appeared in the first cell of the 1-row x 2-column table. If I paste a text as unformatted text, the program is perfectly normal.

Conclusion, Bug 45355 is gone for LO 3.5.0.
Comment 3 panyazone 2012-03-08 03:11:39 UTC
(In reply to comment #1)
> [Reproducible] with reporter's sample and "LibreOffice 3.5.1.1 German UI/Locale
> [Build-ID: 45a2874-aa8c38d-dff3b9c-def3dbd-62463c8] on German WIN7 Home Premium
> (64bit) 
> No problem with 3.4.5, so REGRESSION
> Related to "Bug 45355 - CRASH if characters in text of BENGALI, TIBETAN,
> MALAYALAM, MARATHI, NEPALI, ORIYA, TAMIL, TELUGU"? But that one is not visible
> for me with 3.5.1.1 or 3.5.0 RC2
> @panyazone@gmail.com
> Can you please check whether it's related to Bug 45355?

Confirm that 3.4.5 OOO340m1 (Build:502) did not crash with my sample data. The minor problem #1 as reported also appears a bit better in 3.4.5 than 3.5, i.e., Thai text in the cell area is left-alligned in the cell by default, but it appeared with wrongly-space in the Input Line. The minor problem #2 and #3 are the same in both 3.4.5 and 3.5.

So I will stay with 3.4.5. Does "REGRESSION" mean the bug should be fixed in the next release?
Comment 4 Caolán McNamara 2012-03-08 07:49:35 UTC
I can reproduce a problem under Linux in extra-debugging mode anyway which is plausibly the crash-under-windows problem.
Comment 5 Not Assigned 2012-03-08 08:05:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a3f1614c606629196ca71dc22dab3343b060dced

Resolves: fdo#46923 uninitialized iterators are invalid
Comment 6 Caolán McNamara 2012-03-09 01:10:30 UTC
bah, the bug I fixed was a Linux-only bug only in 3.6.0 series, I can now reproduce the windows-only 3.5.0 bug which remains unfixed for the moment
Comment 7 Caolán McNamara 2012-03-14 06:57:19 UTC
Created attachment 58434 [details]
probable fix
Comment 8 panyazone 2012-03-20 04:47:12 UTC
(In reply to comment #7)
> Created attachment 58434 [details] [review]
> probable fix

Great! I will wait for 3.6.0 to test. Were the minor problems also fixed?
Comment 9 Not Assigned 2012-03-20 06:13:57 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=88907415f03b4566d0ed87e98e372dd5c3c74e50&g=libreoffice-3-5

Resolves: fdo#46923 fdo#46750 revert thai glyph fallback


It will be available in LibreOffice 3.5.2.
Comment 10 Caolán McNamara 2012-03-20 06:23:18 UTC
probably not, some of the minor problems might be fixed by it alright

*** This bug has been marked as a duplicate of bug 46750 ***
Comment 11 Not Assigned 2012-03-20 06:54:03 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eeffbc94d129756410bd2a9198dff5858479738f

Resolves: fdo#46923/fdo#46750 take mnSubStringMin into account
Comment 12 panyazone 2012-03-20 09:34:34 UTC
(In reply to comment #10)
> probably not, some of the minor problems might be fixed by it alright
> *** This bug has been marked as a duplicate of bug 46750 ***

The minor problem #3 is the same as Bug 33090 which you have fixed. It was found in 3.5.0 and still reproducible in 3.5.1.2 Build ID: dc9775d-05ecbee-0851ad3-1586698-727bf66. However, the test text string “สวัสดี Hello ขอบคุณ Thanks” used to report Bug 33090 can be displayed correctly in 3.5.1.2.

To me, the minor problems #2 is also of the same nature as Bug 33090. Will you consider to continue working on them within Bug 33090?

The minor problem #1 seems different and still exist in 3.5.1.2. Should I report it as a separate bug?
Comment 13 Rainer Bielefeld Retired 2012-03-21 00:09:09 UTC
Is this one a DUP or fixed or whatever? A DUP IMHO can't have a Whiteboard target, this one is for Spreadsheet, "Bug 42450 - FILEOPEN: ooconvert crashes while processing docx file" for WRITER?

"Bug 43465 - FILEOPEN document with Thai text contents" sounds similar.
Comment 14 Caolán McNamara 2012-03-21 04:55:22 UTC
A little bit of confusion as to what's a duplicate of what. Double checking on windows with and without http://cgit.freedesktop.org/libreoffice/core/commit/?id=eeffbc94d129756410bd2a9198dff5858479738f then this bug and bug 46750 appear to be the same problem anyway
Comment 15 Caolán McNamara 2012-03-21 04:57:21 UTC
gagh, I mean bug 46896 and this one.
Comment 16 Caolán McNamara 2012-03-21 04:57:35 UTC
*** Bug 46896 has been marked as a duplicate of this bug. ***
Comment 17 panyazone 2012-04-12 10:03:15 UTC
I have just tested my sample data (attachment 57959 [details]) with version 3.5.2 Release, and confirm that the problem is fixed. Thanks all who helped fixing it.

The minor problems mentioned in my original bug report are now reported as Bug 48597 (Calc cell content starting with Thai character is right-aligned by default) and Bug 48614 (Thai characters rendered incorrectly).