Bug Hunting Session
Bug 47049 - Minimized document then opened from explorer does not restore
Summary: Minimized document then opened from explorer does not restore
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 81013 (view as bug list)
Depends on:
Blocks: Desktop-Integration
  Show dependency treegraph
 
Reported: 2012-03-07 05:44 UTC by Cris Mooney
Modified: 2018-10-18 07:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cris Mooney 2012-03-07 05:44:19 UTC
In windows (tested Win XPsp3, clean install LibraOffice 3.5.0r3):

1. Open a LibreOffice document (brand new trivial document).
2. Minimize the document to the task bar.
3. Open the same document again from windows Explorer.
4. User experience is that nothing happens.

Expectation: the opened document should "restore" from the task bar - otherwise most any user will think the "open" did not work.

Core issue: My original test was with LibreOffice "Writer", but I also confirmed "Calc" and so I suspect this is a core library issue and thus reported it as just LibreOffice, without citing a component.

This issue was brought to my attention helping a relatively novice user who repeatedly assumed "the document was broken", when in fact it was simply already open. This seems like an important "real world" issue that likely confuses very many users, especially with open documents "group" stacked on the task bar, and thus important to user acceptance and use of the product.

Note: this was originally noted on a Windows 7 system. When I was unable to find any related item in Bugzilla, I downloaded the current release LibraOffice 3.5.0r3 and installed on a few week old fresh Windows XPsp3 build. I found the issue to be 100% reproducible. Please do not hesitate to contact me if someone looking into this does not find it repeatable, and I will be happy to dig deeper.
Comment 1 sasha.libreoffice 2012-05-30 06:13:31 UTC
Thanks for bugreport
problem reproduced in 3.3.4 on Fedora KDE and in 3.5.2 on Windows 7
but not reprodced in 3.5.3 on Fedora, may be fixed?
Comment 2 Cris Mooney 2012-05-30 09:24:36 UTC
The only quick download for windows I see online at the moment is 3.5.4.2, to which I upgraded from my clean install 3.5.0rc3 on XP SP3.

The problem persists for me in 3.5.4.2:

1. Open a LibreOffice document (brand new trivial document).
2. Minimize the document to the task bar.
3. Open the same document again from windows Explorer.
4. User experience is that nothing happens.

For steps 1 and 3 I tried both "double click" the "untitled 1.odt" I'd created on the desktop (content just "test" text), and right click "open".

Sorry I can't confirm your findings for Windows (XP).
Comment 3 sasha.libreoffice 2012-05-30 23:35:30 UTC
Thanks for additional testing. Therefore for Windows problem remains
Comment 4 tommy27 2014-07-08 00:56:22 UTC
*** Bug 81013 has been marked as a duplicate of this bug. ***
Comment 5 persister48 2014-10-22 22:21:27 UTC
I have the latest version of Libre Office. I just want to say that as of 10/22/2014 I am having the same problem with Libre Office Writer. Every time I double click on the Explorer window, to open a document, the Explorer window stays on top. It's a real pain. I hope Libre Office will correct it in the next version.

I love Libre Office!!
Comment 6 QA Administrators 2015-12-20 16:16:43 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-01-03 19:49:30 UTC Comment hidden (obsolete)
Comment 8 Thomas Lendo 2018-10-18 07:19:57 UTC
Works for me on Windows 10 with

Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 8; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-AT (de_AT); Calc: group

Closing as RESOLVED WORKSFORME.

If you still have the problem, please reopen as NEW.