Bug Hunting Session
Bug 47089 - : LO Crashes if in File Open Dialog the Context Menu is Used to Copy Files
Summary: : LO Crashes if in File Open Dialog the Context Menu is Used to Copy Files
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 79800 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-08 01:14 UTC by Harald Koester
Modified: 2015-12-11 18:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2012-03-08 01:14:42 UTC
Problem description: 

I observed 2 ways in order to reproduce the problem. First way:
[1] Start LibreOffice.
[2] Select "Text Document". Document "Untitled 1" is opened.
[3] Select: File > Open... The Open Dialog of Windows is displayed.
[4] Right click on one of the displayed files. The context menu is opened.
[5] Select "Copy". The context menu is closed.
[6] Try to close the Copy dialog. The mouse pointer changes to the sandglass of Windows...
[7] And that was it. Some seconds later: Windows message, that the program does not react.

Second way in order to reproduce the problem:
[1] Start LibreOffice
[2] Select "Open...". The Open Dialog of Windows is displayed.
[3] Right click on one of the displayed files. The context menu is opened.
[4] Select "Copy". The context menu is closed.
[5] Cancel Open dialog.
[6] Select "Text Document". Document "Untitled 1" is opened. Cursor is displayed at first position, but it does not flash.
[7] Try to insert text. It does not work.
[8] Click into working area. The mouse pointer changes to the sandglass of Windows...
[9] That was it. The only way to continue, is to cancel LibreOffice. Then: Windows message, that the program does not react.

If I used instead of a text document a spreadsheet, the result is random. Sometimes LO crashes at once, sometimes LO crashes, when I tried to save the spreadsheet, or sometimes LO crashes, if I tried later to open a new text document. Hence my impression is, that the bug can occur with a long delay.

LO versions: 3.4.5 and 3.5.0. According a mail in the German user mailing list also in all older versions of LO and also in OOo.

OS: Windows XP Home Service Pack 3, also other XP versions according mails in German user mailing list. But it seemed that not all users of XP have this problem.
Comment 1 Rainer Bielefeld Retired 2012-03-08 02:37:25 UTC
NOT reproducible with "LibreOffice 3.5.1.2 German UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit)
Comment 2 Urmas 2012-03-08 03:05:20 UTC
I can confirm with 3.5.1.1 with XP.
Comment 3 Edgar 2012-03-08 03:25:47 UTC
I can confirm the issue.
System Windows XP Prof. SP3
LO 3.5.0 (new user profile)
Comment 4 Julien Nabet 2012-10-21 12:18:30 UTC
harald/Urmas/Edgar: I haven't tested but Rainer didn't reproduce it with 3.5.1.2 and it was some months ago. Could you give a try to 3.5.6 or 3.6.2 and tell us if you still reproduce it? If still reproduce, test again after having renamed your LO profile (see http://wiki.documentfoundation.org/UserProfile)
Comment 5 Harald Koester 2012-11-28 22:36:57 UTC
I was not able to reproduced the bug with Version 3.5.0 and 3.6.3 on Win 7. It seemed that all occurrences of the bug are reported with Win XP. So it may be only a problem of LO together with XP. In the moment I have not got a Win XP system in order to check this. Perhaps later.
Comment 6 Julien Nabet 2012-12-05 19:18:29 UTC
harald: Thank you for your feedback.I put this to WFM.
Don't hesitate to reopen this tracker if you reproduce this.
Comment 7 Urmas 2014-06-09 05:10:38 UTC
*** Bug 79800 has been marked as a duplicate of this bug. ***
Comment 8 Joel Madero 2014-11-05 23:58:15 UTC
Looks like this was confirmed by Urmas - moving to NEW as REOPENED is incorrect status.
Comment 9 Julien Nabet 2015-11-10 21:49:39 UTC
We don't even know with which LO version tdf#79800 + no feedback from his reporter
Let's put this one to WFM.
After all, if Harald confirms it's ok (at least for not Windows XP, but even MS doesn't support XP anymore...), let's not waste more time.
Comment 10 Harald Koester 2015-12-11 18:48:05 UTC
I checked the bug again with version 5.0.3. It still does not appear with Win7. Hence bug closed.