Bug Hunting Session
Bug 47250 - Writer crashes when control-clicking/right-clicking on table cells, if DudenKorrektor extension is installed
Summary: Writer crashes when control-clicking/right-clicking on table cells, if DudenK...
Status: RESOLVED DUPLICATE of bug 58177
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86 (IA32) Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0 target:3.6.4
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-12 12:47 UTC by Reiner Anselm
Modified: 2012-12-14 16:38 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash-Dump (56.07 KB, text/plain)
2012-10-10 16:00 UTC, Reiner Anselm
Details
plausible workaround (445 bytes, patch)
2012-10-12 10:25 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reiner Anselm 2012-03-12 12:47:29 UTC
Insert a table in a document, mark some cells and then try to get the context menu (in order to change the formatting, borders etc.): LO crashes immediately. I assume that this affects a core function of writer -> blocker. With this bug, the table-function is unusable.
Comment 1 vitriol 2012-03-12 12:53:05 UTC
Probably duplicate of Bug 47015. Marked as a dup for now.

*** This bug has been marked as a duplicate of bug 47015 ***
Comment 2 Roman Eisele 2012-09-14 14:24:08 UTC
(In reply to comment #1)
> Probably duplicate of Bug 47015. Marked as a dup for now.

As far as I can see, this bug report is NOT a duplicate of bug 47015.

Bug 47015 talks about actually changing the border format of a table, i.e. about a crash which occurs *after* you have changed some settings in the “Table” dialog window, “Border” tab, and have clicked on the “OK” button. But the present bug talks about a crash which immediately occurs as soon as you “mark some cells and then try to get the context menu”, probably by control-clicking on the selected cells of the table. IMHO this is a completely different issue.

(Decreasing the Severity a bit: in the LibreOffice QA process, we don’t use “blocker” for normal bugs, not even for very very critical ones, but “critical” instead. But “critical” is appropriate, of course.)
Comment 3 Roman Eisele 2012-09-14 14:34:04 UTC
@ Reiner Anselm:

Thank you very much for your bug report! I am sorry that it has not yet been addressed, probably due to the fact that it was misunderstood as a duplicate of another, very difficult bug (which should be fixed now, BTW).

Now please tell me if I understand the issue correctly, i.e., if my explanation in comment #2 is correct: Did the crash really happen as soon as you tried to open the context menu via control-clicking on the selected cells of the table? Or am I missing something?


Additionally, it would be very helpful if you could answer/handle some/all of the following questions and requests:

-- Can you still reproduce this bug, and with which version of LibreOffice, and on which version of Mac OS X?

-- If you can still reproduce the crash, can you please save the debug information which is displayed by Mac OS in a window after the crash to a text file and attach it to the present bug report?

-- If you can still reproduce the crash, please check if any of the following possible explanations is true:

   a) Do you have any accesibility features enabled? Apple’s accessibility features like "VoiceOver" or "Enable access for assistive devices", which get enabled in "System Preferences > Universal Access" (in German: "Bedienungshilfen"; dont’t know about other languages), are known to cause many crashes in LibreOffice (see bug 47368). So please try to disable any accesibility features, i.e. uncheck "VoiceOver", "Enable access for assistive devices", etc.

   b) Do you have installed any window management/user interface utilities/apps
for MacOS X like 
* Moom           (see bug 42014)
* Cinch          (see bug 51791)
* RightZoom      (see bug 51686)
* ShiftIt        (see bug 52147)
* BetterSnapTool (see bug 53240)?
All these and many similar utilities rely heavily on accessibility issues and
therefore cause LibreOffice to crash. So please check if you have installed any
utility of this kind and try to disable it (or to add LibreOffice to the list
of excluded applications for the utility, if there is such a thing).

   Disabling both all of Apple’s accessibility features and all
accessibility-related/window management utilities, and then re-starting your
Mac could fix the LibreOffice crash. Please try this.


Thank you very much in advance for your answer! With some additional information from you, I may be able to reproduce the crash, and then our developers may be able to fix it.
Comment 4 Roman Eisele 2012-10-10 15:23:47 UTC
This *could* be the same issue as bug 55671 -- but I can’t tell without answer from the original reporter.


@ Reiner Anselm:

Please understand that we can’t get any progress about this bug without further information from your side. Therefore please re-visit the bug’s page:
  https://bugs.freedesktop.org/show_bug.cgi?id=47250
read the questions in comment #3 and try to answer them by typing your answers into the “Additional Comments” field and then clicking on “Save Changes”. Else, we have to close this bug report.

Thank you very much!
Comment 5 Reiner Anselm 2012-10-10 16:00:48 UTC
Created attachment 68406 [details]
Crash-Dump
Comment 6 Reiner Anselm 2012-10-10 16:01:50 UTC
@Roman: Thank you very much for your engagement concerning this bug!
As to your questions:

The bug exists still in LO 3.6.2.1. To reproduce it simply ad a table, mark two or more cells and try to get the context menu (2-fingers or ctrl-click). OS is Mac OS X 7.4

I have no accessibility features enabled, also I don't use any window management tool. 

I attach the crash-dump.

I'm currently quite short with my time so please excuse my short answers. But I hope you can now identify and fix this bug.
Comment 7 Roman Eisele 2012-10-10 16:07:59 UTC
@Anselm:

Thank you very much for your fast answer, and especially for the crash dump!

The stack trace (in the crash dump) contains a very interesting entry:

9   dudenkorrektor.uno.dylib   0x249011b2
Duden::ContextMenuInterceptor::notifyContextMenuExecute(com::sun::star::ui::ContextMenuExecuteEvent const&) + 2922

Obviously this means that you use the Duden Corrector extension, don’t you?

Could you please, when you find some time, just test the following:
-- Deactivate the Duden Corrector extension
-- Quit and restart LibreOffice
-- Try to reproduce the issue by the same steps as before:
   “... simply ad a table, mark two or more cells and try to get
   the context menu (2-fingers or ctrl-click)”?

It would be very very interesting to know if LibreOffice continues to crash *without* the Duden Corrector extension!

Thank you very much!
Comment 8 Roman Eisele 2012-10-11 09:58:54 UTC
@Anselm:

Additional question: which *version* of the “Duden Korrector” or “Duden-Rechtschreibprüfung” extension do you use? 6.0, 8.0 or ...?

(Changed the Summary field to distinguish this bug report from similar, but not related ones.)
Comment 9 Reiner Anselm 2012-10-12 09:00:04 UTC
News from testing: If you deactivate DudenKorrektor, LO don't crash. I use DudenKorrektor 8.0.0.2. After the re-activation LO crashes again.
Comment 10 Roman Eisele 2012-10-12 09:17:00 UTC
Thank you for testing!

Therefore, and because of the stack trace, which suggests that the crash is related to Duden::ContextMenuInterceptor::notifyContextMenuExecute() -- does the extension raise an unhandled exception? --, I think this either a bug *in* or a LibO problem *with* the DudenKorrektor extension. → Changing Component field.
Comment 11 Roman Eisele 2012-10-12 09:38:09 UTC
@ David Tardon;
@ manj_k, Fridrich Strba, and Stephan Hennig:

I have added you all to the CC list of this bug report, because you, David, are our Extension management expert, and the others (manj_k, Fridrich Strba, and Stephan Hennig) have some experience with the Duden Korrektor extension.
Can you please help with this issue?:

This seems to be either a bug in the Duden Korrektor 8.0.0.2 extension, or a bug in LibreOffice which affects especially this extension. How can we judge this? And what should we do about this bug -- can some LibreOffice developer look into it, or should we report it to Duden (and how)?

Thank you very much!
Comment 12 Caolán McNamara 2012-10-12 10:22:45 UTC
DudenKorrektor is only available if I buy it, right ? There's no trial version or anything like that available for installation for debugging this ?
Comment 13 Caolán McNamara 2012-10-12 10:25:12 UTC
Created attachment 68480 [details]
plausible workaround

Duden::ContextMenuInterceptor::notifyContextMenuExecute is obviously inside the duden extension itself and it's throwing *some* sort of exception for an unknown reason.

SfxViewShell::TryContextMenuInterception calls notifyContextMenuExecute in a try catch block. Its plausible that if we change the catch there from catching uno::RuntimeException to catch everything that it'll stop crashing.

Someone with Duden and the crash needs to build with this patch applied to see if it fixes it.
Comment 14 manj_k 2012-10-12 12:51:48 UTC
Trial versions (30 days) of "Duden-Rechtschreibprüfung 9.0 für OpenOffice und LibreOffice" are available on → http://www.duden.de/support/testversionen
Comment 15 manj_k 2012-10-12 13:29:18 UTC
Crash not reproducible (on Windows XP 32b) with
- LibO 3.6.3.1 (Build ID: f8fce0b)
- Duden Rechtschreibprüfung (Demo-Version) 9.0.0.2 [DRO-D.oxt 2012-08-31].
Comment 16 Roman Eisele 2012-10-12 14:32:28 UTC
(In reply to comment #15)
> Crash not reproducible (on Windows XP 32b) with
> - LibO 3.6.3.1 (Build ID: f8fce0b)
> - Duden Rechtschreibprüfung (Demo-Version) 9.0.0.2 [DRO-D.oxt 2012-08-31].

Bad. So either the problem has been fixed in version 9.0.0.2 of the extension, or it appears only on Mac OS X, or it does not appear in the trial version. But who knows?
Comment 17 Reiner Anselm 2012-10-13 07:57:18 UTC
We can exclude one scenario: The problem doesn't appear in DudenKorrektor 9.0.0.2 and MacOS X. So I think it is fixed in the new version of the DudenKorrektor
Comment 18 Roman Eisele 2012-10-13 09:11:27 UTC
(In reply to comment #17)
> We can exclude one scenario: The problem doesn't appear in DudenKorrektor
> 9.0.0.2 and MacOS X. So I think it is fixed in the new version of the
> DudenKorrektor

Thank you for this important hint!

So, how to proceed now? Should we just mark this as RESOLVED/NOTOURBUG (because any remaining problems with DudenKorrekter 8.x are up to the folks at Duden)? I would suggest to do so ...
Comment 19 Reiner Anselm 2012-10-13 09:33:17 UTC
Me too.
Comment 20 Roman Eisele 2012-10-13 13:34:46 UTC
@ Caolán McNamara:
Thank you for your investigation and the plausible workaround! What would you say:
Should we keep this issue open for further investigation, waiting for someone with Duden Korrektor 8.x and building skills, to test your patch, or should we just close the issue (at least for now) as RESOLVED/NOTOURBUG?
Comment 21 Caolán McNamara 2012-10-14 13:35:42 UTC
Lets go with resolved/notourbug as the latest Duden works again. I'll push my patch to master anyway cause it doesn't hurt, but won't go through the rigmarole to get it into 3-5/3-6
Comment 22 Not Assigned 2012-10-14 13:43:21 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22a550690bc7643ba1157543e15907ebba9444a0

Related: fdo#47250 catch harder



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Roman Eisele 2012-10-14 14:10:53 UTC
@ Caolán:
Thank you for you decision!
Comment 24 Caolán McNamara 2012-10-30 12:14:19 UTC
*** Bug 56430 has been marked as a duplicate of this bug. ***
Comment 25 Caolán McNamara 2012-10-30 12:15:47 UTC
proposing for 3-6 given reports that it still crashes with latest duden
Comment 26 Not Assigned 2012-10-30 12:27:45 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=83be8c5b81feaf7e843898f4f6a1387c7ade183a&g=libreoffice-3-6

Related: fdo#47250 fdo#56430 catch harder


It will be available in LibreOffice 3.6.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 27 Marcus Hudritsch 2012-11-03 11:32:14 UTC
(In reply to comment #26)
> Caolan McNamara committed a patch related to this issue.
> It has been pushed to "libreoffice-3-6":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=83be8c5b81feaf7e843898f4f6a1387c7ade183a&g=libreoffice-3-6
> 
> Related: fdo#47250 fdo#56430 catch harder
> 
> 
> It will be available in LibreOffice 3.6.4.
> 
> The patch should be included in the daily builds available at
> http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> http://wiki.documentfoundation.org/Testing_Daily_Builds
> Affected users are encouraged to test the fix and report feedback.

I just donated 50 USD to the LibreOffice project and want to thank you all for your work. The Duden support is not that helpful. I spent more money on the Duden extension than on your project and you guys are reacting a lot faster. Thanks a lot!
Marcus
Comment 28 Caolán McNamara 2012-12-14 16:38:39 UTC

*** This bug has been marked as a duplicate of bug 58177 ***